? M1XIN problem


I had an alarm yesterday on my ELK. Water alarm and motions -- all of which are on my input expander. I called in (don't have internet access for elk yet) and got "alarm memory" but couldn't figure out how to get it to tell me what had caused the alarm. After acknowleging the alarm, Prompt 4 on phone reported "no zones violated" and prompt 5 reported "normal" (no trouble messages. I cut off the alarm via phone (or it timed out, I'm not sure) but 10 minutes later was alarming again. By then wife was home and entered her code to silence it. She read the message off the keypad to me and that's how I found out the water and motions were violated. 10-15 minutes later it alarmed again. She turned the M1 off. When I got home I connected to check status and all the inputs on the expander were violated. It was receiving normal DC power, and all wiring looked good. Nothing has been touched inthe box for a week. System has still not been armed. After checking the wiring I went to the keypad and did an enrollment. After that the status was all normal. I checked the log, but only the startup when I turned it back on was there (I guess turning off the M1 erases the log?)
Today, at the same time (I think) it alarmed again, same message. I've yet to see if it reoccurs after acknowleging alarm with code. Now today the electrician was turning on and off breakers to lable the panel but I have full battery back-up, so I didn't think this would cause a problem.
Any ideas? Is there any way to check to see if the M1XIN is functioning properly?
I would try killing power to the panel to see if you can duplicate the problem. It sounds like you are losing power, possibly because of the electrician, and your battery backup is not powering the M1XIN. You could try re-enrolling the M1XIN. I would also recheck the power connections to the M1XIN.
A follow-up and another question:
Killing the power had no effect, the battery backup worked fine.
I checked out all the wiring, pulled out all the wires and checked the wires for continuity, rewired the input expander and checked wiring on contacts for continuity with power off, then checked voltages with power on. All OK and seemed to be fine. Then again I got the same "input 2 expander missing" message and tried to do bus enrollment but would not enroll the M1XIN. Later working fine with no changes to wiring, then again getting same errors. Today I also got the "output expander missing" message.
I have these two expanders wired per info from Chris RM in this post: [post="8021"]Can I wire it this way?[/post] both powered through aux power source through the extra 2 wires on the data base hub. I went back through the power wires and reconnected everything and was able to re-enroll both expanders and they seem to be working fine. Then back in the panel I noticed when I rewired, I left out the wire that tied the neg from the M1 to the Neg of the P624 (aux power) I had run it from the neg of the Vaux to the neg connection from the P624 where it ties into the database hub extra wire I am using as the negative for the expanders (Is this clear to anyone?)

So, since the outputs and inputs seem to be working fine without the connection, I am leaving it off for now. Do I need to "common up" these two power supplies and if so was I doing it wrong??
Thanks rfdesq and others
If the auxiliary power supplies should be turned off and the M1 power is on, any burg zones will become violated. Turning power off to the M1 does not loose the log.

If the input expanders will not enroll, something has happened to the data bus or input expanders.
Thanks Spanky,
I guess the log was just full as I had a ton of lines that showed input expander 2 problems and it did not go back far enough in the memory of the log to see the earlier events.

As noted in post above, the expanders do enroll now that I removed the wire that "commoned up" the two power sources. 18 hours and all is still well and functioning properly.
But does anyone know if I need that extra wire and if so how did I have it hooked up wrong?
All the power supplies negative's should be connected, otherwise the data bus may not work correctly.