• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

M1XSP & PowerLinc hookup

MrGibbage

Active Member
I am trying to get my Insteon system up and running. I have added the M1XSP and enrolled it into the Elk. I have flasked it with the Insteon firmware using the ElkRP software. Reading the instructions for the M1XSP, I have two shoices for programming the M1XSP: option (1) is if the timeCoreApp is installed on my PowerLinc, and option (2) is if it isn't installed. I didn't know if it was installed, so I grabbed the SALAD Downloader and tried installing the timerCoreApp, but all I ever get is an error that the PLC coulodn't be found. I hooked up the RS232 DB9 -> RG45 directly to the PowerLinc (using the same serial port as for the ElkRP). I tried different baud settings, but still had no luck. Furthermore, I tried linking the SwitchLincs in my house to the PowerLinc, but I don't think I was doing it right. The bottom line is, I need help.

Now, the way I understand it, when this is up and running, my PC will be connected to the Elk using the serial port on board, and the M1XSP will be connected to the PowerLinc using the RG45 ->DB9 serial cable. Please correct me if I am wrong.

Can someone please give me step-by-step instructions on
(1) How to link SwitchLinc to the PowerLinc (btw, I do have a pair of signallinc installed)
(2) How to enroll the switches into the M1XSP.

Skip
 

Spanky

Senior Member
WayneW is right. The easiest way to administrate Insteon switches into the M1 is with PowerHome.
 

MrGibbage

Active Member
I suspect that with the problems that I am having, I doubt if using that software would help. It seems that my M1XSP and PowerLinc aren't talking to each other. Howver, that software does look really cool. Does it just use the same hardware configuration I already have--M1G/M1XSP (flashed to 50.0.22)/PowerLinc all over Insteon? So basically, this is an alternative to ElkRP???

Skip
 

WayneW

Senior Member
No, it is not a replacement to ElkRP. But it will help determine if your 2414s is bad.

You can use PowerHome to:
  • link all your devices to the 2414s,
  • then you connect PowerHome to the serial port of the XSP and blast your device list into the XSP,
  • then you add the names of your devices into ElkRP & configure them as using serial expander
  • then shutdown PowerHome (unless you have a second 2414)
  • then connect the 2414S back up to the XSP
  • then use the Elk to control your Insteon
At the moment PowerHome doesn't support the Elk M1 itself, but in the future it is supposed to be able to connect directly to the M1 and make all this easier.
 

MrGibbage

Active Member
Can someone who has a working PowerLinc + M1XSP controlling Insteon switches please tell me what version and revision their PowerLinc is? Mine is Rev 1.9, v1.1. Everything I read says I need to have v2.12 or newer.


Skip
 

Digger

Senior Member
I had a Version 1.2 Rev 1.6 working with the M1XSP. As I write this I just switched it out for a newer one because of the recall. Now to see if the new one will work.
 

Digger

Senior Member
At the moment PowerHome doesn't support the Elk M1 itself, but in the future it is supposed to be able to connect directly to the M1 and make all this easier.

I can't wait for Dave to have the time to finish the connection of the M1 to Powerhome. I think that will help a lot.

I think I will spend some time on my Insteon this weekend. I am down to 2 working switches. Since I cant return the new ones in the boxes anyway I will swap them out and return all of the dead one.

Before I pull them out I am going to try a few things. I am trying to come up with a test fixture to save the time of swapping the switches out all of the time.
 

MrGibbage

Active Member
Recall??? I just got mine a couple of weeks ago. I tell you, I am starting to think the PowerLinc isn't doing it's job. I have tried disconnecting from the M1XSP and connecting it directly to my computer, and I have not been able to connect any applications to it, no way, no how. I tried the SALadDownloader, but have not had any luck with it. I just a get a "Could not communicate with PLC over port COM3" error. What baud rate should I set my com port to? Is there a way to update the firmware on the PLC? Do I need to send it back to SH? Do I use a standard serial cable, or do I need to use a null modem cable?
 

Digger

Senior Member
There is another thread that mentions the recall of some of the older powerlincs. I just got my new ones this week.

Some powerlincs can be dead out of the box. My USB one was. Never got it to communicate at all. Spent soooooo many hours on it and then gave up. The amount of time I have spent on Insteon I should have gone with something else.

SOMEDAY this protocal and hardware should be awesome. Until then........
 

MrGibbage

Active Member
Interesting. I just googled "powerlinc recall" and got about a dozen hits, and none of them mentioned a powerlinc recall. I did see a tread or two about apliancelinc recalls. Is it possible that you are thinking about that instead?

I too have spent a full week trying to get anything to talk to my PowerLinc, but alas, no luck at all :rolleyes:
 

Digger

Senior Member
DEFINITELY a Powerlinc recall. I just got mine this week. They are keeping it quite. Its on here somewhere burried in a thread about Powerhome and the Homeseer software (I forget what they call it).

Other thread
 

MrGibbage

Active Member
Well, mine is a 2414S with Rev 1.9, so mine is supposed to be fixed already. ***Sigh*** Is anyone successfully using a 2414S with Rev 1.9? I'm sure not.
 

BLH

Active Member
If you are using the Smarthome Device Manager 3. Most times it defaults to USB and has to be manually run to point it to the serial ports. The later versions of SDM3 also turn off HTTP access to itself by default. Has to be manually changed in the registry if HTTP access is needed.
I believe KenM's SetSHPort can also do the change in the Registry that SDM3 writes whan the port is changed. HW Rev 1.9 with Firmware 2.13 is the latest I have seen. In the USB model it is HW Rev. 2.0 with Firmware 2.13
 

MrGibbage

Active Member
I am using KenM's set port utility, and that seems to be working, but of course, overall, the system is not working. I know that Ken's utility is working because I see in the Device Manager widow the GetPort command returning COM3, and when I click on the link up upload any software, I get a "Could not communicate with PLC over port COM3" error.

How do I know if I need HTTP access? Or, can you tell me what registry setting it is, so I can just enable it to see if that is the problem?

Btw, my Device Manager shows version 1.00.116.116 in the title bar. I just downloaded it this week. Where can I get version 3?

Skip
 
Top