need help with m1xsp and thermostats


so I just got in a new m1xsp to integrate with my rcs zoned hvac system, but something's not working along the way, so I'm looking for help.. first off, I can connect the rcs to a pc via serial and poll it with A=1 R=1 and it'll respond back (I even used the cable that comes with the m1xsp to rule out the cable).. everything was set up as per the instructions in the m1xsp manual for rcs serial, mode set as 1,0,0,1 set to rs232 , and address 2 (tried address 1 as well) I enrolled it into the elk, and updated the firmware to 1.0.3x? (I forget the exact version, but its the latest... I set up the 4 rules and tried them out... however when trying to view the thermostats from the keypad it says t1 (thermostat1) 'not enabled' ... also when trying to view them from the m1xep it unit not communicating' from the climate tab.... the light on the actual m1xep alternates between a short blip and a long blip of light... which I think is normal...? (figure its communicating with the rcs maybe?) ... finally I tried hooking it up as a serial expander mode 1,0,0,0 baud 9600, and tried a rule to send text out the port, but received nothing from the port of my computer which I'd hooked it up to.... I'm stuck, is my brand new m1xep a dud even though it enroll's just fine ? did I miss something ? I tried searching for solutions, it seems sendero had the same problem but no solution was ever posted in his thread... any help is greatly appreciated.


I know that this is not going to help, but it will give you a good place to start looking.

There is a area on the keypad tht you need to goto and enable the Elk xsp. I will try to find it for you, but hopefully someone with a better memory will reply before I find it.

I am not sure about the version of your RCS thermostat, but other RCS versions use RS-485 between the thermostat control box and the M1XSP.

Make sure the jumpers on the M1XSP are set for RCS.

Does the M1XSP show up as an enrolled device in ELKRP or viewing the devices on the keypad installer menu 1 after enrollment?
got some new updates, but still not working... first off spanky I'm using a rcs zc6r (6 zone controller, the older model that uses ts15 and ts36 thermostats) it has the ability to use rs232 or rs485 directly from the main unit... I've since tried using the m1xsp connected to the rcs via rs485 .. but still showing up as not enabled via the elk keypad... I tried enrolling the m1xsp via the keypad and that goes through with no problems and it shows up on the keypad and in elkrp.. I read through the rcs serial protocol and I figure even if I can't use the rcs mode of the m1xsp, I'd be happy to just use it as a serial extender to pass on commands to the rcs to set the setpoint, etc... I'm using the latest version of elkrp, latest firmware on the elk, my two keypads, and the m1xsp and m1xep, so I'm kind of out of ideas what to do next... I'm gonna try looking for that possible menu item from the keypad to enable... but in the manual it just says the m1xsp needs to be enrolled... so that's all I've done to it and added the sample rules from the manual as well... will keep trying, keep the suggestions coming, thanks!
The M1XSP is not compatible with the ZC6R. The M1XSP does not support the zone code command (Z=data) that is used with the ZC6R.

The M1XSP will work with the ZCVx products that have the RCS protocol revision 4.3. The ZCVx products do not use the Z=data for zone information. Each individual zone is assigned its own network address.