New M1, Keypads, and ELKRP Software

opie

Active Member
Be careful with the new ELK RP 1.6.10. I disabled a rule and later tried to "receive to database" and got stuck in a dialog loop. The dialog said something like "Can not receive rules while disabled" and would not let me go on. The connection finally timed out and that ended the loop. This may be just due to my set up but I thought I would put it out there.
 

rfdesq

Senior Member
Am I going crazy. When I go to download the new firmware either ELK RP is missing or ELK M1 4.4.4 is missing. At this momemt ELK M1 is missing.
 

opie

Active Member
Spanky said:
If you downloaded ELKRP before 12 noon on Friday, Sept 8th, download it again.
That's probably it. I'll try again and report if I am able to dulicate.

Thanks Spanky.

See you next week at CEDIA!
 

rfdesq

Senior Member
elcano said:
Went there, three documents found M1XEP, M1SXP, and ELKRP, no M1 4.4.4.

Current documents 1 - 3 of 3
Name sort_none Updated sort_none
ELK-M1XEP ETHERNET INTERFACE - FIRMWARE UPDATE Ver. 1.2.2 (w/Release Notes)
07/13/2006
Firmware (version 1.2.2) and Bootware (version 1.1.4) for the Elk-M1XEP Ethernet Expander.

ELK-M1XSP SERIAL EXPANDER - FIRMWARE UPDATE Ver. 1.0.20 and 50.0.22 (Insteon) (w/Release Notes)
06/29/2006
- Firmware update for the ELK-M1XSP Lighting/Thermostat Interface & Serial Port Expander.

ELKRP SOFTWARE Ver. 1.6.10 (w/Release Notes)
09/08/2006
- Remote programming software for Windows PCs. Version is 1.6.10. This version is required for M1/EZ8 firmware version 4.4.2 or later.

- New users will need the FULL Install file.

- If you already have ElkRP Version 1.4.5 or later installed, you may elect to download the UPDATE file.
 

carry15+1

Active Member
With users reporting problems with upgrading their M1G's I've been holding back on upgrading. Is it possible to DL the entire new software set and install it in a separate directory - allowing me to go back to a previous version if I have problems?
 

Mike

Senior Member
I am pretty sure it does that by default, and this is how you can specify which version you want to install (or downgrade if appropriate). That is how I thought it worked, since I need to reinstall I'll see if I can prove that.
 

Spanky

Senior Member
Found out the problem. The M1/EZ8 download was taken offline late Friday due to a question on the EZ8 bootloader. Unfortunately the M1 and EZ8 was bundled together. It will be back up Monday.

Sorry for the inconvenience. :eek:
 

Steve

Senior Member
carry15 said:
With users reporting problems with upgrading their M1G's I've been holding back on upgrading. Is it possible to DL the entire new software set and install it in a separate directory - allowing me to go back to a previous version if I have problems?
Mike is correct. Put all your files in the Updates directory. When you are prompted to update the firmware, all files in that directory are displayed so you can easily choose an older file to back up. RP is also smart to know if you are installing a new version vs reprogramming with existing. Don't know about an older version since I never went backwards, but I assume there is a notice for that as well.
 

rfdesq

Senior Member
Spanky said:
Found out the problem. The M1/EZ8 download was taken offline late Friday due to a question on the EZ8 bootloader. Unfortunately the M1 and EZ8 was bundled together. It will be back up Monday.

Sorry for the inconvenience. :eek:
Thanks Spanky. Thought I was either going crazy or I was caching a previous version of the site. Will the new KP firmware be back up then too, I don't see that either?
 
Top