new to HAI omni IIe ...troubleshooting (apple) app connection

HoustonHAI

New Member
Hello everyone!
 
I've tried to research as much as possible before posting, but I still haven't found a solution for my connectivity issues, so please go easy on me :)
 
I just bought a home with an HAI automation system, and when AT&T came to install a new router they did not plug in the router to the automation system (I'm assuming it needs to be connected to the HIFI2 Ethernet port for connecting wirelessly to my phone's app?). So I'm not even 100% sure if it's possible to connect at this time.
 
I am currently using an iphone app called "Myro: Home" to try and connect to my home's automation system (omni IIe with omni thermostats, lighting, and HIFI2 home audio). I'm considering downloading NQlink or SnapLink as recommended by some older posts, but I want to wait until I am sure I'll be able to connect before spending the $25-50 on a single app.
 
I've gone through the instruction and install manuals several times and failed each time to understand how to connect to my automation system. I'm moderately capable when it comes to these types of things, but admittedly this is my first big leap into automation. 
 
1) I found my IP address, port, and both encryption keys from my alarm's keypad, but keep getting a "connection timed out" error in my phone's automation app.
2) I have not been able to figure if I need to connect my AT&T router to the system's Ethernet port, of if the router needs to connect to the CAT5 switch box.
 
Is there any recommendation for someone that needs help troubleshooting to ensure everything is properly set up? Has anyone else had issues connecting? Am I messing up some basic step that is somehow being overlooked?
 
Thanks in advance!
I'm sorry if this is such a newb question that it's a pain. 
 
P.S. Since I can only post once per day for now... feel free to PM me with any questions if it helps to get in touch quicker. Thanks!
 

pete_c

Guru
Welcome to the Cocoontech forum HoustonHAI.
 
Have a quick read to familiarize yourself with your new AT&T network and combo router/switch/WLAN and Firewall.
 
I assume you have the panel installer code and a copy of the configuration on a USB stick?  It sounds like you also have the HiFi 2 system in your home.
 
Next read the HAI installation manual again and configuration of the network connection via the Keypad that is probably attached.
 
You will need to configure the IP of the panel via the Keypad using the installer code.  Before doing this you will need to know the IP and subnet of your router.
 
All you need to configure is an IP on your panel that is on your configured router.
 
hxxp://knightsecurityinc.com/wp-content/uploads/2014/05/hai-omnipro-ii.pdf

Relating to your HiFi2 device I would suggest you read the installation manual.
 
I would suggest that you purchase the Leviton OmniPro installation program called PC Access. 
 
Read about it here.
 
hxxps://www.leviton.com/en/products/1105w
 
Before connection to any mobile applications you will need to have configured an IP on the panel and open a port (3389) on your firewall for external access.

Note none of the mobile applications can configure the panel.

 
There may be some folks here on the forum near your home that you can contract to help you. 
 

neillt

Active Member
As Pete was alluding to, it's most likely a problem where the previous owner had a network range that was not the default for AT&T... so the IP address isn't working with your new network.
 
Here are some basic steps you can try to get things connected.  (I am simplifying this down *significantly* to a scenario that is most common for a residential internet install)
 
Make sure both the OP II panel and the HiFi2 are plugged in to the network.  Then, take a look at an IP address of any device on the network (laptop, phone, etc) and see what IP it has.
 
Let's say it's 192.168.1.134.  What we care about are the first 3 "octets" of that address.  The 192.168.1.x part.  If that doesn't match the first 3 of what was programmed into the OP II, then they aren't going to communicate.  If you need to change the address, do that via the alarm keypad.  Most residential routers don't start assigning addresses until 25 or 50 as the last number, so if you pick something low (say 5) you will most likely be OK.  So now your panel is 192.168.1.5, or whichever three groups match your network.
 
Now, head over to a computer, and open up a command line (in windows go to the start menu and type cmd then press enter, for a Mac start Terminal in the "Other" folder inside your apps)
 
Once you have a command line open on your computer, type:  ping 192.168.1.5 and press enter.  Substitute the address of the panel into that command.
 
You should get back some lines that say "Reply from .....".  On MacOS you will need to hit Control-C to stop the ping.  As long as you got that instead of "Timeout" or "Host is Unreachable" or similar errors, it means you are now talking to the panel on the local network. 
 
Try loading up Myro with that panel address, with your phone on your wi-fi.  It should connect.
 
Once you get that far, then it's time to wade into reprogramming the HiFi2 and making remote access work.
 

HoustonHAI

New Member
neillt said:
As Pete was alluding to, it's most likely a problem where the previous owner had a network range that was not the default for AT&T... so the IP address isn't working with your new network.
 
Here are some basic steps you can try to get things connected.  (I am simplifying this down *significantly* to a scenario that is most common for a residential internet install)
 
Make sure both the OP II panel and the HiFi2 are plugged in to the network.  Then, take a look at an IP address of any device on the network (laptop, phone, etc) and see what IP it has.
 
Let's say it's 192.168.1.134.  What we care about are the first 3 "octets" of that address.  The 192.168.1.x part.  If that doesn't match the first 3 of what was programmed into the OP II, then they aren't going to communicate.  If you need to change the address, do that via the alarm keypad.  Most residential routers don't start assigning addresses until 25 or 50 as the last number, so if you pick something low (say 5) you will most likely be OK.  So now your panel is 192.168.1.5, or whichever three groups match your network.
 
Now, head over to a computer, and open up a command line (in windows go to the start menu and type cmd then press enter, for a Mac start Terminal in the "Other" folder inside your apps)
 
Once you have a command line open on your computer, type:  ping 192.168.1.5 and press enter.  Substitute the address of the panel into that command.
 
You should get back some lines that say "Reply from .....".  On MacOS you will need to hit Control-C to stop the ping.  As long as you got that instead of "Timeout" or "Host is Unreachable" or similar errors, it means you are now talking to the panel on the local network. 
 
Try loading up Myro with that panel address, with your phone on your wi-fi.  It should connect.
 
Once you get that far, then it's time to wade into reprogramming the HiFi2 and making remote access work.
 
 
Thanks for the info!
 
I got the IP on the alarm keypad to changed to the IP from my computer (and I changed the last digit similar to your instructions), but the ping still timed out.... I'm thinking there's an issue with the physical connection between my router and the HiFi2/OPIIe system.... On the pc board for both units (OPII and hifi2) there are Cat5 connection ports labeled "ethernet" and there's also a CAT5 switchbox. Here's an imgur link that might help give a better visual of how everything is set up... I'm assuming both of the ethernet ports should have cables running to my ethernet switchbox, and only one of the ethernet switchbox ports should have a cat5 cable running directly to my router? (when AT&T came to set up my fiber a few weeks ago they unplugged several cables so that might be one of the issues, the pic might help clarify).
 
https://imgur.com/a/lSIDBry
 
Currently, the yellow CAT5 cable runs directly from the hifi2 ethernet port to my AT&T wbg 210 router, and the ping times out.
Previously, the yellow CAT5 cable ran to the ethernet switch box (upper left corner of pic) and then another Cat5 ran from the switchbox to the router, again, ping timed out.
 
Im sure there is some small detail I'm overlooking, but It's hard to find what is misplaced, even with the hifi2 & OP IIe setup guides.
 
I'll be able to reply tomorrow, since this is a new account. If email is easier my gmail is texas airline pilot ....gmail with no spaces (mods if this is against the rules please let me know and i'll remove it)
 
any advice? 
 

pete_c

Guru
The HAI panel appears to be mounted upside down.  Typically the rows of terminal strips are on the bottom and RJ 12 / RJ45 port is on the top.
 
So do each wire one by one. 
 
Ethernet cables should be ==>
 
1 - LAN Switch ==> 1 Ethernet cable ==> ethernet LAN port on your AT&T combo router
 
2 - LAN Switch ==> 1 Ethernet cable ==> HAI panel - there are a couple of LEDs there that blink if connected to the switch.
3 - ===========> 1Ethernet cable  ==> HiFi unit
 
Check to make sure the power indicator is on the LAN switch and check the port LEDs are illuminated and or blinking.
 
Thinking the default subnet for your router is: 192.168.1.0 / 24 (255.255.255.0) which provides IPs from 192.168.1.1 to 192.168.1.254.
 
Connect a laptop via Ethernet cable or connect wirelessly. 
 
Look at the settings page on your router to see the IP of the router.  Thinking it will be 192.168.1.254,
 
Configure the IP of the HAI panel to an IP say 192.168.1.1 and your HiFi to 192.168.1.2

Ping both IPs 192.168.1.1 and 192.168.1.2
 
Also write down the two lines of encryption keys from your configuration and match the settings on your cell phone application.
 
This is what the keys look like:
 
ENCRYPTION KEY PT 1:6F- 1B- 26- A2- FF- D9- E4- 12-
ENCRYPTION KEY PT 2:65- 1A- 27- A4- FF- D8- E3- 11-

 
If connecting your cell phone to a the local wireless network configure the IP: 192.168.1.1 on the application Myro and see how it works for you.
 
On the router / firewall then open port 3389 from the internet to the IP 192.168.1.1.  Set it for TCP/UDP.
 
Yes here learned to fly in the early 80's (Cessna 152 / 172's.) and then stopped 'round 1989 or so.
 
Worked for an Airline from the 1990's to 2000's (IT stuff) and managed the SITA/Equant/Arinc accounts for a bit. 
 

HoustonHAI

New Member
pete_c said:
 
Check to make sure the power indicator is on the LAN switch and check the port LEDs are illuminated and or blinking.
 
Thinking the default subnet for your router is: 192.168.1.0 / 24 (255.255.255.0) which provides IPs from 192.168.1.1 to 192.168.1.254.
 
Connect a laptop via Ethernet cable or connect wirelessly. 
 
Look at the settings page on your router to see the IP of the router.  Thinking it will be 192.168.1.254,
 
Configure the IP of the HAI panel to an IP say 192.168.1.1 and your HiFi to 192.168.1.2

Ping both IPs 192.168.1.1 and 192.168.1.2
 
Also write down the two lines of encryption keys from your configuration and match the settings on your cell phone application.
 
This is what the keys look like:
 
ENCRYPTION KEY PT 1:6F- 1B- 26- A2- FF- D9- E4- 12-
ENCRYPTION KEY PT 2:65- 1A- 27- A4- FF- D8- E3- 11-

 
If connecting your cell phone to a the local wireless network configure the IP: 192.168.1.1 on the application Myro and see how it works for you.
 
On the router / firewall then open port 3389 from the internet to the IP 192.168.1.1.  Set it for TCP/UDP.
 
Yes here learned to fly in the early 80's (Cessna 152 / 172's.) and then stopped 'round 1989 or so.
 
Worked for an Airline from the 1990's to 2000's (IT stuff) and managed the SITA/Equant/Arinc accounts for a bit. 
1) Good catch on the HAI mounting... I flipped the image upside down so it would be easier to see for everyone.
2) I got the OPII and hifi2 ethernet cables properly positioned per your instructions. (thanks for that clarification!)
3) I was able to successfully set my keypad IP to 192.168.1.1 and also successfully ping the keypad
4)***I am assuming the only way to set the hifi2 IP is through the PC Access program? ..I have this program on an old HAI tablet but the windows 10 OS seems to be unable to connect to my router. I have a macbook and imac so hopefully I'll be able to run PC Access via an emulator... is there another way to setup the hifi IP address?
5) related to #4, I am currently unable to ping the Hifi2 because I haven't setup it's IP.
6)encryption keys are written down
 
Continued problems:
7)I copied the keypad's new IP address (192.158.1.1) into Myro and i'm still running into a timed-out retrying..." error message. I have tried with both 3389 & 4689 as the Port.
8) I think my Port forwarding setup might be an issue for me. I've never setup port forwarding before, and I tried to create a custom port in my router's settings but I am unsure if I successfully set this part up.
 
Thanks for the help so far! I really appreciate all of y'all being so patient with someone new like me.
 

pete_c

Guru
Good news.
 
**I am assuming the only way to set the hifi2 IP is through the PC Access program?
 
Not sure as I have a Russound connected to my OP2 panel via serial port. Manual for HiFi2 should be able to help you.
 
Google HAI HiFi2 installation manual.
 
Connect your phone to the local wifi network and try again.  You should be able to access your panel.  I am not familiar with the Myro application.
 
 
There should be a tab on your router configuration for configuring a through port.  It be listed as games or something similiar.
 

rumb

Member
Verify that your att router is 192.168.1.0.  Many routers it's 192.168.1.1 probably safer to pick a number higher up like .100 for Omni.
 
Log into your router and you can see whatever is connected to it.
 

HoustonHAI

New Member
rumb said:
Verify that your att router is 192.168.1.0.  Many routers it's 192.168.1.1 probably safer to pick a number higher up like .100 for Omni.
 
Log into your router and you can see whatever is connected to it.
 
my router's ip is 192.168.1.254 so I set the omni pro's keypad to an IP of 192.168.1.1 and when i find a way to access the hifi2 I was planning to set it to 192.168.1.2
 
I'm also in the process of learning how to set up port forwarding on my AT&T router. It doesn't seem as straight forward for me, but I'm still learning. 
 

HoustonHAI

New Member
UPDATE: I got the alarm/lights/thermostat working!!!
 
Now I just have to get the hifi2 system up and running and the camera for the entry door as well... The home came with an OLD tablet running windows 10 with the hifi2 software, called "PC Access", unfortunately the tablet is so old (imagine an ipad that weighs 8 pounds and is almost 2" thick) that it doesn't even seem to be able to connect to my router at all (ATT won't support windows 10 troubleshooting anymore)... so I'm guessing my only way to get the hifi2 system up and running is via imac with a windows emulator.
 

pete_c

Guru
Good news!!!
 
Guessing your "AT&T wbg 210 router" is an Arris BGW210-700.  This is how I originally guessed that your router IP was .254 as that is the default for this modem.
 
You probably already have the manual but here is a PDF of it any how.
 
hxxps://fccid.io/PGRBGW210/Users-Manual/User-Manual-3205200.pdf
 
Change the xx's above to tt and you can view or download the manual. 
 
That said you can also call AT&T for service and tell them how you want to configure your router.  I am not sure if they would charge you to do this or not.

When I had Comcast turn up my Internet on a new home in Illinois I gave the technician permission to check the line and I did the rest of the installation myself. (early 2000's).

In FL new home went from Verizon DSL to Fiber I worked with the installer and did most of the installation myself as I had run Ethernet throughout the house during construction. The technician was nice but methodology was mickey mouse (not sure how trained he was).
 
It's been a couple of years that I helped a family with their OmniPro 2 panel configuration near Tampa, FL. 
 
They only used MACs so using Teamviewer I installed Oracle Virtual Box on their most used Mac in the house.  Then I installed a copy of Windows XP (or XPe) on their MAC.  Very easy to do this. Take the license from the old tablet and download an old ISO of Windows XP / XPe.

The Mac with the XP Virtual Box worked fine with Leviton PC Access Dealer Version (which they purchased) and Upstart (UPB configuration program which is free).  Mostly I was trying to teach the wife how to use PCA and Upstart to become self sufficient.  I reorganized their configuration on paper and sent wife a copy of redo.  She did it all and that was that.
 
Top