Newest Insteon Firmware


Senior Member
I took it upon myself to upgrade my firmware for the elk and xsp devices and the xep tonight. Everything went smooth, except for one thing: relinking my insteon devices. All settings were put back to the elk and there are no conflicts.

Everything connected should be at the latest revisions, and my second serial expander for the insteon devices is at 50.0.22, harware 0.3 and bootware 1.0.1

My problem is I go to put the m1 in linking mode (light 256 on) and then try to link insteon devices like the past by touching the up paddle for 10 seconds until it blinks. I tried 3 different insteon devices in different parts of the house and recieved no change in blinks at the xsp (still no delays in blinking, just steady on/off.

I also tried turning on/off the first light to make sure I just wasn't seeing the lights properly.

Anything I might have missed? I had this working reliably and had been able to add all my devices previously.
Insteon application firmware 50.0.22:
1.) Added support for “Powerhome†software (available from: Powerhome can now be used for programming and managing Insteon address IDs in the M1XSP. This includes: reading Insteon address IDs from the M1XSP into the PC software, and reading (discovery) of the M1 Lighting device names (text) which are stored inside the M1 by way of the M1XSP. This process requires a direct serial port connection directly from the PC to
the M1XSP, temporarily disconnecting the M1XSP from the Insteon Powerlinc 2414s.
4.) Added a text string “LINK^M†to be transmitted from the M1XSP to the M1 whenever the link mode is activated (lighting device 256 ON) and a valid link is received from the Insteon Powerlinc 2414s. This is helpful during the
manual linking mode. An M1 rule can be written to blink an output, make an announcement, etc. whenever a new device is linked into the Insteon Powerlinc 2414s. Be certain to program this exact text into the ElkRP Automation/
Text string locations in order for it to be available in the rules engine.
5.) Improved the receiving of certain commands from the Powerlinc 2414s during the manual link mode.

If you haven't already, try resetting the power to your M1XSP and then go into the light 256 method. Also for troubleshooting, use ELK-RP to add the text string "LINK^M" (without the quotes) and add a rule to fire a voice message when the string is received from the M1XSP (port X). The "LINK^M" string is now sent to the M1 whenever the M1XSP sees a link command from the 2414S. The M1XSP's LED should also do the 3 blinks.
Here is the link to the last beta version of the PowerHome Elk Insteon programmer: I am working on a few changes that I thought would be done last weekend but a harddrive mishap kind of sidetracked that.

Anyways, the beta is fully functional and should help anyone in uploading their Insteon devices into the M1XSP. The current beta requires PowerHome to be installed (just copy the executable to the PowerHome directory) but the next version will run completely stand-alone.

If anyone has any problems or questions, feel free to post them here.

I have not had a chance to check out powerhome since we had the baby, but I did find a new symptom: When I came back from the hospital, a light in the kitchen would be on, and the bathroom fan upstairs would be on. These are switchlinc v1's that have not been replaced yet by insteon.

I thought this was interesting so thought perhaps the format value in lighting got reset and that was my issue. Unfortunately it still showed serial expander.

I found the coincidence too odd and traced out which rules I had running for insteon devices. Among them were A6 and A14. I took out my maxi controller and try x10 a6 and x10 a14 and miraculously I was able to reproduce the issue (well sort of).

It seems that the elk is sending out x10 rather than insteon. Perhaps I need to reflash the device? Could be an exception that was missed in testing as the insteon data was reset by the flash upgrade and I was not able to relink devices so perhaps it falls through to sending x10.

Amusing that the one time the light controls arent working is the one time it would have been more useful (with her in the hospital and me coming back late).

If anyone has any further ideas given this new symptom, I am trying to figure out how to take this further.

I went back and had it display the firmware, which gave me:
expander 1 1.0.20 hardware 0.3 bootware 1.0.1
expander 2 50.0.22 hardware 0.3 bootware 1.0.1

so that looks right (wanted to rule out it being flashed to 1.0.20 for example, but I thought I checked that originally as well).

I have reflashed the second expander and will try to link it again tomorrow. I will add the new LINK^M stuff too. I plan on looking at Powerhome as well, but it looks like I am having other issues right now, and that may complicate this (or will it provide further information?).
As an update I tried linking insteon devices to the reflashed expander and was not successful.

I'm going through the documentation and release notes to see if I missed anything.

I may try reverting back to an older firmware and seeing if I can link it and then start over. I am also going to try powerhome but my symptoms seem to point to a more basic issue (although I like the computer based linking).
Ok I had more energy and took this further: I rolled it back to the previous version 50.0.18 I think. No dice. It still seemed to trigger insteon devices.

I reflashed it back to the latest and power cycled the Elk. I tried to relink insteon devices and it worked.

The one thing that I did not test, but perhaps might have been related was if I flashed the expander and then still had elkrp connected and tried to link devices, would it fail? I am not sure if I disconnected before trying to link devices. In the last instance I was sure to disconnect before trying.

Unfortunately I already linked devices before I thought of this so I have not tried to test this yet (although maybe once I play with powerhome and it is not such a pain to link individually I will try to see if this was the issue, as it should be able to be repeated if so).

In regards to power cycling, I know I tried that twice earlier on, so I do not think that was the issue.
Ok for the sake of 'science' I reflashed the firmware to see if ElkRP being active could have been related. It was not, I reset all of my insteon devices while connected.

I am going to guess rolling back, power cycling and then reflashing and power cycling must have corrected whatever issue I had. Included in case anyone else has a similar issue.

My system is all back to normal now.
I am having this exact sam e symptom. I cannot link any devices to the M1XSP/PowerLinc. All I ever get on the M1XSP is the same slow steady flashing light, even when setting device 256 (I also tried 255) to ON, and starting the linking process with my SwitchLincs. Mike, can you look up two posts from here (Jul 3rd, 12:21AM). You said "No dice. It still seemed to trigger insteon devices." Did you mean "X10 devices"? And then you said "I reflashed it back to the latest and power cycled the Elk. I tried to relink insteon devices and it worked." Do you mean you flashed it back to a non-Insteon firmware? You lost me on that one.

Did you try using the software that dhoward offered? I downloaded it, but haven't tried using it yet.

Hmm sorry I did not post the final to this, I thought I had. It has been awhile but this is what I did (roughly):

Reflashed the Elk or Ethernet expander (or XSP) to a prior boot loader setting, and redid the flashing operations. That seemed to work. I'm travelling on business so I don't have the screens in front of me, but that is what I did. It took a few steps I remember, and I am pretty sure it was tied to the Elk portion.

I did not realize I did not post this originally. I hope this helps.

If this does not get you setup, post again and I will try to look at it when I get home. I think it was downgrade boot loader code on the elk, down grade firmware, and then reload the newer items (or something along those lines).
You had two questions: Regarding Powerhome, I did begin trying it and was able to get it working partially for linking, but I seemed to get a lot of 'noise' in that I would get undefined blocks that had all the items in them, or bits of garbage that would never update.

My trial had ended, and dhoward offered an extension but I have not had time to go back and look at it. I was focused on getting the linking working reliably at the time and never got to downloading to the elk. I have seen that he has a new release and that it was supposed to have a lot of improvements. The interface looks much better, but that is about as far as I have gotten to date.

It is much lower on my priorities right now but if I get to it I will definitely post my results. There seems to have been a lot of progress. I wish I could say the same about my own setup, I still need to spend some time and get CQC running (I have a Fujitsu 3400 sitting idle!).
I flashed the M1XSP to 1.0.20 and back to 50.0.22 and I still don't get the three flash sequence. Anything else I can try?
I think the controller was included with what I did.

Try this (based on what I remember doing to get this working, it is unknown if some of these steps are not really required):

Downgrade the controller to Ver 3.2.2 (BOOT_M1G_3.2x to 3.2.2.bin)
Let it reboot.
Upgrade the controller to the latest version (I have 4.4.4 but I think I may have upgraded since the patch we are discussing).

Then go and update the M1XSP to the latest. I can't remember if I downgraded the XSP as well and then back. So if the above steps don't work you might want to add that into a subsequent test. I mainly remember redoing the main controller.

I hope this helps. My log does not go back that far so that is no help, and I redid my computer since then so any local logs are gone as well (if there is such a thing).