• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Omni IIe and snaplink

Bob22

Member
Hi, was not able to connect remotely for the past 2 years since I changed my modem/router. I am trying now a new router, TP-link Deco and have same issue. I can't forward a port, as the router does not see the panel. I tried to change the ip address but it doesnt help. The only reason to do so is to be able to connect with SNAPLINK, although reading other posts, not sure if this app still works
 

pete_c

Guru
Welcome to the Cocoontech forum!!

I am using Android and Windows Snaplink with no issues.

What is the MFG and model number of your Modem Router?

Personally here use OpenVPN server on my router / firewall here and an OpenVPN client on any external to my home network device these days.

This allows me access to my OmniPro 2 panel, CCTV, Automation servers et al on my home network with no open ports on my firewall.
 

dwalt

Active Member
Hello @Bob22,
Please provide some more information...
What is the ip address you are assigning to the Omni IIe? What is the ip address of your router?
When you hook a data cable to the Omni IIe, do the leds next to the data port flash?
If you have a PC on your house network, what ip address does it have?
Can you ping the ip address of the Omni iie from your PC?
dwalt
 

Bob22

Member
Thank you for responding. I assigned an IP is 99.243.70.100, which is close to the public ip. I also tried to assign 192.168 type ip, similar to the other devices on the network. I am not a computer guy, so dont understand well the different terms. However, support individuals from the internet company and best buy, didn't know what to do.The less next to the data port flash. I am trying now a tp-link Deco-X50. I have a vpn option on my phone and computer, but not sure how to install one on the modem
 

dwalt

Active Member
Ok, We need to sort the ip address out first. Start with the ip address on a pc at home. Do you have a pc?
If so, type "command" to open a command prompt window then type ipconfig. Your ip address will be displayed.
or You can download advanced ip scanner from here:


This is a simple program that lists all the devices on the network. From this we can see your ip addresses and see if your Omni 2e is visible on the network.
 
Last edited:

Bob22

Member
I am still confused with the ip address. If I type on the computer "what's my ip" google will show my ip address as 99.243.70.228. when I type ifconfig I get the IPV4 address which is 192.168.68.59
Omni 2 is not visible even though there is light near the cable connection. Interestingly, when I connected my old PC to do that, it did not initially connect until it "fixed" its connection to the router.
 

ano

Senior Member
The 99.243... is your EXTERNAL IP address provided by your Internet provider. This IP address likely is changed every so often. Sometimes yes, sometimes no. Unless you have Business Internet, assume it can change. This is what Comcast, Cox, etc. supplies to YOU.

The 192.168.68.59 is the LAN IP address set by your router. It may or may not change, depending on router and PC settings. Your HAI panel will have an address of 192.168.68.X. You set this manually on your HAI Keypad. On your keypad press 9, your PIN, then 6, then down arrow once, I think, until you see an IP address. Is it what you want it to be? Say 192.168.68.100.

Now you need to "open" your HAI port, at the HAI IP address to the outside world. What router do you have? Since your EXTERNAL IP address CAN change, most people find using a dynamic DNS service to help. This will let you find your external IP address so you can connect to it easily.

Probably enough here to get you started.
 

Bob22

Member
Thanks Ano. yes, I have set the ip address as you suggested, which is within the range of my router, but can't open the port. I have used dynamic DNS previously, but since my ip change only a few times a year, that a minor issue now. First I need to figure out why I can open port, i.e. HAI with the assigned address is not seen when I need to choose a device to forward a port.
So I think I am going back to my combo Rogers ignite modem, at least its one device.
 

pete_c

Guru
What is the MFG and model number of your Modem Router?

To make it easier you can configure your new Modem Router with same subnet, IP, DHCP scope as your old router.
Just connect a laptop to the ethernet port of your Rogers modem (nothing else) and log in to the web gui to get this information.

What is the local IP of the Omni panel? Post a ping from any device on your home network to your OmniPanel?

Look at the configuration of your router and do a copy and paste here ==>

IP: router or gateway IP
Subnet: typically it is 255.255.255.0
DHCP Scope: range of IPs used for DHCP

The OmniPanel does not run a DHCP client such that you have to pick an IP outside of the range used for DHCP on the router.

You may have to adjust the range of DHCP.

Here is an an example of my OmniPro panel IP.

IP of panel here is 192.168.244.182

Code:
ping 192.168.244.182
PING 192.168.244.182 (192.168.244.182) 56(84) bytes of data.
64 bytes from 192.168.244.182: icmp_seq=1 ttl=64 time=0.556 ms
64 bytes from 192.168.244.182: icmp_seq=2 ttl=64 time=0.357 ms
64 bytes from 192.168.244.182: icmp_seq=3 ttl=64 time=0.464 ms
64 bytes from 192.168.244.182: icmp_seq=4 ttl=64 time=0.368 ms
^C
--- 192.168.244.182 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3063ms
rtt min/avg/max/mdev = 0.357/0.436/0.556/0.082 ms

Here is my DHCP configuration. It is small here. You can make it any size you want.

Code:
Subnet 192.168.244.128
Subnet mask 255.255.255.128
Available range192.168.244.129 - 192.168.244.254
Range From 192.168.244.240 To 192.168.244.253

Post your configuration here.

Here is my favorite online IP calculator which will help:


Baby steps:

1 - post your model and mfg of your router
2 - post the IP of your panel
3 - copy and paste a ping of the IP
4 - post the gateway IP, subnet, mask and DHCP scope of your firewall router

Your router may not be showing you the IP address of your panel because the panel does not run DHCP client.
 
Last edited:

dwalt

Active Member
Your router may not be showing you the IP address of your panel because the panel does not run DHCP client.
I agree. Thats why a ping from pc to Omni 2e or run advanced ip scanner to really see if the panel is on the subnet.
 

Bob22

Member
So I changed back to a different modem/router XB7 model TG4482A(XB7-C)
I assigned an ip to the panel 10.0.0.200
gateway address 10.0.0.1
subnet mask 255.255.255.0
DHCP range 10.0.0.2-10.0.0.253
PING 10.0.0.200 (10.0.0.200): 56 data bytes

64 bytes from 10.0.0.200: icmp_seq=0 ttl=64 time=40.925 ms

64 bytes from 10.0.0.200: icmp_seq=1 ttl=63 time=7.034 ms

64 bytes from 10.0.0.200: icmp_seq=2 ttl=63 time=10.838 ms

64 bytes from 10.0.0.200: icmp_seq=3 ttl=63 time=7.639 ms

64 bytes from 10.0.0.200: icmp_seq=4 ttl=63 time=7.388 ms

64 bytes from 10.0.0.200: icmp_seq=5 ttl=63 time=14.158 ms

64 bytes from 10.0.0.200: icmp_seq=6 ttl=63 time=12.655 ms

64 bytes from 10.0.0.200: icmp_seq=7 ttl=63 time=7.703 ms

64 bytes from 10.0.0.200: icmp_seq=8 ttl=63 time=10.676 ms

64 bytes from 10.0.0.200: icmp_seq=9 ttl=63 time=7.664 ms
 

pete_c

Guru
Great news @Bob22

Is the XB7 model TG4482A(XB7-C) modem you intend to use?

Have you port forwarded to new IP: 10.0.0.200?

Is it working now with SnapLink.
 

Bob22

Member
I intend to use this modem as this is a good combo provided by the internet provider, and the separate router was not helpful. I am far from snap link. Can't forward a port. How do you interpret the ping? I tried to add device with reserved ip, added the above address. Needed to add MAC address. with arp command, I received 0:7:a6:0:7c:d6 There are some numbers missing. I added '0'. Not sure it's correct. But after adding the device, it still dont show up in the list of devices to open port. I tried to create address outside of the range of the DHCP, but it doesnt let me
 

dwalt

Active Member
The MAC address is labelled on the Omni 2e. Its on a chip just below the data port and to the right.
The label says "MAC" then has 6 pairs of digits. mac label.jpg
 
Top