Omnipro II network connectivity


New Member
I've seen others post about a similar problem and I have not been able to solve it. 
I have an Omnipro II for the last 12 years or so. I was able to access the system through PC access since the last time I upgraded my network router (Linksys Velop) which connects to the internet through a charter modem. I have had a gigabit switch the entire time.
I cannot access through PC access, so I tried to ping the Omnipro II with no success. I have tried multiple cables, confirmed to work with other devices. The two little lights next to the ethernet port on the Omnipro light up solid and blink when I plug in the cable.
I have tried setting the IP address to different values through the HAI wall console ie.,, and with no success. I confirm I can ping other devices on the network, all with addresses 10.186.1.XXX. 
After reading about some solutions, I plugged an old Apple Airport Express onto the SWITCH and connected the Omnipro to the LAN port on of the Apple Airport Express. I can see the Apple Express in the DHCP table of my Linksys router, but I never see the Omnipro listed. I can also still not ping it successfully. I am at a loss. Any help would be greatly appreciated. Thank you
Welcome to the Cocoontech Forum @zoltanman. There are many users here on the forum still using the HAI Omni Pro panels.

Edited / updated this post at 1851 C time.

Warm reset the panel via the console keypad and
Disconnect the battery and transformer for a bit.

Reconnect the transformer and battery.

Plug in your laptop to the OmniPro Ethernet interface and ping it.

If you have warm reset the panel and still cannot ping the Ethernet interface then it may be a hardware issue and you will probably have to RMA the board to Leviton.

For intermittent Ethernet issues that have been documented here on the forum read this for a quickie micro router fix using a micro router fitted inside the Omni Pro media panel that has worked for me for a few years now.

Microrouter DIY for use with the Omni Pro Panel Ethernet port - HomeSeer Message Board

or connecting an old Ethernet hub might work for you.
Last edited by a moderator:
You could also try using an older 10/100 switch, but maybe that’s why you tried the Apple Express….  SJ
I tried the warm reset "erasing ram" from the console. I tried powering off and disconnecting the battery. Still could not ping it. 
I tried connecting a laptop directly to the ethernet port on the panel. I couldn't successfully ping it, but I also could not ping another laptop to which I connected directly. I tried both a straight and crossover cable without successful ping, so I don't know if I did this correctly. 
I saw the thread on the micro router fix, and honestly it just confused the heck out of me.  I tried to fumble my way through it by using an old Apple express router, but couldn't figure out how to set it up. The terminology just confused me when comparing it to the setup pages for the Apple router. I'm not sure what to alter. I'm hoping since I have this old router, that I could use it in the same way as the microrouter fix? 
However, there are several things confusing me about the setup.
For instance, my main network is The main router address is

In the configuration software, there is an "Internet" menu where I can where I can connect using DHCP or static. If I choose static, I could set the apple router to something like on my main network. The subnet mask is and the router address is (my main Linksys router for the network. There is a blank field called DNS servers: do I do anything with that? There is also a field for IPv6 DNS servers, which is blank as well, and suspect should be left that way.
In the configuration software for the Apple router, there is a "Network" menu where I can run that router in Bridge versus DHCP and NAT mode. Which one do I choose? If I choose, "DHCP and NAT", then I have 3 options for DHCP range which are 10.0.x.x, 192.168.x.x, and 172.16.x.x. What does this mean in terms of setting the ip address for the Omnipro? They are all different from my main network, Is this ok or should they be the same? Perhaps I have flexibility to change the network numbers for the Linksys if needed.
The next option on this page is port forwarding which I don't comprehend. The options for setting this up includes five separate fields as follows:
public udp ports:
public tcp ports:
private ip address:
private udp ports:
private tcp ports: 
what do I do on this page? 
It would be easier if I could attach some screenshots of the menus, but I can't figure out how to do that. I can also not post more than once daily right now, so that is why I am trying to include as much as possible into this reply. Thanks for the input. 
Right now if you cannot ping the Ethernet Interface at all on the OmniPro panel then you may have a hardware failure.
A router is a router is a router.
What you do is basically pass the traffic from the LAN side to the WAN side of the router.
The WAN (Internet) ports that I passed were the OP2 management port, 80 for the router LAN GUI and 22 for the router SSH use.
You typically want a static IP configured on your WAN side which will be in your home subnet.  IE: is the subnet is the subnet mask
You can make the WAN (Internet) static IP the same as the Ethernet configuration on the original OP2 IP address.
You can make the LAN address anything you want in the small subnet on the LAN side.  As long as the traffic is passed to the WAN side you OK.
Since the router is inside of your network you are not exposing the OP2 to the Internet no matter what rules you have set.
I would just configure them as public TCP/UDP ports.
The above noted if you cannot ping the Ethernet Interface on the OP2 then more than likely you have a hardware issue.
The "fix" is related to an intermittent issue which crops up on the OmniPro board.  A warm reboot would typically work making the board work for a time then over time will start to disconnect.
  • Network Solutions, Connected Home, and Home Audio products
  • Mon-Fri 6:30 AM - 5:00 PM Pacific Time
  • Toll-Free 1-800-824-3005, select option #1