OmniPro II randomly doing SYSTEM RESETs - help


I have OmniPro II controller running 4.0b firmware; with 2 additional 16-zone expansion boards; 4 Omnistat2 RC1000WH thermostats, one keypad.
Brand new home installation 3 years ago; worked perfectly for 3 years until 2 weeks ago. 
I've noticed multiple entries in the SYSTEM LOG with "SYSTEM RESET" messages.  Sometimes many in a row, over several minutes. 
But the OmniPro II controller was still working, and I could connect to it via iPhone app (both Haiku and SnapLink apps) and control outputs and flags etc.   The automation scripts would run as normal.
Now as of yesterday, again after a flurry of SYSTEM RESET messages in the LOG, the automation scripts are no longer being executed as expected.
I did a complete restart (unplug AC transformer and disconnect 12VDC battery backup for 10 minutes).  Plug power back in, and connected to controller as usual via Ethernet using PC Access program on Windows laptop;  all seems ok; system status = "System ok".
But automation scripts refuse to execute anymore.  Yet they all are still there per PC Access program.
iPhone apps connect as expected and I still can control things and settings as normal. 
But I need my automation scripts to run!
What should I do next to FIX this issue?
THANK YOU for helping me.
Houston-area, TX
Hello.  Its possible you might have a logic problem in your program, and until some combination of inputs occurs, it runs fine.  Start top to bottom and look for anything that might cause a loop or unstable variable.  If all seems OK, make a backup of your scripts in PC Access, then delete them. Add the first few back manually and see if they are working. If all is working for a few days, reload it all back and see if it keeps working.  If you don't have a hardware problem, which is not very likely, I would say 98% its a programming loop.  Really watch where many lines of code set and act on the same variable or switch. Like maybe if x is on it turns on y, and if y is on it turns on x.
UPDATE:  I have determined that the reason my OmniPro II controller had been doing SYSTEM RESETs... is related to its ETHERNET interface.  There is no hardware issue (as best as I can tell).
Upon disconnecting the ethernet cable from the OmniPro II controller, waiting a few seconds and then re-inserting the cable... the system began to operate normally.  
I did more digging and began to monitor my local in-house LAN traffic, using a Raspberry Pi running syslog-ng server with a USB memory stick in it, and configured my local router to send its syslog messages to the Raspberry Pi.
The resulting data logs showed that whenever my OmniPro II controller began to act up (ie SYSTEM RESETs)... I noticed also that one of my TVS... a SONY Smart-TV  (which of course is connected to my local LAN), was sending out hundreds of ARPs.   This was strange, and so I disconnected the ethernet from that Sony TV (which in fact is running an Android-like OS for its SMART-TV features, which I rarely if ever use).
My OmniPro issues have disappeared and all running as expected for several weeks now... before I was having lots of SYSTEM RESET messages every day.
So I thought I would share this update.
JFab Design said:
I have also heard the Sonos can cause issues with HAI panels with packet floods.
Please try to change IP for someday to know problem made by ethernet connection or not. Other reason above that I met, The power transformer need replace, It's seem working fine but when you turn on/off some device (LED lights is example) the current provide drop then make controller reset.
I have proven to myself several times that the OP2 is very susceptible to having SYSTEM RESET issues if its Ethernet interface has too much traffic and/or broadcast packets overload due to some other device on the home LAN.   I made some progress when I determined (using WireShark packet captures) that a Sony Smart-TV was causing some issues so I disconnected that TV from my LAN.   THE OP2 behaved much better.   However, another slew of SYSTEM RESETS occurred the next week, and yes I have 4 Sonos PlayBars and that also maybe caused some OP2 issues.
Finally frustrated enough, I have now COMPLETELY isolated my OP2 on its very own dedicated Ethernet subnet coming directly off my Ubiquiti EdgeRouter... its the only device on that LAN subnet, and sees NO TRAFFIC from any other devices, unless the traffic is destined for OP2. 
So far, the OP2 is behaving perfectly normal again.
Easier to install a microrouter between the OP2 Ethernet port and the rest of your network.
I posted a sticky on how to do it over here:

Microrouter DIY for use with the Omni Pro Panel Ethernet port

Works fine with my CCTV and Omnitouch screens and PCA and Homeseer Omni Plugin and Home Assitant plugin.

This is a band aid fix to the OmniPro promiscuous network port issue which takes down the serial bus and a bunch of other stuff on the OP2 panel.
I have posted on Cocoontech related to the network issues with the OmniPro 2 panel.
The ethernet port hardware and transport to the serial bus needs a redesign which I double that Leviton will ever do.
Have a gander here (under the HAI vendor section) to get the details about the issues.
I had similar issues with my OP2 and installed a router between it and the rest of my network (like was mentioned by Pete which solved the issue).  However, I received feedback from Leviton and Worthington Distribution (during CEDIA last year) that the issue might be having a 1000MB ethernet switch connected to the panel which can really only handle 10MB.  When they installed the OP2 at CEDIA (showing off Alexa stuff), they ran into issues and had to find an older switch to connect the OP2 as they knew about the issues.  I was doing some work on my panel and removed the router to test their theory.  At the same time, I configured the port on my network switch (that the OP2 is on) to 10MB with no auto-negotiation.  I left the router next to it in case I needed to go back to that setup, but it has been running for months without a single issue.  I know that some people don't have any issues, but likely may depend on what's going on in your network.... SJ
Yes before the bandaid fix of using a microrouter tried
1 - old hub
2 - an autonomous VLAN dedicated to the OmniPro2 network
3 - managed switch port set to 1/2 duplex 10Mbs
4 - cold reset of the OmniPro 2 to scratch and reprogramming the panel
5 - updating and downgrading firmware
1,2,3,4,5 did not work for me.  At the time I was between 50 and 100 network devices on the main LAN in the home.

It's been a few years back that I tested and probably a version or two of firmware levels back.

Will test again with current firmware as the current lan connection goes to a managed switch.

First sign of issues here was time going way off then disconnects on the Omnistat and finally network disconnects.
My guess, the ARP requests are causing the issue (possibly a watchdog timer or running out of memory). If you can put the devices either on their own network (VLAN perhaps) or the Omnipro on it's own network. You shouldn't see the issue any longer. You will need a router though.
Yes now here using ARP for monitoring of the new upgraded firmware WiFi devices.  I should really just leave it alone for time bean as I have no issues here.
I only changed mine because of having some other issues (completely unrelated) and thought I would try it out.  I did setup the port as 10MB/Full duplex/no auto-negotiation for my switch which is likely incorrect, but still works fine.   I agree that if it works, leave it alone!  SJ
Yeah played with this stuff for weeks a few years did creep up slowly and initially only solution was to disconnect the ethernet port.  (touchscreens were serially connected and they worked fine after this) and went to using PCA serially just to watch the bus.
There were a few Cocoontech members having the same issues.  Ryan wrote the original HAI Logger program to watch and reset the time on the panel.
On CT user sent his OP2 board back to HAI (or Leviton?) and asked that they fix it and they did.  Personally they told me they could not fix the issue when I opened a ticket with them.  Other users purchased new OmniPro boards.
When it was really bad and before the ethernet port would disconnect itself the time would go off hours in a day and that was havoc for my automation stuff.
Yes and here would have to change the IP on the panel to do this which really isn't a big deal as all the connecting stuff is still using the same old IP.