• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

OmniTouch Pro

CK_Omni

New Member
Hello! I am wondering if I could buy a OmniTouch Pro/Leviton License?
Some of my family hade OmniTouch installed in their home in 2015. But It has been discontinued and stuff like Cameras, Alarms And Lights don't work.(this is was a new house) I have OmniTouch the software but need a license. To test their system. A company called OneTouch/ili installed our system. There are almost no documents on my Type of OmniTouch (they are using a template) But I'm moving them to Home Assistant.
 
Hi,
Where did you get a copy of OmniTouch Pro? I’ve been trying to find a copy/download for quite a while!
Thanks,
Nick
 

pete_c

Guru
You need a valid license to run OmniTouchPro to first time authenticate for use. BUT the servers may not be up anymore for authentication.
 

pete_c

Guru
I originally purchased 2 licenses many many years ago then Leviton gave me a 3rd license when I called them about purchasing another license a couple of years ago.

That said I have been able to replicate my one OmniTouchPro running in Windows embedded to 15 touchscreen tabletops. Then using the OmniTouchPro designer can change each one to have a unique display.

After installation just shut off the Omnitouch application and copy out the installed directory and installed apps configuration directory. Using set up I can change the screen size and update and do see the same activated serial number on all of the devices. It's very primitive and was written for Microsoft CE and really hasn't changed since first app. I have tested it to work on Windows CE, Windows 95, Windows 98, Windows Vista, Windows XP, Windows 7, Windows 10 and Windows 11. It runs much faster than the Omnitouch 5.7e touchscreens. It runs nicely on my HP Elitepad G2's and HP X360 running Windows 11 and my Asus AIO made for POS running Windows 11. I have it running on my Ubuntu 22.04 Lenova Laptop with PlayonLinux. The embedded tabletops are running OmniTouchPro_CE.exe and the W2016 server is running OmniTouchPro_10Pe and OmniTouchPro_CE. Set up shows same registered serial number.

Did a test tonight installing new Omnitouch on a second W2016 server. Via RDP copied over the directory and config files. I ran Omnitouch

My customized Intel tabletops run with and EFI boot rom or with a Seabios X86 boot room and run Windows, Linux or Android. I like Windows because the tabletops also run MS SAPI voice fonts. Avaya / Cisco was selling these as VOIP with wireless handsets and Utilitiy companies where selling these to manage your Zigbee thermostats. (inside there is a DECT chip, Zigbee Chip, Wifi/BT, Gb NIC port and HD video chip). Easy to write to NIC ROM and Boot ROM. These were sold as cloud managed devices way long time ago.

They run Homeseer Touch primarily, then via a push button on the touchscreen run OmniPro Touch. I put an exit button on the OmniProTouchscreen to go back to Homeseer Touch.

Joggler-OmnitouchPro.jpg

Main running designer and example (to copy out) runs on Windows 2016 Standard server. I then RDP to it running HAI Designer to instance of OmnitouchPro running on the Windows 2016 server. Then I change the IP of the same design over to a running Omnitouch tabletop. I can change the screen size running the setup feature.

PlayonLinux-OmnitouchPro.jpg

I activated the three licenses a couple of years ago and it worked fine. I copied them around then and that worked. You can see the configuration basics in the configuration files. IE: IP of your panel and key code to your panel. When using HAI designer you just look for instance IP running and then upgrade it to any design you want.

VNC session to one tabletop (same as rest of them).

Here is an Omnistat screen created with HSTouch and the Homeseer Omni plugin. Here I have integrated HAI temperature / humidity sensors and 1-Wire temperature sensors (all over the house).

Never touch Thermostat and mostly just look at status.

omni-omnistat.jpg

Modded (cleansed) the Sonoff NSPanel Pro (480 X 480 display) to run side loaded apps. Runs Snaplink, Homeassistant, Homeseer Touch fine.
It is almost flush to a wall if I remove the back AC transformer. I have to test to see if it runs via a 5VDC connection.SonoffNSPanelPro-1.jpgSonoffNSPanelPro-2.jpgSonoffNSPanelPro-3.jpgSonoffNSPanelPro-4.jpgSonoffNSPanelPro-5.jpg
 
Last edited:
Top