OP2 lost Network comms


After YEARS of stability, I woke up this morning to find my OmniLink software would not connect to the house (I'm not there right now).  Thinking I probably had internet / router issues, I tried to remote into the PC I use to run PC Access from local network and was surprised it came right up.  I then ran PC Access on that (local) PC and could not connect from there either.
The only suspicious entries I see are in my router (Arris SVG2482AC connected to Comcast) device table:
  • 00:07:A6:00:A9:ED      in "Online Devices", connected to via Ethernet, BUT ALSO:
  • 0C:B6:D2:B1:8F:2F     in "Offline Devices", with a Reserved IP of !!!
I can ping and get responses, but I didn't record the MAC address of my OP2 was back when it was working, so not sure if what I'm pinging is actually it...
Also, I'm assuming I assigned .200 to the 2nd device (starting 0C:B6...) because I thought that was the OP2 at some point in the past.
One more thing: I have a Expansion Enclosure and I thought I remember that the ethernet cable actually plugs into it (correct??).
If so, does it have a separate MAC address from the OP2??
No one has been in the house since I last connected (yesterday).
I'll have somebody there this afternoon who can plug/unplug stuff to help me debug, but I need some ideas on where to start...
Thanks for any replies
The expansion enclosure does not have an ethernet connection.   Only the main board.   The expansion enclosure connects to the main board using a RS485 connection.   
Sorry, but I don't have any good ideas on your problem.  I hope you let us know what you find is the problem so we can be looking for the same if we experience this with our systems.
Leviton was still offering tech support a few months ago.   You might try them if nobody here has a solution.
Look for blinking LEDs near your network interface on the Ethernet interface on your Omni Panel if it is plugged in to the network.
If there is only one LED lite and the other one isn't blinking then it could be a hard ware issue relating to the panel or network switch or even a bad cable.
The with any PC on the network ping the IP of the OmniPro panel.
If your local PC can ping the interface then PCA should work fine connecting to your panel.
Outside your network your Firewall combo SB box should be set to an open port and Omni panel IP to the internet.
Do the following:
1 - Post the IP here of your Omni panel.  This IP should be in the subnet that your router uses for the internal LAN.
2 - Post the IP of your gateway (router) and subnet mask used on your home network.
3 - Then in a terminal window ping the IP from any computer on your home network and post the results here on the forum.
IE:  my OP2 panel's IP is
:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.576 ms
64 bytes from icmp_seq=2 ttl=64 time=0.415 ms
64 bytes from icmp_seq=3 ttl=64 time=0.460 ms
64 bytes from icmp_seq=4 ttl=64 time=0.431 ms
64 bytes from icmp_seq=5 ttl=64 time=0.413 ms
Note the only configuration related to your Omni on your router should be firewall settings for external access and nothing else.
There is no DHCP client on the OmniPanel.  It is a very simple connection. (well very primitive).
Here's my local network info:
   IPv4 Address. . . . . . . . . . . :          (of the OP2)
   Subnet Mask . . . . . . . . . .  :
   Default Gateway . . . . . . . . :
and results of ping/arp:

Pinging with 32 bytes of data:
Reply from bytes=32 time=9ms TTL=64
Reply from bytes=32 time=20ms TTL=64
Reply from bytes=32 time=22ms TTL=64
Reply from bytes=32 time=5ms TTL=64

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 5ms, Maximum = 22ms, Average = 14ms

C:\Users>arp -a

Interface: --- 0xc
  Internet Address      Physical Address      Type                f0-fc-c8-fc-bc-29     dynamic            00-07-a6-00-a9-ed     dynamic
I also confirmed that the mac address returned by arp (00:07:a6:00:a9:ed) matches the sticker on the network chip inside the OP2.
(Note that my router THINKs the OP2 is a DHCP client (even though we know it's not) because I never set a static IP for it, but since it responds to pings (and presumably other packets directed to that address), the router is happy to add it to it's "Online Devices" list).
So everything looks good from the router (and PC issuing these commands) point of view.
Also keep in mind that I didn't change ANYTHING network-wise from when it last worked (yesterday) until today.
(I suppose Comcast could have made some subtle change (maybe with IPV6 stuff??) overnight but can't see how that would cause this)...
Can you tell me how to go about contacting Leviton tech support?
I'm guessing at this point I may have to break out Wireshark and see what's going on down at the packet level...
Good news
I woke up this morning to find my OmniLink software would not connect to the house (I'm not there right now).
Reboot your XFinity box first.  What is the model number of your XFinity box?
Are you using your internet IP on the OmniLink software or a dynamic DNS name when using PCA remotely?
Do a port scan of your internet IP using whatever free tool you google on the Internet. 
Try this one ==> hxxps://pentest-tools.com/network-vulnerability-scanning/tcp-port-scanner-online-nmap
The port scan show show the open port used for the Omni panel.
Now do a screen print of your firewall configuration that shows IP, Port of your OmniPanel to the internet.
Print or copy the screen print to the forum...block out stuff you do not want to show.  You should see IP and default port 4369 forwarded in your port forwarding rules.
You can test this disconnecting your phone from home WiFi and making it a WiFi hotspot and then connecting your laptop to your cell phone and running PCA on it configured to your Internet IP.
Have a look here at a post from 2012 ==> HAI Omni IIe remote access problems
Thanks for responding.
I included my gateway/router model info in my initial post:     Arris SVG2482AC connected to Comcast.
As I mentioned in that post, I was able to remote into a Windows PC I leave on 24/7 inside the house (using VNC), so all the rest of the testing was done on the local network (as if I WERE inside the house).  Because of that I don't think the internet facing stuff (public IP, DNS, port forwarding, etc.) comes into play here.
I did reboot the Arris with no change in the problem.
Next time I can get someone to go there I plan to try the following:
  1. Replace the network cable between gateway and OP2 (and maybe try a different port on the gateway).  However, the fact that I'm getting successful pings leads me to believe this won't change anything.
  2. Go into the OP2 network settings from the console and verify IP/Port/Keys, but again I don't see how those could have changed overnight...
The person who was physically there yesterday confirmed that the OP2 appeared to otherwise be working normally.  He was able to navigate the console menu, turn on/off several X10 modules and reset the alarm, so the problem appears to be ONLY with the local network comms.
Any other thoughts?
Because of that I don't think the internet facing stuff (public IP, DNS, port forwarding, etc.) comes into play here.
Correct for using VNC.
Yes for the inside stuff the firewall does not need to do any port forwarding.  VNC typically uses port 5000 so that is working.  
For the OmniPanel another port has to be opened on the firewall.  
Typically as you mentioned the firewall will not change by itself.  Do the internet port scan next to see what ports are open on your firewall.
You can do this from any PC outside or inside your home network.
IE: try it on your remote controlled VNC computer and then look at the firewall settings again from your remote controlled computer.
That it works fine from the inside of your network then your cables / hardware are fine.  It is a firewall configuration issue.
I'm not sure why you're still focusing on firewall issues: I'm NOT trying to connect to the OP2 from outside the gateway and there is NO firewall between my PC on the local network and the OP2.  As soon as I was able to connect to the PC on the local network via VNC, I got around ALL the firewall, port forwarding, external IP, DNS resolution -related issues and really just have the 3 devices: PC, router & OP2.
The fact that pings are working means that ICMP packets are traveling from PC -> router -> OP2 AND back, but for some reason when PC Access tries to send TCP packets on port 4369, the handshake is not working.  That's why I think I'm down to either intermittent hardware problem with router ethernet port or cable (I say intermittent because the successful pings are using the same hardware), OR hardware/software inside the OP2 itelf.
Thanks for the email; I'll shoot off something to them this morning.
 I woke up this morning to find my OmniLink software would not connect to the house (I'm not there right now).  Thinking I probably had internet / router issues
Are you referring to HAI Snaplink?  What is OmniLink Software?
All of the Leviton HAI software connects to the IP of the panel via Ethernet with IP / port  / keys settings configured on the software.
I assumed you were writing that it worked internally (LAN) and not externally(WAN).
I am thinking now that the only issue could be the settings in the OmniLink software which again are IP, Port and 2 line alpha numeric code.
Not a hardware or cable issue.
OmniLink is the "new" name for the NQLink app that runs on Android devices.
As soon as I saw I could connect to my PC INSIDE the network and run PC Access, I quit testing via "Omnilink (NQLink)" from OUTSIDE my network.
Not sure where you got that I was successful in connecting to OP2 from LAN and not WAN: I can't connect from either...
The only settings that I know of that are required for PC Access to connect from the same LAN are the IP (, port (4369) and encryption keys (not posting those for obvious reasons!) and AFAIK those have not changed.
That's why I think it must be a hardware or cable OR software issue in the OP2 itself...
OmniLink is the "new" name for the NQLink app that runs on Android devices.
As soon as I saw I could connect to my PC INSIDE the network and run PC Access, I quit testing via "Omnilink (NQLink)" from OUTSIDE my network.
I have not used NQLink or Omnilink on Android.    Yeah if PC Access works inside then your Omni Ethernet Transport is fine.
So you are saying you can connect to your inside PC but when running PCA you cannot connect to your OmniPro panel eh?
Not sure where you got that I was successful in connecting to OP2 from LAN and not WAN: I can't connect from either...
Apologies I though you mentioned that PC Access works fine on the inside of your network.
All of the software used for the OmniPro panel uses same transport same keys and same port.
If none of the OmniPro panel software works then it could be a transport issue.  
For those who are following along: I got someone in the house to:
  1. Confirm the OP2 Network Setup: IP Address, Port # and Encryption Keys: all items were correct (matched PC Access Network Options), so nothing there...
  2. Unplug the ethernet cable from router and confirmed that pings no longer worked.
  3. Plugged cable into DIFFERENT port on router and confirmed that pings once again worked.
  4. Tried a completely different ethernet cable.
I changed the IP Address in the Network Options to .201 (an unused IP); when I tried to connect, I got:
  •         Comm Status: Connection Timed Out    (10060)
  • NOTE: I also got this message when used the correct IP (.200) but the wrong port (4368)!
  • I then changed the IP Address to match a different (not HAI) connected device; when I tried to connect, I got:
  •         Comm Status: Connection Refused       (10061)
so far the messages are about what I would expect; I then put back in the correct IP Address (.200) and when I tried to connect, I got:
                  Comm Status: Retrying                          (100)
about every 15 seconds for 2-3 minutes; at the end of that timeout, I got:
                  Comm Status: Interrupted Function Call (10004)
It looks as if the OP2 is responding to the initial TCP Port 4369 request packets from PC Access, but then the negotiation breaks down (maybe during the encryption key verification???)
If anyone (w/Dealer PC Access) is willing to do a test to help me get a little further down this road, could you change the Network Options in PC Access and modify one of the Encryption Keys slightly so that they WON'T match the OP2 and then try to Connect and report back what message you get in the status bar at the bottom of the window.  If it's the same (10004) message, then maybe that's where the breakdown is occurring....
Thanks again for all the interest
There have been reported issues with the Ethernet port on the Omni Panel because it is using old technology 1/2 Duplex 10Mbs connection.
This causes disconnects and eventually no connnects to the panel.  The quickie band aid fix is to reboot the panel removing the battery and unplugging the power supply.  It'll work for a bit then eventually start to fail.  Did open a ticket with Leviton about said issue many years ago.  Their fix was to connect the Ethernet port to an old 10Mbs hub (not switch).
The fix is to route the traffic from the Ethernet port using any old router connecting the Ethernet port of the panel to the LAN port on the router and then connecting the WAN port of the router to the home LAN.  The IP of the LAN port is put in to a DMZ to allow all traffic.
Hi Pete - I wanted to chime in on this topic l, and to your last response specifically because Im facing essentially the same issue. Someone assisting me on this had looked at event logs I had shared from my phone as I was trying to connect to the snaplink app and having issues. they determined my google WiFi router was doing some weird packet detection and stopping communication.

I keep reading suggestions to workaround this by purchasing another cheap older router but Im unsure of how to set it all up. Was hoping I could get some help since Im not experienced with networking. Would I plug the omnipro panel into the old router then plug a cable into the old router and that into the google WiFi router? If yes, what other setup or configuration would be needed?