PFSense + Teardop (VPS) and OpenVPN

pete_c

Guru
It's only about using an OpenVPN client from the internet to your PFSense connected to Starlink / TMobile router.  
 
On home network VPN clients work fine out the T-Mobile router.  
 
I only use OpenVPN / IPSec clients today to manage home network (automation, OmniPro2, CCTV) stuff and have no open ports.
 
I have OpenVPN server, IPSec VPN server and Wireguard running.  I have not yet tried to test T-Mobile / Starlink with Wireguard clients.
 
I also utilize PIA and can use it with a static IP which might also work...
 

pete_c

Guru
18th of June, 2022
 
Still working on the free Oracle Cloud tear drop here.  Trying to keep it going by leaving the T-Mobile modem connected to the Oracle cloud.
 

JimS

Active Member
Finally took about a day and got my openVPN working again on Oracle and pfsense local box.  For some reason, inactivity I think, my openVPN instance on the Oracle server was shut down and it wasn't clear how to just restart it.  Ended up deleting that instance and installing a new instance of it which meant reconfiguring things.  For some reason I avoided the command line config earlier but had to do it this time.  Basically followed this:
https://www.youtube.com/watch?v=E-CLtExRzX8
 
After that on the server account for the pfsense box checked options for
 
Allow Access From:
all server-side private subnets
Allow Access From:
all other VPN clients
Then select yes for configure vpn gateway and enter subnet in the box
Allow client to act as VPN gateway
for these client-side subnets:
Something like  192.168.1.0/24 allows access to any 192.168.1.x addresses on lan.
download the ovpn client file and load it into the pfsense box as the openVPN config file.  
 
There are probably some things I could do better so am open to suggestions but that works.
 

pete_c

Guru
Thank you @JimS
 
Here frustrated with the configuration to Oracle on my test PFSense box.
 
Went a different route per suggestion of a PFSense forum user.
 
Cloud VPN Solution
 
Activated 3 free connections there.
 
Not getting any emails relating to purchasing anything right now.
 

JimS

Active Member
Well, it WAS working.  :(  Not sure what happened.  Fiddled with pfsense firewall rules - nothing.  Restored config from when it was working.  That didn't work either.  Frustrating.  May try the one you posted a link to.  Are there any detailed how tos for that?  I always seem to get tangled up in the details.
 

pete_c

Guru
So far it seemed easier to set up than the Oracle OpenVPN server.  I did not read anything.  Just set it up and downloaded ovpn files and it worked.  
 
That said I have an issue right now where I cannot see the internet when connected.  Give it a try Jim.  So far no email tickles relating to the OpenVPN service.
 
Top