PLEASE! Need some help with a domain that will not load.


Active Member
Hey guys, I have not posted on here in some time.  Normally I am the "go to guy" for all things PC, gizmo's and gadgets.  It sux when I have a problem, as there is no one above me in my local "chain of command"  LOL
I sure hope someone here has had an issue like this, has seen this and can offer some help. 

Anyhow, I designed using Drupal.  All has been going great for the past few months since I put it in place until just a couple of weeks ago.  For some reason the page times out when I try to load it like 80% of the time.  20% of the time it loads instantly as it should.
This is for the root of the domain page, any sub-page under that domain, as well as the /forum that is installed.  I am at the end of my rope trying to figure out why!
Here is what I have determined so far:
  • It is not an Internet connection issue, as I can load 20 other sites in other tabs, while that one is still trying to load.
  • It is not a server problem in any way, as 6 other people I have called, can load the site time and time again and have no problems or lag in any way
  • it is not a browser problem, as in addition to my default browser, Firefox, I have tried Chrome, IE and Opera.
  • It also is not a problem with my network, or between here and the server:  I can remote into my MediaPC in the living room and view or edit the site 100% each and every time.
  • It is not my host file, as I have removed all but the default entry for local loopback
  • It is not my antivirus, Avast! as I disabled it to test.
  • It is not Ad Block Plus, as I disabled it on the domain, as well as it is not installed in IE that I used also to test.
I have a basic DSL modem with 4 LAN ports.  I have the WAN port going to a 8 port gigabit router with 802.11N wireless.  All computers in the house are connected either through one of the 8 ports or via WiFi.  So this desktop is connected in the same way as all other devices in the house.
Oh, lastly, I restored an image of the machine a couple weeks back when this problem started, to a point before the problem, and that did not resolve the issue.
To sum it up, I can load the page fine from any other computer here in the house, except this one, my main machine.
This has me going crazy, and I have no clue what to do next!  I have googled the problem over and over, and followed tons of links, but I have found nothing like my specific problem.
Many thanks to any and all suggestions!
I use the following program on a regular schedule:
  • MalWare Bytes
  • AdAware
  • SpyBot Search and Destroy
  • CCleaner
  • TuneUp Utilities
When this happens, have you tried 1) Pinging the server during these down times; 2) tried other browsers at the same time?
Thanks for the response! Yes, I have tried other browsers on this machine all at the same time, and they all time out, again around 80% of the time.
As for pinging the server, yes I have tried that as well.  The server always responds to ping requests.   Matter of fact, I just tried something new.  I browsed to the page in FireFox, and while it was trying to load I pinged the server at the same time.  The server responded 3 different times I pinged it, all at the same time the browser was still trying to connect, and then eventually timed out a few seconds later.

Pinging [] with 32 bytes of data:

Reply from bytes=32 time=94ms TTL=46
Reply from bytes=32 time=94ms TTL=46
Reply from bytes=32 time=95ms TTL=46
Reply from bytes=32 time=94ms TTL=46

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 94ms, Maximum = 95ms, Average = 94ms

This is one mystery that I have struggled with for 2 weeks now, and have tried everything that I know.
It could be something else running on the computer blocking access?
I keep it simple on the PC (or Laptop) just running Malwarebytes and PandaAV.
Recently (days ago) I ran into an issue with the newest updated Java on my laptop.
It will no longer allow me access to my KVM.  Its some odd security thing with the newest Java. 
I would start by first removing:  (BTW this is not knocking your software - just cleaning your PC).
(I use Malware Bytes and CCleaner and Spybot).  I only leave Malwarebytes running and Panda. 
Note that you are just removing these for a short time.  I do most of the work these days on the PFSense firewall.
Take your time doing this.  You didn't mention what AV you are running.
  • MalWare Bytes
  • AdAware
  • SpyBot Search and Destroy
  • CCleaner
  • TuneUp Utilities
Once removed then go here and run Combofix:
This software will clean up your browsers and your PC and reset most defaults.
If you computer is infected then it will take a long time.  That said run it a second time for kicks.  It should run faster.
Then reinstall Malware Bytes and your AV.  You don't really need to do anything else.
I think Malware Bytes will also take care of any root viruses and or whatever you run for AV.
I have been using Combofix for a few years now and its always worked for me. 
I have also lightened the AV a bit and making the firewall do front line defense blocking just about everything these days. (I have tried).
Recently I was in an office looking at one PC used by said office owner.  While most of the computers were only utilized for the day to day stuff of normal work; this one in particular was used for accounting. 
I could see that IE, FF and Chrome were hijacked with just about every plugin available for these browsers. The owner was running AV and made the assumption that AV took care of all her needs; but couldn't figure out why the PC was so slow.  There are more PCs like this on the same network. 
I have suggested separating the "work" stuff from "play" stuff using autonomous networks. That and the firewall was left open at defaults for access to the accounting software; which really was done up by software centric folks that have no clue about networking and firewall stuff.  I have seen this now a couple of times in small businesses.
Can you create a static file with just some ASCII words (hello world?) on your webserver (example.html), and load it from within an Incognito/InPrivate session?
What happens when you go to the command prompt, and enter telnet 80 ?
Any chance you turned on parental filtering for a certain IP address in your router?
Can you try from another machine, BUT with the same IP address as the machine that's having trouble?
Have you tried from within Safe mode with networking?
Personally, I think you are dealing with some process or device blocking your HTTP requests.  This usually is a filtering process, such as AV / parental controls.
If you still don't get anywhere, we'll have to break out Wireshark.  I would be more than willing to connect to your system via and take a look at it, just need to let me know.
Pete, thanks for the info.  As for the Virus software, Avast, I did mention it in my first post, as it was one of the first thoughts that I had. 
     As for the software, I normally just use CCleaner and Malware Bytes.  The others, I downloaded, installed and tried to see if they could find something those missed.  Every one of the programs, ran with a through scan, found only one item, and thats that I have windows automatic update turned off.    I absolutely HATE bloatware, so finding "TuneUp Utilities" was a nice find for me.  It has a combination of utilities under the hood to clean the registry, delete temp files and old restore points, manage start up programs (Registry as well as start up folder), remove broken shortcuts and file associations, Advanced task manager with detailed information about any running process, and a few other things.
     I find it peculiar than the ONLY site I can not access, is one that I worked on using Drupal.  If you are not familiar with Drupal, it is a web based database driven engine for websites.  All of the editing is done in the browser. is a unknown domain name, that no software could possible be programed to block.
     I have downloaded ComboFix and will install and give it a go.  As for restoring browsers to default, I do not think that is necessary.  I installed Chrome and Opera both to test accessing, and on first run of both, newly installed, they could not contact the site.  This leads me to beleive it is not a specific browser problem.
    Lastly, you mentioned the toolbars on a work computer. I have NO toolbars installed on this PC.  Not Yahoo, Google, WeatherBug or any of the other thousand tool bars.  As for a firewall, I have a Firewall on my router as a first line of defense, then it goes into my router, with a firewall as well as a second line of defense, and then to my PC with Windows Firewall active.  I do not allow traffic on any 80xx port or on the standard FTP port 21.  Knock on wood, I have not had any malware, adware or virus's on this PC in almost 3 years.  Well, that I know of, of course ;)
Hey Dan!  Looks like I was replying to Pete at the same time you posted. I am 99% sure it is not a parental setting, as I haven't touched the router in a year or so.  Also, I can access the site 2 out of 10 times or so.  I will double check to make sure. 
As for telnet, the first time I ran it it responded immediately.  I ran it again and it timed out.  Same thing I get when using a browser.
C:\Documents and Settings\John>telnet 80

<title>501 Not Implemented</title>
<h1>Not Implemented</h1>
<address>Apache Server at virtualhost. Port 80</address>
Connection to host lost.

C:\Documents and Settings\John>telnet 80
Connecting To not open connection to the host, on port 80: Co
nnect failed

I will swap my IP addresses for the MediaPC and this one, and give it a try.... Good idea!
I will try safemode, and see how that goes.
Thanks for the ideas, and will post back with results shortly!
I've got nothing of substance to add for now, but wanted to say that problems such as these are always difficult to troubleshoot...
Knowing that it loads from other machines without issue suggests that the web server is functioning properly. The fact that you can only get to it 20% of the time from your machine, suggests that there is an issue with your machine; hardware or software.
Thanks for the post.... however I am one of those people when they get a flat tire, I replace the tire and don't just go buy a whole new car ;)
Heheh.  I will try everything else on the planet first, before formatting and starting over with this machine.  I have a perfect Acronis image backup with everything installed and fine tuned.  I run the machine about 2-3 months, and then reinstall that image to keep this machine in tip top shape, and running fast and smooth.
If the telnet command doesn't work properly, then we can eliminate any type of browser plugin (some malware components 'support' all browsers, so I wanted to make sure).
Either the IP address of your PC is being filtered, or the IP address of your web server.
You now need to unload as many components as possible, so booting into Safe mode with networking is the next step IMO.
If you have a Linux live CD, I would give that a shot as well (if it still happens, then it's probably your router), as it would help you figure out if a format/image restore would do the job.
Good luck, as frustrating as these cases can be, they can be fun to troubleshoot.
Yeah. I definitely agree, and am not the "buy a new car" type either. To add to that point, I had ~197k miles on my last vehicle, and have 114k on my current vehicle ;)
However, if I've done as much troubleshooting as you have, I'd be well on my way to backing up my data, and restoring from that image again and/or reformatting.
Curious what the outcome will be or what you have as issues.
Your thread and posts here will help other folks should they ever have a similiar problem.
I used to use Avast a while ago.  Not sure though which AV I used that would black hole a website (or IP); but there was one a while ago.
@ pete: Combofix did not fix this perticular problem.  I looked through the log file as well, and nothing stood out.  No red flags or andthing bad that I could see.  This machine, as I mentioned is pretty well firewalled, protected and routinely cleaned & scanned.
Glad about the telnet thing, that eliminates the browser(s) completely.
Leaving for work now, will give safemode with networking a try when I get home.
@Dan: NOTHING about troublshooting this is "fun" :)
EDIT: Posting at the same time again:
@Pete, I am reletively certain that it is not Avast causing this, as I completely disable all shields, local and web and can still not get to it in any browser
If you have a Linux live CD....
Yup this will rule out an issue with your firewall or OS; IP/MAC on the PC stuff.
For a bit thought it might have been relating to using Drupal.
Well, I have to say you have a good mystery here!
One thing that comes to mind is a problem with the DNS server.  Is it possible that the PC you are having trouble with is set up to use a different DNS than your other PCs?  That could explain why the one PC has trouble and the others don't.   Still, it doesn't help explain why you can do pings while the browser is still waiting for a response (assuming you are doing the pings from the troublesome PC). But it is worth checking if for no other reason than to cross that off the list.
Might also be a hardware problem somewhere.  Have you tried swapping the connection from you troublesome PC to a different port on the switch or router?   If you have a spare switch and.or router, it would be worth trying a different one, just to eliminate those pieces of hardware.