Premise Premise on Vista

Motorola Premise


Senior Member
Hey all,

I've loaded Vista Ultimate on a Dell PowerEdge SC430 server with 1GB of RAM. Vista loads and runs fine, but I'm having trouble with the Premise install. The installer app copies the files, and completes the majority of the installation, but never completes (I never get a "installation complete" message and the installer window sits there for hours without finishing the last little bit).

I've tried installing just the Premise Server, and just the Premise Builder as well, neither finishes installing on their own either. I can use the task manager to kill the installer app, and I can open the Builder, but it never shows me the "Local Computer" in the Builder login window. If I hit Cancel there and try to import, export, etc. it tells me the license key is expired also. This should be impossible since the software is now license-free, so I'm wondering if the install is bombing at the end where the server registers itself as valid. I'm definitely using the same license-free installer I've used on multiple other installations (but all on XP).

Or maybe it's a hardware problem? Just wondering if anyone else has run into this problem. I may just have to rewind and order XP Media Center, but wanted to check with you all first.

Will Gosling
The first thing you need to do is add another gig of RAM. Vista will eat up nearly a gig on its own before you launch any other programs.

Second, are you installing as an admin, and I don't mean as the Administrator or your own account that has administrative privileges, that is not enough. The easiest thing to do is to right click on the installer app and select Run as administrator. The other option is to
turn UAC off, then your accounts that have administrative privileges will actually have the privileges you are expecting.
I have the exact same problem. My system:
Compaq gx505 athalon 3800 w 2 gig ram and plenty of disk. vista ultimate

I can run the install about 3/4 of the way on the progress bar and it stops. Sys behaves exactly as stated below. I have turned off UAC and run as administrator with the same result.

I have searched for an install log but found nothing. Any help is welcome.
Same Problem.... among with other problems of vista.
solution: Uninstall Vista ---> Reinstall XP
Installed on Windows 2000 server - works like a champ and has been working great for quite some time....
Yeah, I made the original post. The builder seems to run ok after forcing the install to quit, but I'm thinking that Vista may have issues with installing and running the Premise Server and Premise Server Monitor services that run at system startup. I've had the Server Monitor fail on the last couple restarts, and the machine has been completely freezing up frequently without any blue screen...just freezes and won't respond until powered off. I think I managed to uninstall Premise after a few tries (the uninstall hangs before completing the same as the install does).

I have decided to use the Vista machine as my personal workstation and use my older 1 GHz 512RAM XP machine as my Premise server. Should have enough guts to run the Server services and stream music. I may try installing on Vista again as a test, but will only install the Builder this time. I'll see if the system crashes and weirdness goes away when the Server services aren't installed.

Good luck!
-Will G
I wonder if the installation would work if you start it using Windows Vista's Windows XP (Service Pack 2) compatibility mode.

Also, if you suspect the unreliable behavior is due to the Premise services, you can temporarily disable them using the Services control panel so that they do not start when the computer boots.

Thanks for the suggestion, but the install locks up when trying with the XP Service Pack 2 compatibility mode as well. Have people had success with the installation on Vista where the install application actually finishes successfully? I wouldn't necessarily put this
past Vista having a problem with some of my hardware and not telling me about it, although everything I have is pretty basic...Dell server SC430 mobo, 2 GB ram, sata drives and onboard video.

Still planning on reverting to my older XP machine for my home server unless anyone can suggest other options to try. Thanks to all who have input on this thread!

-Will G.
To maximize success for a reliable installation, I would suggest running premise on XP as a dedicated machine. If you consider what IT professionals run on exchange servers or in server farms, it’s probably XP or the Windows server product line. As a server, I'm not sure what Vista buys you since I believe its mostly GUI related. That said, if the install fails on vista, it would be nice to know what’s causing it.

As an aside, has anyone run Sys on a Windows XP embedded server (fanless - diskless) installation?
I haven’t tried SYS on Embedded XP, but from my limited conversations w/ some of the guys that work for me, it shouldn’t be much of a problem. It’s built on the base W2K OS, so that should work well. AUO Online has some XP Embedded kits; I was thinking of picking one up, particularly given they have bezels and touchscreens (wonder how one would use that!)

Yes, as I travel a bit, I loaded Premise onto my Vista equipped(?) laptop. I wish I could recall the steps, but i do recall it was a bit of a pain. The installer did quit (or was it when I uninstalled). I think I went thru it a couple of times, basically rebooting after it hung.

I now have the server, the monitor and George's UpNP service(s) running on my laptop.

Hope this helps...