• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Problem when trying to enroll wireless sensors

mikesm

Member
Hi everyone.  I have a Elk M1G with 7 hardwired expanders and a M1XRF2H receiver.   I have had the system configured and running for the hardwired zones for over a year and working well.  I am now trying to enroll a few of the Alula RE218 flood sensors into the system.
 
As far as I can tell, these sensors must be enrolled in through the panel, and through through the ELKRP2 program.  
 
The first thing I did was to add a set of wireless expander zones starting at 113.  I added 3 wireless expander zones since each RE218 has 3 zones on it (heat, freeze, and flood), and I wanted room to add more.
 
Then I sent this config to the panel, and exited RP2.   I went to the panel and enrolled 2 of the RE218's, in zones 113-118 (with 3 different loop values).
 
I exited programming mode on the panel, and went back to RP2, and a conflict was show when I connected to the pnael.  I read in the values from the panel to the database, but after doing this, not only did the wireless sensors not sow up in wireless setup, but the wireles zone groups now show up as more hardwired expanders!
 
I have done this twice and it's doing the same thing both times.
 
What am I missing?  Is there something different I have to do after adding wireless zones so they stick other than sending them to the panel and saving to the account file?  Why do they come back from the panel as hardwired zones?
 
Thanks!
Mike
 
 

RAL

Senior Member
What version of RP2 are you running?  The current version is 2.0.38.  Back in 2.0.34, a bug was fixed which sometimes caused wireless zone expanders to be changed to hardwired.  That might explain your problem.
 

mikesm

Member
I am running 2.0.40 of ElkRp2.  Maybe I should try downgrading to 2.0.38?
 
EDIT: 2.0.38 doesn't seem to be available for download...  I guess I should report this as a bug?
 

RAL

Senior Member
mikesm said:
I am running 2.0.40 of ElkRp2.  Maybe I should try downgrading to 2.0.38?
 
EDIT: 2.0.38 doesn't seem to be available for download...  I guess I should report this as a bug?
I would go ahead and report it.  There are also some Elk support forums on their web site that you can try posting to.
 
I don't think going back to 2.0.38 would help.
 

mikesm

Member
Ok, I called them and got some good info to help resolve this.  This is for everyone who might be seeing the same problem.
 
1) Do not create a set of wireless zones that have no real devices in them.  I had planned to enroll a bunch of RE218's that had 3 loops in each, so created 3 wireless groups.  Apparently if you try and import a wireless group that is empty, it will convert to a hardwired expander.
 
2) Define the zone first in Elkrp2, THEN do the enrollment.  I was trying to enroll them first, and then define them.  This doesn't work.  You define them in rp2, send the definition to the panel, and then enroll them, and read from the panel back to RP2.
 
As far as I can tell, none of this is written down in the manual, but it appears to work, at least for the first sensor.  Hopefully I can then move ahead with the others.
 
BTW, a question for folks.  I don't want the siren going off in the middle of the night if there is a water leak.  I have the Elk M1G integrated with home assistant, and it can read the zone info and shut off the water, or turn on the lights in the master bedroom to wake only my wife and I up, not the kids and the neighbors, much less sending the police here.   :)
 
I am planning on putting these in a new Area, and enabling the silent alarm option for the zone.  Will this achieve my goals or is there a better way to do it?  The manual says it's it's a heat, freeze or water alarm (the three different loop sensors on the RE218), the alarm will go off even if the area is not armed.
 
Thanks!
Mike
 

RAL

Senior Member
mikesm said:
Ok, I called them and got some good info to help resolve this.  This is for everyone who might be seeing the same problem.
 
1) Do not create a set of wireless zones that have no real devices in them.  I had planned to enroll a bunch of RE218's that had 3 loops in each, so created 3 wireless groups.  Apparently if you try and import a wireless group that is empty, it will convert to a hardwired expander.
 
2) Define the zone first in Elkrp2, THEN do the enrollment.  I was trying to enroll them first, and then define them.  This doesn't work.  You define them in rp2, send the definition to the panel, and then enroll them, and read from the panel back to RP2.
 
As far as I can tell, none of this is written down in the manual, but it appears to work, at least for the first sensor.  Hopefully I can then move ahead with the others.
 
BTW, a question for folks.  I don't want the siren going off in the middle of the night if there is a water leak.  I have the Elk M1G integrated with home assistant, and it can read the zone info and shut off the water, or turn on the lights in the master bedroom to wake only my wife and I up, not the kids and the neighbors, much less sending the police here.    :)
 
I am planning on putting these in a new Area, and enabling the silent alarm option for the zone.  Will this achieve my goals or is there a better way to do it?  The manual says it's it's a heat, freeze or water alarm (the three different loop sensors on the RE218), the alarm will go off even if the area is not armed.
 
Thanks!
Mike
Thanks for sharing what you learned.
 
For the water leak alarm, you can use a zone def of 13 or 14, or use the silent alarm option on zone def 25.  One difference is whether you want a notification on the keypads (seems like you would).  But if you have central station monitoring, they'll be notified either way.
 

mikesm

Member
RAL said:
Thanks for sharing what you learned.
 
For the water leak alarm, you can use a zone def of 13 or 14, or use the silent alarm option on zone def 25.  One difference is whether you want a notification on the keypads (seems like you would).  But if you have central station monitoring, they'll be notified either way.
 
Thanks for the quick reply.  Yes, definitely would like to be notified on the keypads!  I assume then I would want to put them on Area 1 (the main area) use the aux alarm (type 13 or 14), not enable the silent alarm, and not a separate area?
 
Thx
mike
 

mikesm

Member
PS I assume that if I didn't care about heat or freeze, I could only enroll the one zone, and then set the loop value appropriately, and worry about the other sensor inputs?  I'm in the SF Bay area, and the house is very well insulated, so heat or freeze is probably not very useful...
 

RAL

Senior Member
mikesm said:
Thanks for the quick reply.  Yes, definitely would like to be notified on the keypads!  I assume then I would want to put them on Area 1 (the main area) use the aux alarm (type 13 or 14), not enable the silent alarm, and not a separate area?
 
Thx
mike
 
I would keep things all in one area.  If you put them in a separate area, you need to dedicate a kaypad for that area, or go through some extra steps with an Area 1 keypad to do things in a different area.  Since you want these zones armed all the time, I don't see a reason to place them in a separate area, as long as you choose a 24 hour zone type. 
 
Since you want a message on the keypad, I would use the water/heat/freeze zone defs since they are 24 hours zones and automatically produce a message.
 
With zone types 13 and 14, you if you really had a need to use them,  you could write a rule to put up a message on the keypad.  But why go through that extra work and waste a rule for something the other zone defs give you for free?
 
mikesm said:
PS I assume that if I didn't care about heat or freeze, I could only enroll the one zone, and then set the loop value appropriately, and worry about the other sensor inputs?  I'm in the SF Bay area, and the house is very well insulated, so heat or freeze is probably not very useful...
 
Correct, you don't need to use the extra loops if you don't want to.  Just skip the enrollment of them.
 

mikesm

Member
RAL, thanks for the note.  One thing though, if I use the heat/freeze/flood types, won't the alarm go off if sensor detects water, etc...?  That is, the siren would go off?  I wouldn't want to have water detected in the night causing all the neighbors get woken up.  Does it just beep on the keypads, or is it a normal alarm?
 

RAL

Senior Member
mikesm said:
RAL, thanks for the note.  One thing though, if I use the heat/freeze/flood types, won't the alarm go off if sensor detects water, etc...?  That is, the siren would go off?  I wouldn't want to have water detected in the night causing all the neighbors get woken up.  Does it just beep on the keypads, or is it a normal alarm?
I think this is one of those cases where no single zone definition will give you exactly what you want, so you need to pick a zone def and then use other system options to get there.
 
If you choose a water/freeze/heat zone def, then I can see several ways to keep the outside siren from sounding.
 
One thing to try is setting the Cutoff Timer for Water to 00000 (zero) seconds.  According to the manual, that will prevent outputs 1 and 2 from activating.  I don't believe that will reset the alarm condition, so I think he keypad will still beep.   And I think you could still make voice announcements over output 1.
 
Another way would be to set the Silent Alarm attribute as part of the zone definition.  But that also will keep the keypads from beeping, which I would think you want.  Even though the keypads won't beep, a message will be displayed on the keypad, but then you'd have to notice it. How long will it take until you notice?  Could be a while.  You could fix this problem by writing a rule to say that when the zone is not secure (i.e. in alarm mode), then beep the keypad using the rule and/or make voice announcements. I think that will not be overridden by the silent alarm attribute, but I haven't tried that specific case.
 
Another way would be to configure the Output 2 Delay Turn On to keep the outdoor siren quiet for 30 seconds or whatever time you think you might need to respond to the alarm and silence it before the outside siren sounds.   That will apply to all alarm conditions, but it's a nice thing to do to keep from annoying the neighbors no matter what the cause.
 
Top