Problem with M1XEP


I just received my M1G system and am in the process of "benchtesting" the installation. I have all of the security related functionality tested and working correctly. The ELKRP software is able to connect to the M1G panel through the serial port successfully. I am now attempting to install the M1XEP ethernet module so that I can connect to the panel using the network and am having some problems. Here are the specifics:

The closet where I will be installing the M1G panel does not have wired ethernet access to the network so I am useing a wireless network bridge to connect the devices in that location to the network. I have the M1XEP plugged into a Linksys switch which is plugged into a SMC EZ Connect Wireless Network Bridge. I know that the the switch and wireless bridge are working correctly as I can plug my laptop into the switch and use the network with no problems. In this configuration, the ElkRP software is unable to find the M1EXP. I also tried eliminating the switch by pluggging the M1EXP directly into the wireless bridge, but that did not work either. However, if I plug the M1EXP into a switch that is hardwire connected to the network ElkRP is able to find the M1EXP. I really need for this to work wirelessly and I am at a loss as to how to resolve this problem and would welcome any suggestions.

So when your laptop is plugged into the closet Linksys switch, can RP on your laptop access the M1? If so, then that probably says the M1XEP is configured correctly. If not, start fixing that issue before you jump to wireless.

When you have the laptop connected to the closet Linksys switch, you said the network was working. Meaning that you can jump across the wireless to other computers in your home or surf the web? What computer was used to test the hardwired connection (the same laptop or something else)?

Is the M1XEP configured for DHCP or static IP? I assume you should be able to ping it from your laptop connected to the closet Linksys switch. Can you ping it across the wireless?
First I would connect the XEP to your laptop with a crossover cable and insure everything works. Your ip addressing, subnet mask, etc. When you are sure it works, here are a few other tips...

If you are using the default secure port - 2601, make sure you enable or forward it in your router. If you are using a static IP, be aware that the secondary DNS is not implemented yet, and in fact, if you enter something in it, it could hose you up.

From Elk engineering:
The best way to set the fields on the TCP/IP tab in the XEP setup window for now is to:
1) Connect to the control.
2) Open the M1XEP Setup window and select the TCP/IP tab.
3) Click the Receive button to receive all the current settings from the XEP into ElkRP.
4) If you want to set it to DHCP then.
a. Click the “Static†option then
b. Click the “DHCP†option
5) Or, if you want to set it to STATIC then
a. Click the DHCP option then
b. Click the Static option and
c. Set the static address, mask, gateway, and primary DNS
d. Leave the secondary DNS UNCHANGED.
6) Click the Send button to send the changes back to the XEP
7) Disconnect and allow the XEP to re-boot.

If you’ve changed the secondary DNS, you should perform the above steps to make sure it is still OK.

Also, are you using 'Find' to located the XEP? If so, Find requires port 2362, be sure that is open in your router as well.

As a last resort - is it not possible to run a cat5 from your router to the closet? I always prefer a hardwired connection anyway.

Hope this helps.