Problems with Elk M1 and Omnistat 2 Tstats


Sorry for the dup post...I just realized this is a more appropriate forum....

This week I installed a new M1 Gold panel with and M1XSP (in hopes of controlling two Omnistat 2 thermostats). I have the panel working great and the M1XSP has successfully enrolled but I cannot seem to communicate to the Omnistats, they work great as standalone programmible Tstats. I've read through several threads on this subject and I have tried serveral different addresses and baud rates but still no luck...the dreaded T01 Not Enabled message is all I get....Help would be greatly appreciated!

Here is what I have done so far...

Installed the M1G and M1XSP - enrolls fine, no conflicts.
- updated firmware to 70.0.2
- M1G running 5.2.10
- ElkRP running 2.0.16
- Set Baud Rate to 300 on Tstats and XSP, S3 is low
- Set XSP S5-S8 Mode to 1010
- JP3 to RS232
- JP5 shorted
- JP1 open - all keypads and add-ons connect via M1DBH Data Bus Hub
- XSP address = 1, no other devices have this address except one keypad
- Serial cable wired per directions
- J8 removed from Omnistats
- CAT5 used for cabling to Tstats, 2 Tstats in parrallel, single cable run used for each (Orange-Yellow, Green-Green, Brown-Red, Blue-Black)
- Tried only one Tstat
- Tried 2400 and 300 Baud rates
- Tried Tstat Address of 1, 2, 3, and 4 (I am assuming this address corrisponds to the TSTAT NUMBER in RP)
- Tried reflashing the firmware of the XSP

I need to test the cables but they are new runs and I doubt both are bad...I'll check them tonight through the DB9.

Again, I appreciate in advance any assistance or ideas to try....Thx!

OK - strange one going on here...I left m12go running on my PC for a few hours, came back from dinner and can now see the thermostats...wierd...could 300 baud just be extremely slow? or could I be seeing lots of data errors? not sure, I'll keep playing...