Sending serial commands to RCS TStat from Elk

tmbrown97

Senior Member
Hey guys (and hopefully Spanky),

So I just installed my RCS communicating zone controller and tstats (or WDU's) - got it talking to the Elk - all is well there.

However - I wanted to try hitting some of the more advanced commands of the controller by sending direct commands over the serial port.

So - I have the message going to the serial port, but instead of being read as raw ASCII, it seems to be getting sent under the "TM=" command which makes everything into a simple text message on the display - and doesn't actually execute the command.

Is there any way around this? I want to send an exact ascii string directly to the zone controller without it getting converted into "text message" text.

Thx!
 
When you send a raw command, you have to start the string with the > symbol. If that's missing, try adding it in at the start of the string. Also, is your M1XSP firmware up to at least 1.0.46?

If all that looks good, exactly what command are you trying to send?

Chris
 
Man you had my hopes up for a second...

Here's the exact string I'm trying to send as a test: "> A=2, OT=135 ^M^J"

but it just shows up in the messages in the thermostat exactly like that - when what it should be doing is setting the Outside Temp on the thermostats to 135 degrees (within range of its capabilities).

Actually - just checked, and mine are firmware 1.0.40 and 1.0.42 - so I'll give upgrading a try and report back.
 
Well upgrading firmware did change something - the message displayed in the messages immediately cut down to "T=135". So, I tried a few variations - including ditching the ',' and even just sending OT=135 but now it's just not doing anything that I can see.
 
I send the outside temperature using a string formatted like this:

>A=255,OT=135^M

I use the 255 broadcast target since I have three different TR60s, so this just hits them all at once. I tried this using 135, and they updated. Perhaps the ^J interferes in this case.

Chris
 
You da man... that fixed it, and 5 minutes later, Elve is updating the custom value and Elk is sending it to the thermostat!

Idle curiousity - where did you learn about the newer firmware issue? I follow pretty closely and haven't seen that before.

Thx!
 

Attachments

  • RCS TStat.jpg
    RCS TStat.jpg
    126.9 KB · Views: 3
When I installed my TR60's this summer, I was looking for a way to use the messaging feature on them. While hunting around for ways to do that (and not realizing that just sending text apparently would have worked just fine), I noticed the 1.0.46 support to send extended commands using the >. I didn't actually end up using the messaging, but I do have CQC plug current tempature into a counter on my Elk, and then one of its rules shoots it out to all the thermostats. Of course, thanks to the weather.com feed change, that also means I'm migrating to another weather source this weekend for the temperature.

Chris
 
Yup - same boat, but it works for now. When Jayson updates Elve I'll migrate to a new service. Interestingly, I didn't get the email about the service becoming pay-per-use - would be awesome (but unlikely) if they grandfathered in the really old accounts.

The messaging feature is mildly interesting - I can see only one use for it - and that's if the system ignores set temperatures because the windows are open, then send a message and trigger the flashing red light - but of course you'd have to clear all messages when the condition resolves itself (wouldn't want it to stay pending user clearing it). Otherwise the tstat is the last place someone should have to go for info.
 
Back
Top