Snaplink to Omni won't work over LAN. Remote connection OK.


New Member
Anyone having issues connecting Snaplink across the LAN?  I have an Omni system with the Snaplink app on an iPhone.  I am able to connect to the Omni using Snaplink when I’m on an external network and coming into my LAN with port forwarding.  However, when I try to connect to the Omni from the LAN (using the controller’s direct IP and port 4369), Snaplink will not connect.  I can connect to the Omni using the Dealer PC Access software on the LAN.  It is very weird and I cannot figure out why Dealer PC Access works locally but Snaplink will not.
I had an issue once trying to use an external address (DNS) inside our home.  My routers security would not allow, but direct IP always worked.  Assume it worked in the past?
I have 2 configurations in Snaplink.  One for the static IP from my ISP that I use when I'm not at home.  The other config uses the local Omni IP address that should work when I'm on my home Wifi, but it doesn't.  
It did work at some point but something changed a few years ago (I'm not sure what).  I didn't pay too much attention because I could always use the external (static IP) config and get to the controller.  It's a long story, but now I need to get the local config working.
Before I let this thread go, I was hoping someone could at least confirm that they are able to get this to work:
Snaplink to an Omni Controller
Using an iPhone over WiFi (local LAN to controller)
Using the Omni's direct IP address (192.168...  probably) and local port number (likely 4369)
It works iOS 15.3
The only problem is I usually have to enter the PIN code twice, because the PIN screen appears twice.
TNB. I will give you the simple answer that may work for you. It looks like you have set up your router with port forwarding to a DNS. I have been using DYNDNS but it has become a little expensive but I don't want to change anything now.

First of all, turn off the wifi connection on your cellphone to force the cell to connect to the 4G network. Delete the snaplink setup that you have and re enter the snaplink network address block as your dns name (ie. and then hit the "syncronize controller" button. That will hopefully force the snaplink setup to the 4G cell mode. Save the entry and give it a try.

I had this problem with both android and iphones. If this doesn't work then I will give you the full process that I used for setup. I did this quite a while ago so it is taxing the memory cells.
I quit opening any ports on my firewall many many years ago. Just use VPN with Snaplink and it is one configuration to IP of the OmniPro panel.

OpenVPN client is available now for Windows, Android and iOS clients. OpenVPN server is available now on many SOHO combo routers.

If Hairpinning is turned on your router then you should be able to access your OmniPro 2 panel inside or outside your home network using your WAN IP.

In my PFSense firewall Hairpinning is known as NAT Reflection.

What is the MFG / model number of your firewall?