Solar Temp Humidity sensor problems.

esvfm

New Member
I've recently ordered a range of sensors and hubs from you and have been getting on well with all of them but the temp solar humidity unit.

I can read the separate temperature device fine and I can detect the DS2438 ok on the network. The problems I'm having is that I always read 0 for the solar sensor and the humidity values seem quite low too (I've seen nothing higher than 50%). I've tried reading the values in a number of ways including USB and serial adaptors the dallas one wire java viewer and the one wire C public domain kit. I've checked that the config register is set to read the 3rd channel and that appears ok so does the onboard temp probe.

I was wondering if there are some checks I can perform on the device to check that the sensors are behaving properly (I'm a software engineer by trade). Or do you have any other ideas as to what the problem could be?

Thanks for your help,

Chris.
 

ericvic

Active Member
Chris,

Are you supplying external power to the device?

You should not be getting 0 values on the solar sensor. They will probably be very small but should not be 0.

Are you sure that the actual humidity is greater than 50%? You could take it to the bathroom and run a steamy shower to see if it will register higher humidity.

Eric
 

esvfm

New Member
Hi Eric, thanks for the quick response.

I've tried tried using external and paracitic power for the device (running it through one of your 6 channel hubs), it doesn't seem to make any difference.

Nice idea about the shower! Unfortunately due to the fact I'm doing things at work, I can't take the sensor into a shower, even if I did I think the health and safety people would have 'issues' with me doing such a thing. Its fairly wet and horrible here in the UK at the moment and the outside relative humidity is in the high 80 - 90% range so I presumed it would be a bit lower inside but not 40% lower. We're due to order some more sensors soon so I think I'll grab another one to compare it with.

With the solar sensor 99% of the time the readings are 0, though I have seen it show something tiny like +/- 0.002 for a second or so, this being inside a fairly well lit office (or up against a window), putting my finger over the sensor makes no difference.

Thanks for youre help,

Chris.
 

ericvic

Active Member
Chris,

It certianly sounds like there is a problem with that board. If you want me to take a look at it you could ship it back and I will see what I can find out.

Eric
 
Top