Sporatic Elk Module Trouble / Restore and other is


Active Member
I have had my M1G installed since august of last year... at the moment i only have the basics, 2 input expansion boards, ethernet interface and HAI thermostat integration.

I seem to have two types of intermittent problems and another odity...

1) module trouble/restore. This happens sporatically (8/24, 8/30, 9/20, 9/23, 9/26, 12/13, 12/14, 1/13, 1/19, 1/30, 2/19, 3/1) and is always on Serial Exp 1. I get this series of three mid-level beeps that repeats maybe 2/3 three times and goes away (presumeably after the restore and before i can get out of bed). This almost always happens in the middle of the night, but not always - but always when nobody is touching anything.

2) this happens more rarely, but i can't pinpoint the cause either. From what i can tell, there seems to some sequence where if i open various zones which filter into a combination of inputs on different input expansion cards, i get this neverending searies of very low level beeps. example: garage door, hall door on Exp 3, nook window and/or porch door on Exp 2. The only way i know to stop it is to power down the Elk turn it back on. I am clueless here....

3) This one is consistent upon and power down/up of the M1G. Upon bootup, every single registered Zone is listed as violated on the keypads. Once i open one window/door contact on an expander, all zones on that expander correctly clear from violated status. So i have to do this on two zones (one for each expander). Right now not too bug a deal especially since #2 occurs infrequently but once i install a third expander in my outbuilding, it will become more annoying!

NOTE: I do NOT have any inputs connected to the M1G itself as this was a retro install and my main closet is not near the security wiring leads (which used to go to the Elk's precursor - the Moose Z1100?). Also, all contacts are registered as "Type 1 - Normally Closed" which is correct. But upon reboot it is as if they treated as normally open althoguh regustered correctly?

Any tips would be appreciated.
Your #3 issue is easy. Upon power up all zones are autobypassed and show up as violated until the M1 accesses the zone. The input expanders can take upto 60 seconds to check in with their status unless a zone changes state. In your case you opened a window and the status of all 16 zones on the input expander immediately updated. Everything is working normal here.

Look at the data bus errors in user menu 8,6,1 and see if the data bus errors are counting up over a period of a day. A few errors is OK, but thousands indicate a data bus problem.

Turn off the power and measure the resistance between Data A and Data B on the RS-485 data bus. It should be around 65 ohms. More than 20 ohms up or down means a data bus termination problem.

Remember that the RS-485 data bus MUST be run in a series wiring configuration with a termination resistor in place at the extreme ends of the data bus run. The old Z1100 allowed for star wiring. Make sure your data bus is not wired this way. If it is, you may need a M1DBHR data bus hub for retrofit, which allows for star wiring.

Update to the latest M1 software. We continue to improve all areas of the M1 thanks to the great feedback from the field.
As always, you guys know how to give support!!!

On #3 - perfect... You're right - i think my frustration was with the associated beeps or voice announcement when i had all speaker output on (another post for another day). With no endless audio, no objection at all to waiting 60 secs to clear...

Bus Error Screen shows: T5A1 44145

I'll check tomorrow, but assuming the delta in the last value is what we're interested in? since the things only been installed for ~200 days, i'm assuming an average of 200 a day is problem indeed?

Ohm reading on the terminals on M1 reads 61.9 - looks good...

On the wiring, the databus runs are new (only the zone leads are reused)... I used cat5 or 6 instead of the 4-wire that was there (only using 4 wires though)... I have two branches - one going to each side of the house and coming off the same terminals on the M1... They daisy chain with the devices inline, which the inbound and outbound wires all connected on same screw terminal. Definately not star wiring, but seems more like parallel than series based on what i do with deep cycle batteries - i guess the fact i'm connecting to a terminal block is confusing me here...

Keypad #1 --- Input Exp2 --- M1 --- serial expander --- Input Exp 3 -- Keypad #2

I will install the firware upgrades today and check the termination - i'm almost positive i have one temrination on each run (KEYPADS ONLY) - i remember reading that manual multiple times on that subject :D But who knows...


p.s. This probably is not relevant, but one other interesting thing is that the beep level on the keypad is not consistent. i.e. while navigating to the bus diagnostics menu, beeps went from normal to barely audible back to loud.... Seems to get soft after entering authorization, but isn't consistent... Backlighting is constant though, so again, probably irrelevant.
The T5A1 is Serial Expander (Type 5), address 1 caused the last error listed. Check to see if you have the latest upgrade software in the serial expander and it is wired in series on the data bus.
Well i've updated the units... Also installed the output expander / relay boards over the weekend on the same side of the 485 bus. Still getting a tone of errors in that diagnostics menu (same device)....

I also double checked for extra termination - none... every thing is good

I'm a bit stumped, because the serial device is the first in line in the most complex side so as it sites nows branch B:

serial expander -> input expander -> oupt expander -> keypad

As far as i can tell no other issues n the devices downstream.

Per my prior comment, i still think we have a disconnect on serial... but i run 4 wires into the green connector and four wires out of the same to the next device on the line - same colors are always on same pin.

At this point, when i get some time, i may try putting the serial expander on a single run and temrinating it and temporarily removing everything else on it?

For a test, bring the expander back to the M1 control and connect it directly to the M1 control board. If you are still get errors, there could be a hardware problem on the expander.
FYI - still having trouble even after my latest round of mods...

Per spanky's last recommendation, i actually already have the expander as first device within a foot of the elk.

Old Wiring:

Keypad #1 (jumpered) --- Input Exp2 --- <<<<<< M1 >>>>>> --- serial expander --- Input Exp 3 -- Keypad #2 (jumpered)

New Wiring:

Keypad #1 (jumpered) --- Input Exp2 ---<<<<<< M1 >>>>>>--- serial expander --- Keypad #2 --- Output Exp --- Input Exp 3 --- Input Exp4(jumpered)

I have a spare serial expander which i'm willing to try, but the ohm reading is correct (as it was before)... I'll go give that a shot and see what happens
New wiring brought the resistance to ~69 ohms, but i have over 100' of cat5 running to the outbuilding so i'm sure that's the cause - seems to be within Spanky's tolerance...

Tried the spare expander (used as HVAC control for HAI)

same results... (300+ retry errors this morning on same device)