Starlink, Static IP and DDNS settings problem


New Member
Because of remote location internet problems we are moving to Starlink. The problem with Starlink is that it uses CGNAT to translate addresses so there are no static IP addresses for residential customers.

Their service is great, fantastically fast, but the lack of an unmoving address is likely to be a problem for remote phone access to the cameras on our Coccoon 8 camera HE160233 Home Security system. So I followed this article to set up a reverse SSH connection to a small server on our LAN. This maps ports 8080, 5000, and 5001 from a static IP address at AWS's Sydney location to the same ports on the HE160233 on our LAN.

Because there seems to be nowhere to specify the LANs external address, I assume that the phone's get their target address from a Cocoon server somewhere and it gets the address when the HE160233 bounces some sort of keep alive information off it. In the Network section of the manual (4.2.6, page 23) DDNS is described and there are a number of services supported in the DDNS menu. I planned to use this to advertise the AWS's static IP address but have a problem.

I've set up addresses using both no-ip and dvrdydns. Both work and map a hostname to an IP address. The problem is that when I try to enter them on the DVR I get an error when I select either Test, Apply or Exit: User Name or Password of DDNS is incorrect! After many attempts and changes of passwords etc I conclude that my understanding of the field Host Name is probably wrong. Can someone advise please?

For noip I enter the name as either my email address or user name, the password as used to login to, and the host domain as any of, or No combination worked. For dvrdydns I've tried the dvrdydns username, password and either or Also tried the address of the AWS host as the host domain. I've also tried ticking and unticking UPNP.

The only other thing that seems possibly relevant is that we log in the to DVR with no password, just admin and enter. This was apparently an instruction we received earlier.
Last edited:
Welcome to the Cocoontech @john939 .

Tried something similar on the forum here one user using Starlink and myself using T-Mobile.

Tested it with an Oracle VPS (Free) and OpenVPN VPS (free).

Only did a bit different creating a VPN client on the Firewall (PFsense +) to the VPS. An external VPN client to same VPS.

PFSense + (free commercial version) has a built in client wizard so all you need is the OVPN file to configure it which is the same as the ovpn file you would use on your client.

The VPN tunnel allows access to all of your devices on your home LAN (here it is automation servers, cctv and alarm panel)

This allowed access to the home LAN via the external VPN client. I have not touched it in a while and it is still active.

I haven't tinkered with it in months now.

Here is another guide:

GUIDE: Starlink + pfSense guide for idiots. No starlink router, no complex failover stuff, just easy steps.

The OpenVPN VPS was easier to set up than the Oracle VPS. Note both are free.

Last edited:
Good idea and thanks for the info. I have a spare Raspberry Pi 2B and an Odroid C2 so I might have a look at adapting your guide to openwrt.

My current network config uses a Telstra NBN Gen 2 attached to the Starlink Router to provide multiple ethernet ports plus a longer distance 2G wifi on a guest network (5G direct from Starlink). I doubt the Telstra router as a VPN solution and would prefer to only run the Cocoon through VPN so I'll look at hanging the Pi off the Telstra router to do nothing but connect the Cocoon and VPN.

I'm still keen to understand what I'm doing wrong with DDNS if anyone can help as I'd like to get the SSH solution working even if I move to a router based VPN.
So guessing the DDNS is going to the IP of the VPS eh?

For a test maybe try changing the DDNS login from a name to an IP?

Here test web interfaces using a reverse proxy to local lan via SSH. (to a local LAN)

If you VPN then you do not have to use reverse proxies on any ports. You will see them all.
Found this on Reddit.

DDNS manual workaround

I wasted a couple of days trying figure out what was happening with DDNS using Starlink.

To integrate Starlink into my system I ditched the Starlink WiFi router and used an old Netgear HFC router with a WAN backup port. It connected instantly with DHCP and revealed the real IP address of the connection. This is a very different address to the public address.

Now I manually enter the IP address for the router connection into the DDNS client and I have no issues connecting to my office network.
I do enter the correct address into the two DDNS accounts and if I use the hostnames in a browser the correct address is returned.

The problem occurs when I try to fill in the three fields in Cocoon's DDNS page. Something in name, password, and Host Name causes it to throw up an error.