Stupid RDP tricks

jrfuda

Active Member
I once read an article/post about "stupid RDP tricks," you know, ways to do something during an RDP session so you can't log back in.

Well I just did one.

Word to the wise: When restarting your PC via an RDP session, be sure to select Restart from the drop-down menu, NOT Shutdown.

Doh!
 

electron

Administrator
Staff member
that hurts lol, if you have another machine you can connect to, and have wake on lan enabled for the machine you shut down, you could start it again, but Murphy's laws dictates that you won't have this option B)
 

huggy59

Active Member
It's easy to do similar things when playing with routers and switches remotely - shutting down the port you're connected to, changing IP addresses and losing your connection, etc. We all have holes in our feet where the bullets went thru at one time or another! hehe
 

deranged

Active Member
One of my finer moments is when I was attempting to turn off 1 port on a ups in a remote office to restart a hung server. Instead I shutdown the whole ups.

ugh.

StevenE
 

huggy59

Active Member
Last Laugh:

After I was let go from my last position, my boss tried to change the setting on the large Liebert UPS system in the data center, apparently without reading my notes or the manual. Nine racks of servers, networking gear, and a PBX, shut down the hard way! hehehe
 

electron

Administrator
Staff member
When a Liebert goes down, the entire place usually goes down B) My most common mistake is updating a firewall policy on one of my linux machines, but making a mistake, so I end up getting kicked out and have to wait till I get home in order to fix it. Work around: one of the first lines should be to allow established connections, works great now. As for RD, the only thing I have done by accident started some really slow program on the remote system because I thought I was working on my local system.

Btw, I have a problem with RD which happens on every machine I have, whenever I minimize RD to the background, it will try to steal the focus once in a while (even when nothing is going on on the remote machine), screwing up any input on the machine I am working on, and usually it maximizes itself when my boss is sitting right next to me ;) I am really getting tired of this but can't figure out how to fix this. Has anyone ever run into this?
 

jrfuda

Active Member
electron said:
As for RD, the only thing I have done by accident started some really slow program on the remote system because I thought I was working on my local system.
I always runmy RD sessions 1 resolution "notch" below whatever I have the client set on, that way it's always windowed. I also don't map any drives, etc and leave all the sounds at the remote machine. If I need to get a file to/from the remote machine, I just use email. I never have a problem with the remote machine stealing focus using these techniques.
 
Top