TZ16 Thermostat not adding to network


I've just added a TZ16 thermostat setup, but for some reason my master remote won't add the module.

I've checked all the wiring and everything is the way it is supposed to be. The HVAC system, control unit and the wall unit all seems to work fine. The z-wave interface unit has both the power and the network LEDs lit. However, when I try to add the module to the remote control, the remote doesn't respond.

To check to make sure that the module hasn't been added, I've tried to transfer the network to Homeseer, but it doesn't pick up the thermostat.

Any thoughts?
Nothing like embarrasing yourself in public ... just figured it out ...

This is the exact same problem I've had before, by not resetting the module by using the delete command on the remote prior to adding to the network. I "deleted" the device, then included it and presto!

See jskoog's response to one of my prior posts here for an explanation of why.
Spoke a little too soon ... now, the z-wave module won't communicate with Homeseer.

The device added perfectly from my remote to Homeseer, but if I try to change for example the cooling setpoint, it won't send it to the unit. When I set the cooling setpoint, it looks like everything functions perfectly in Homeseer, but when I go to the wall unit nothing has registered. I've tried this for different temps and both heating and cooling. Homeseer shows the status of the device with the correct cooling setpoint.

Current temp for the thermostat is 0 degrees constantly. I've tried to manually poll the devices, and it will list each device and show the thermostat as 0 degrees. I've tried to delete the whole network, reset each module (I only have four isntalled so far) and just add the thermostat alone, but no change. I've also added a screw-in module for the light in the closet where the z-wave module for the thermostat is mounted, just to make sure that it wasn't a signal reach issue, but that the screw in module seems to work perfectly.

I'm going a little nuts here ...
I can't help you yet, but I have one of these on order and should be receiving it tomorrow. The timing isn't great as I'm about to head out the door but I'll try to play with it when I get back on Wednesday and let you know how it works out.
ChrisWalker said:

Have you tried using it with any other software?

I've just started installing my z-wave system ... and had settled on using HomeSeer as my base ... so no, I haven't tried anything else at this point ...

any software solution I could try inside of a trial period, without buying any additional hardware, that isn't too hard to configure?

I'm sorry--I don't know of any Z-Wave Certified software on the market which has an evaluation copy available...