User disarm codes not working

rfdesq

Senior Member
I just finished installing another M1 Gold this weekend. Here is the setup:

1. Latest firmware, both keypads and panel.
2. Two keypads, both working and enrolled.
3. All zones work, all outputs work.
4. Three user codes setup.

Here is the problem:

None of the user codes will disarm the system. I have the users set to allow their code to disarm the system. I changed the master installer code and the RP code and both work. I have two of the users set to master and neither of their codes work for the advanced installation menus. I originally used six digit codes and they worked three out of 25 times. I went to four digit codes and they don't work at all. The only way to disarm the system is with ELKRP. Other than the disarm codes not working everything else seems to work fine. Any thoughts?
 

Digger

Senior Member
It must be something basic. I would have bet that under user setup area 1 wasnt checked off.

I looked through RP real quick and didnt see anything else that jumped out at me. Maybe walk away from it for a while and then go back and try and enter one of the users again from scratch and you might catch the problem.
 

rfdesq

Senior Member
I even added a fourth user using the keypad and it didn't work. It shows in the setup but doesn't disarm the system. All I get is that dreaded tone when you enter a wrong code. I'm waiting for Spanky to tell me to reset the panel to factory setting and upload the settings again with RP.
 

Spanky

Senior Member
Try programming the user code from the keypad. Setup the user arm/disarm options in the installer menu programming and then enter the new user code using user menu 6.

The main things to have set is arm/disarm capability for the code. If you are using a six digit code make sure you have enter all 6 digits.

You said that you had done the enrollment sequence, but maybe do it again.

Make sure that codes are not a duplicate of another code.

From your comments, nothing blaring that would cause what you are seeing.


edit: One other idea is to have ELKRP upload the codes from the M1 and see if what it uploads is what you think they should be.
 

rfdesq

Senior Member
I will try the keypad programming when I return to the residence. I did the enrollment several times and both show in and working. Both keypads do everything but disarm. I seem to have the most trouble with keypad installations. One keypad came up with "keypad bootloader" on the screen so I downloaded the bootloader software to that keypad and got it going. No duplicate codes either in six digit format or four digit format. I will try to upload the codes although there are no conflicts between the database and the system. If all else fails should I do a factory reset? I saw your post on resetting from the keypad and printed it out from another thread. Thanks.
 

Spanky

Senior Member
If a keypad is showing "Keypad Bootloader", you will need to download the keypad application code. You can get it from the M1dealer.elkproducts.com site. You will have to register the M1 to gain access. If you have an M1, you can register.

If you want to go back to square one and start again, go through the factory reset sequence with keypad address one, at Globals, G45, enter 99. You will then have to re-enroll the modules with Installer menu 1.


I just thought of one additional thing to check. Make sure the address of the keypads have been set. Hold * and F5, then F1, use the up and down arrows to set each keypad to a unique address. If there is a duplicate keypad address, it will display on the LCD OK, but code entry may not work right. Note: you must have an address 1, and you must re-enroll after changing addresses.
 

rfdesq

Senior Member
Is the keypad application code the same as the bootloader firmware that I sent to the keypad? I will check the keypad addresses again, but I'm sure there is a 1 and a 2. Sounds like I'm going to do a factory reset. Thanks.
 

Spanky

Senior Member
Bootloader is not the same as application code. Application code is loaded after bootloader is loaded. Normally you do not have to change the bootloader.
 

Spanky

Senior Member
Keypad download:

m1dealer.elkproducts.com,
then Downloads,
then M1KP Keypad Firmware Update


You must be a registered M1 owner/dealer to download the files.

Register your M1 with its serial number and you will be sent a User Name, and Password within 24 hours. Sorry, no automated return of User Name and Password.
 

rfdesq

Senior Member
Now I see where my confusion lies. Your reference to the "application code" is the 2.1.40 firmware update. Before I was able to update the firmware on the second keypad I had to reinstall the bootloader firmware. The keypad just sat there with the words "keypad bootload". That is why I had to upload the bootloader first. I have been on the ELK dealer site for quite a while as this is my fourth install. I was just confused with your terminology. Keypads have given me the most problems. I am going back to troubleshoot on Wednesday night. I will reset to factory settings and I am bringing a spare keypad with me. If it doesn't work with the reset then I'm going to take the two keypads and the data bus hub out of the system and troubleshoot from there with the spare. I'll let you know the outcome. Thanks.
 

rfdesq

Senior Member
Fixed it. Here's what I did:

1. Factory reset, re-enrolled both keypads, did not solve the disarm problem.

2. Disconnected one keypad from the data bus hub, removed that keypad from the system and database (it didn't want to remove keypad #2 for some reason), tried with the remaining keypad, did not solve the disarm problem.

3. Disconnected both keypads from the system including the data bus hub, installed a new keypad directly to the data bus, did not solve the problem and got a keypad comm error.

4. Went into RP removed the checkbox from the one touch quick arm, had to enter the six digit code a few times to arm, it started to disarm with the six digit code, checked the one touch quick arm box again, quick armed, then was able to disarm with the six digit codes.

5. Took off the lone keypad from the data bus, hooked up the data bus hub, connected the two keypads, re-enrolled the second keypad, it now disarms with the six digit disarm codes.

Thanks all.
 

rfdesq

Senior Member
Here's an update:

User codes continue to arm and disarm. But now, those that are set to master do not allow me to get into the higher programming screens from the keypad. I have to use the installer code exclusively. Thoughts? Spanky?
 
Top