• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

WebControl 8 2.2.2 hardware FW upgrade problem

Tschmidt

Active Member
I have a couple of WebControl8 2.2.2. boards running V03.02.17d firmware, thought I would update to the latest and greatest.
 
I'm using the upgrade instruction:
http://www.cainetworks.com/support/how-to-update.html
 
I'm stuck at step 1.
The WC8 is not password protected so noting to log into.
http://192.168.2.109/api/bootloader.cgi?start  throws an 404 error says to use  MPFS and to log in. Clicking on the MPSF link requires a log in. I tried the WC8 default admin/password credentials and skipped the log in, both no joy. 
 
FYI: the WC8 is not easy to access so I'm not sure what the LEDs are doing. 
 
Instruction say to use IE, I'm using Chrome and I tried MS Edge, same result.
 
What am I missing?
 
 

Attachments

  • 404error.JPG
    404error.JPG
    18.7 KB · Views: 3
  • OutsideTemp.JPG
    OutsideTemp.JPG
    27 KB · Views: 2

CAI_Support

Senior Member
When update having problem, we always recommend to try cross over cable by direct from computer to board.  However, for rev 2.2.2 hardware, older firmware does not have bootloader so that user could not do update like later firmware. I think 3.2.17d is the last version firmware does not have bootloader support.  The bootloader support through web interface was introduced in 3.2.17e firmware.  Sorry about that.
 

LarrylLix

Senior Member
I have updated my older board many times via back to back modems in separate buildings.

I am not sure what version of the hardware I have.

EDIT: I have Version: v03.02.18b2
 

Tschmidt

Active Member
According to the CAINetworks page support for the boot loader began with:
 
Since 3.02.17d firmware, we implemented a bootloader feature allowing user to update firmware in its own locaiton without shipping the board in.
 
Is that page incorrect? If so it would be good idea to correct the misinformation.
 
Just for fun I'll try a direct connection tomorrow to see if anything changes.
 

CAI_Support

Senior Member
If your board showing the bootloader.cgi not exist, then it does not support user firmware update. Sorry about that.
 
Top