Z-wave issue??


I have been using Z-wave (Homepro Models) successfully with HAL for nearly two years. I recently purchased 3 HA05 Intermatic outdoor screw-in lamp modules to install in my exterior lights. I can successfully find/discover the modules in HAL and I can turn them off using HAL. But I can not turn them on via HAL only using the local control. I tried all three modules with the exact same results. I am using a homepro usb controller which can successfully control all my other homepro switches and a bunch of intermatic HA02 Appliance modules with no issues. When I send the on command I do see the led blink on the HA05 and I see the "on node" command being sent from HAL but there is absolutely no response. Yet I can consistently turn it off via HAL. I tried multiple bulbs and multiple lamps.

My only thought is maybe an incompatibility with the HA05 and the homepro controller.
So maybe I need to change to the HA22 for zwave control. I am at a loss here. I thought it was an open standard which would seem it should work with any manufacturers controller.
Anyone out there have one a HA05 working with a homepro usb zwave controller? Any other ideas?

Thanks in advanced,

What other software have you tried? I haven't had any troubles with the HA05s... Your ACT USB controller should work fine.

Thanks for the reply Chris. Unfortunately I do not have any other software to try (unless you wanna give me a trial copy of control think just to verify? ;-)). I just ordered a handheld remote and a HA22 just to verify if the problem is indeed HAL, the ACT controller, or a faulty module(s).
Also I am testing a lamp within three feet of the controller. And that fact that I can turn it off via HAL tells me there is good communication between controller and module.

Thanks for the suggestions/info,