Jump to content


Photo
- - - - -

Adding Hikvision DS-2CD2032-I cameras


  • Please log in to reply
13 replies to this topic

#1 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 05 December 2013 - 10:59 AM

I just bought Haiku and my first task is adding a Hikvision DS-2CD2032-I camera. The camera manufacturer wants me to use a rstp url but apparently that is not supported.

The URL to the web interface is http://x.x.x.x/doc/page/main.asp. Using that in Haiku, I get "HTTP/1.1 200 OK Please verify that the URL points to a valid MJPEG stream".

What URL should I use?



#2 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 05 December 2013 - 04:54 PM

I contacted the manufacturer and they gave me this URL http://username:pass...102/httpPreview

That worked to get video but Haiku freezes up after minute or 2.  I used the Hikvision app iVMS-4500 HD that uses H264 and it doesn't freeze up.



#3 lupinglade

lupinglade

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 1514 posts
  • Experience:guru
  • Software:Custom
  • Hardware:HAI OmniPro II, Custom
  • Tech:UPB, INSTEON, Z-Wave, ZigBee, Custom
  • Audio:Nuvo
  • Video:AirPlay
  • CCTV:ip, dvr
  • Phone:Asterisk

Posted 06 December 2013 - 05:32 PM

Does Haiku freeze or is it just that the video stops streaming?

#4 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 08 December 2013 - 10:22 AM

Does Haiku freeze or is it just that the video stops streaming?

 Both and if I wait, later I can get into other parts of Haiku.



#5 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 09 December 2013 - 10:57 AM

Just tested again. After about 3 minutes the app froze. Stayed frozen for 5 minutes until I exited the app. Went back into the app and there was no HAI data. Exited the app and went back in and everything was back to normal.
 



#6 lupinglade

lupinglade

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 1514 posts
  • Experience:guru
  • Software:Custom
  • Hardware:HAI OmniPro II, Custom
  • Tech:UPB, INSTEON, Z-Wave, ZigBee, Custom
  • Audio:Nuvo
  • Video:AirPlay
  • CCTV:ip, dvr
  • Phone:Asterisk

Posted 11 December 2013 - 03:00 PM

To diagnose this further, we'd need access to a sample camera via the Internet. Thanks.

#7 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 12 December 2013 - 03:48 PM

Access info PMed.  Thanks



#8 Fearless

Fearless

    Cocooner

  • Registered
  • PipPip
  • 18 posts

Posted 19 December 2013 - 05:35 PM

Is this a low priority or no priority?



#9 lupinglade

lupinglade

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 1514 posts
  • Experience:guru
  • Software:Custom
  • Hardware:HAI OmniPro II, Custom
  • Tech:UPB, INSTEON, Z-Wave, ZigBee, Custom
  • Audio:Nuvo
  • Video:AirPlay
  • CCTV:ip, dvr
  • Phone:Asterisk

Posted 20 December 2013 - 07:57 PM

We've looked into it and it appears the HTTP stream that this camera is providing is corrupt. You can see this corruption even in Safari and it hangs shortly after. You may need to use the Pull JPEG option in combination with a JPEG URL.

#10 Larrabee

Larrabee

    Newbie

  • New Member
  • Pip
  • 2 posts

Posted 10 November 2014 - 05:22 PM

Hello, I know that this is an older thread, but I would like to know how this worked out.

 

I recently purchased a Hikvision DS-2CD2132-I dome camera, and it appears to be the perfect camera.  Good build quality, good features, good price, and it claims both MJPEG and H.264 streams.

 

However, like the fellow before me, I cannot get it working with Haiku.

 

When I enter: http://192.xxx.xxx.1...102/httpPreview into Internet Explorer, it prompts me for the user/password, and it starts to save a stream (does not view it).

 

When I enter this into Haiku, it claims "Connection failed.  Please verify that the URL points to a valid MJPEG stream"

 

I have the sub-stream aka MJPEG stream configured to Medium quality, 352*288 resolution, variable bitrate, 25 fps. max bitrate 512, and i-Frame interval of 50

 

I've played a little with these settings (although not everything).

 

1) Should this work?

2) What do I do to make this work?

 

Any help would be greatly appreciated.


Thanks



#11 Darkmcs

Darkmcs

    Cocooner

  • Registered
  • PipPip
  • 10 posts

Posted 09 January 2015 - 09:33 PM

Any update on getting the 2cd-2132-i working on Haiku or Space?

#12 lupinglade

lupinglade

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 1514 posts
  • Experience:guru
  • Software:Custom
  • Hardware:HAI OmniPro II, Custom
  • Tech:UPB, INSTEON, Z-Wave, ZigBee, Custom
  • Audio:Nuvo
  • Video:AirPlay
  • CCTV:ip, dvr
  • Phone:Asterisk

Posted 09 January 2015 - 09:58 PM

@Larrabee: I think you are using the HTML viewer page not the direct MJPEG stream URL.

#13 Matt1269

Matt1269

    Newbie

  • New Member
  • Pip
  • 1 posts

Posted 04 October 2015 - 11:35 PM

Has there been any recent updates to this? Is the httpPreview  link the best option?

 

Has anyone got an Avigilon camera working on Haiku or Space?



#14 heffneil

heffneil

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 635 posts

Posted 22 May 2017 - 07:53 AM

I have found that I can get the image preview to work one time.  In other words you can not have multiple clients accessing this image or it will crap out.  Not sure if there is a solution to this but it is severely limiting.  Not sure what has to happen or whats a better stream to work but I have found this will not work.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users