FireFox browsers do not function - Error 522

LarrylLix

Senior Member
Many have complained elsewhere about some browsers not functioning with cocoontech.com lately.
 
Apparently my FF version must have been behind in updates as the last two updates to FF over the last week or so has locked me out from reading the forums.
 
According to cloudFlare they get a reported error 522 from the website.
 
Sometimes it reports that the cloudFlare intermediate pop site is down also. Currently working with my Edge version but I try to avoid it usually.
 

LarrylLix

Senior Member
Seems many websites are beginning to complain about an "out of date browser" now with FireFox latest versions.
 
Strange how the newer updates have started to trigger this problem again.
 

LarrylLix

Senior Member
Looks like the forum coders have fixed something for FireFox now. Mine just started working again! I don't think FF had any updates since.
 
Thanks!!
 
 My mistake. I got suckered into loading Edge by mistake and FF still cannot access this forum.
 

LarrylLix

Senior Member
Looks like the forum maintainers have included the necessary hooks for FireFox browsers again!
 
Yay! Welcome back to me!
 

pete_c

Guru
Newest version Firefox in Linux here still does not work with CT if I log in to the forum.

Not logged in to the forum I can browse the entire forum with no issues.
 
[sharedmedia=gallery:images:1509]
 
Chrome continues to work fine and today accept using Chrome in Linux / Edge on Windows 11 on the CT forum.
 

LarrylLix

Senior Member
Yup. FF only worked on a slip through. Next time it was rejected by the server again.
 
FF released a new version but still no acceptance from the forum server. It just doesn't answer the requests.
 
Eventually the junk browsers (edge and chrome was removed a year ago) will be removed from my machine.
 

xtbjeff

New Member
I thought cocoontech had disappeared like some other automation sites because it would no longer come up on Firefox.  Today I was purging obsolete bookmarks, and I thought I'd find out what had happened to coocoontech.  Apparently the problem is it just doesn't work with Firefox, which is the only browser I normally use.  So I tried accessing with Edge and here you are.
 
Those using X10 automation may be familiar with the products I've designed.
 
xtbjeff
 

samgreco

Active Member
I'm not convinced that it's Firefox.  My FF install at home has not been able to access Cocoontech for some weeks.  But my FF install at the office has been working the whole time.  I'm starting to think that Cloudflare is the real culprit.
 
But who knows.  At home, I fire up Chrome to access, while I stay on FF at work.
 

pete_c

Guru
I gave up using Firefox here for Cocoontech many years ago.  I can browse the forum if not logged in but cannot if I am logged in.
 
Nice to see you here Jeff.  I am still using your stuff here for my X10 connected to my HAI  / Leviton OmniPro 2 and Homeseer software.
 

pete_c

Guru
Tried Firefox 102.0 (on Ubuntu laptop) this morning.  I was able to log in and post this.  It is slow and working today.
 
I have the Ghostery add on running in Firefox.  I use Firefox in Windows 11 on my tablets and I use it all the time with PIA.  I have not tried Cocoontech with it though.
 
Using a PFSense + (commercial version) Firewall here at home with pfBlocker, ClaimAV, Snort and DNS resolver running.
 

pete_c

Guru
I would suggest that you do not use Microsoft DNS or ISP DNS servers or Celluar DNS servers.
 
When surfing here on my Android phone / Windows 11 tablet I typically VPN to my home and use the PFSense server out to the Internet. 
 

xtbjeff

New Member
I tried Firefox again here, but no go.  This is the only website that I receive that 522 error.  The error occurs on two different computers, running Win7 or Win10.  Cloudfare indicates the error is between them and the cocoontech.com host.
 
Thanks for the feedback on our X10 stuff.  I just released the XTB-XM to provide an alternate X10 interface for controllers like the Smartenit Harmony that use the discontinued Smarthome IM.
 
Jeff
 

pete_c

Guru
Tried again this afternoon and Firefox did not work.  It's been an issue for a few years now.  Geez thought it was working.
 
[sharedmedia=gallery:images:1539]
 
I use mostly Chrome these days for Cocoontech.
 
Top