Humidity sensors locking up Henriksen software


Hard to tell on the reading error part. But I was reading the DS2438 data sheet, and noticed that there is a A version that doesn't support the 'sleep' mode. I happened to have some samples of those, so I replaced the DS2438 in that sensor. I looked for a bit with the OneWireViewer, and didn't see any sags, so now I've gone back to my wserver s/w and will see what happens.

On my cable, I'm using cat 5, but using one wire from each pair, rather than a single twisted pair. Less common mode rejection, but less capacitance, which I wanted, given the distance.

(** Update: Just after I posted this, I looked at the s/w and noticed a low voltage error again. However, this time, when I monitored the VDD A/D input, although it did detect a low voltage, it had gone back to normal. So after 1 error, the DS2438 went back to normal operation. Maybe the sleep mode was somehow being triggered by environmental factors. In any event, if this solves it, I will switch out all my DS2438s with the A version. I sure hope this is the answer..... I can live with an occasional error, but can't put up with a locked up situation)


Well, I guess I should put closure to this, even though this problem seems specific to me ;)

So, after almost 2 days running with the DS2438A chip, the problem appears to have been solved. During that time, I've had 5 voltage sags, probably caused by electrical glitches on the long run, but in each case, the chip did not lock up (or go to sleep, I guess) and continued to operate. And so the Henriksen s/w never got into that 10 error/100% CPU condition.

I would have to conclude at this point that something was causing the old DS2438 to go into some lockup or sleep mode. Given that this happened on 2 different chips, it would seem to be design related. The sleep mode seems to be the most logical conclusion, since the problem did not occur with the new DS2438A chip, where the only difference is that it doesn't have the sleep mode.

Thanks for the folks who tried to help. Hopefully my problem will help someone else with theirs, but for now, I'm happy that I can leave my weather station running without having to babysit it!


Active Member
Did you monitor the source voltage being fed down the 100' wire?

Is the current rating high enough on your power supply?

Is there a problem with your 100' network cable somewhere along the line like a cut/nick?

Just throwing out ideas.

I had a 19volt 1.5 amp DC adapter that came with a Direc PC satellite system.
I feed that to my HB 6 channel master hub and it pumps out a very solid voltage to all my devices.


I actually don't feed power down the 100' wire. I have a local DC PSU in the shed that feeds the power to just that sensor in the shed. You can monitor the voltage using the built-in A/D, and it's always solid, never varying. I just think that there may be spurious glitches that are picked up on the 1-wire line that was causing the sleep mode.

System is running great now.