PFSense on a Qotom Q310P mini PC computer

Thank you Morgan.  I forgot to document TTL-RS-232 device.

Here is a picture of concoction.  (total price around $14 USD which was cheaper than the Sure GPS)
I had a magnetic tiny GPS antenna sitting around with a 12 foot cable. The media panel is near a basement windows with a SW exposure so will be mounting GPS on media board and using external GPS magnetic antenna.

Purchased one of these from Amazon.
Uxcell a14041500ux1216 MAX232CSE for $7.37
Wired PPS from GPS to Pin #1 on the above mentionsed TTL to RS-232.
Then noticed that the 4 comm ports were disabled via the BIOS.  Enabled one com port (first one).
Then saw traffic via cat cuau0 serial port.
and checked via ntpq
ntpq> cv
associd=0 status=0012 1 event, clk_bad_format,
device="NMEA GPS Clock",
timecode="$GNGLL,xxxxx", poll=89,
noreply=0, badformat=1, baddata=0, fudgetime2=400.000, stratum=0,
refid=GPS, flags=7
and checked status of NTP server via PFSense and see that it is working fine now.

So I am now done with the GPS / PPS part of this little project.
Next the UPS and connectivity to PFSense UPS monitoring.

Wanting to mount the UPS on a cement wall looking for a metal shelf now.
Nice to see others using pfsense. I switched over about 9 months ago. I'm running it on a HP T620 plus thin client. I also moved to Ubiquity access points a few months ago.
Been using PFSense now for over 10 years....and before that used SmoothWall....
Just recently switching WAP's to Ruckus from Ubiquti...purchasing Ruckus #2 in the next couple of weeks...
CommScope owns Arris and Ruckus...
Ruckus WAPs
6th of July, 2019
Got a headless boot issue.  Looks like PFSense now will not boot without a monitor attached.  It was booting.  It is not related to the bios.
I do not know what I did to the build.
Thank you LanBrown.  Never seen this issue before with any of my PFSense boxes.

The current PFSense box running on an Intel i5 has been doing fine for years.

This box is currently a test box inside of my network which is eventually going to a family member's network.
Ordered a dummy VGA plug this morning from Amazon.
It was working fine headless until I tweaked it a bit.  I read about a bug relating to PFSense and VGA boot and Atom based CPUs.
I disabled the VGA console boot and it did boot headless one time.  Now it is not booting.  Might edit the config file ...found some references...

OK so edited the /boot/loader.conf with this line on the top:
You can use ssh and vi to edit or sftp to the box and edit it via my linux laptop.


Optionally can also add:


It reboots fine without the VGA monitor plugged in.

Trying a halt and cold boot next.

Works warm boot and cold boot using the "kern.vty=sc" option in the /boot/loader.conf file.

/boot: cat loader.conf


GPS is still working although I want to change it some.

/boot: ntpq
ntpq> cv
associd=0 status=0012 1 event, clk_bad_format,
device="NMEA GPS Clock",
poll=80, noreply=0, badformat=1, baddata=0, fudgetime2=400.000,
stratum=0, refid=GPS, flags=5

The GPS is currently set for NMEA 4.0 and I might change it NMEA 2.0.  I am not getting number of satellites seen right now and was able to before.

Next adding and modifying SQUID, NGBlocker, SNORT and VPN.

Just doing a side by side comparison to my current PFSense firewall.
8th of July, 2019
I did not like that the micro USB passed data and primarily using the RS-232 / PPS for NTP.
I want to power the GPS via the microUSB port on the GPS to the USB port on the computer.
So purchased a data blocker for a power only connection.

Configured PFBlocker, Snort and Squid today.

Ready to move this week which will involve XFinity customer service.

Final tweaks will be done remotely.
pete_c said:
/boot: cat loader.conf
Fwiw, mine reads:

I had tried to find a way to get a screensaver to time out, in order to be able to leave a monitor connected to it.  I never figured that out to my liking, so I just gave up and left it unconnected.  It's been working fine and everything I've wanted/needed to do has been available from the web pages, so I didn't push further.

It's been VERY nice having a rock-solid and fast router for my uplink.  Just set-and-forget with no hassles.
Thank you Bill.
Yesterday finished the small piece of plywood mounting stuff next to the fuse panel for this set up.
I will take a picture.  There will be no monitor connected.  Basically it is a:
1 - mini Leviton media can - just patch panels inside
2 - 8 port Gb switch
3 - ISP modem
4 - PFSense Firewall
5 - POE power injectors for WAP, Ooma box and Panasonic DECT telephone base
Next is the UPS stuff (which will also be connected to the PFSense box).
The RS-232-TTL device is so small may just use heat shrink tubing on it.
Looking now for my personal PFSense replacement box which will also be similiar except that I want VGA / HDMI, serial ports and 6 NICs on it (AES capable).
Seeing barebones boxes for under $200.
4th of August, 2019 - Update
Updated the GPS board with the Windows Software and it is working well now.
The issue I had was that for whatever reason PFSense wasn't showing number of satellites and position coordinates.
This was related to two NMEA sentences.
Mostly guessing here just kept making changes to the firmware of the GPS board and after a bit of tinkering it worked.

I did change the default GPS boot serial speed to 19200 and will change it back to 4800 as the boot configuration in PFSense sets the speed to 4800.
Will post configuration screens used. 
Here is the PFSense screen with the GPS location info.
Here are the screens for the modifications to the GPS that I used such that I would get number of satellites and position / altitude in PFSense.

Fwiw, mine reads:
Thank you Bill.
I had tried to find a way to get a screensaver to time out, in order to be able to leave a monitor connected to it.  I never figured that out to my liking, so I just gave up and left it unconnected.
Current test box does not have a monitor connected to it.  That said you can set the sleep on the monitor via the Qotom bios.
I am now done with the box and getting ready to move on to other stuff I am installing there.
1 - UPS - for ISP modem, switch, PFSense box and a couple of POE connections.
2 - WAP POE connected.
3 - Panasonic DECT main phone base and Ooma box will be POE powered from the basement.
Last week install a Roku box and configured it for Netflix and Amazon AOD. 
Also installing a customized TVBox with Kodi and a very limited simple menu. It really is a micro NAS box that I am using there.
So TV gets Satellite TV and OTA plus added Roku box and Kodi. 
So ordering a:
1 - UPS
2 - POE WAP (Ruckus)
3 - 2 POE power splitters and 2 POE injectors
Next will be switching from XFinity security to using the Amazon Show and Amazon Ring security (all wireless).
8th of August, 2019
Still very slow going here...
Ordered to install next week:
1 - ARRIS SURFboard (32x8) DOCSIS 3.0 Cable Modem, 1.4 Gbps Max Speed, Certified for Comcast Xfinity, Spectrum, Cox, Cablevision & more (SB6190 White)
2 - Ruckus Wireless ZoneFlex R500 Wireless Access Point (Dual-Band 802.11ac, 2x2:2 Streams, BeamFlex+, Dual Ports, 802.3af PoE) 901-R500-US00
Thinking of installing the Ruckus in the main floor coat closet sort of center of the home. 
For installation of the PFSense box initially was going to bring a small VGA monitor just for configuration.  Might instead mount a small 8" POS monitor on a stalk and just leave it there for future use.  It is a touch screen that I never used and has a small footprint and a nice bracket.

Considering purchasing a Qotom 6 port AES-NI i-series box for my use to replace my DIY'd Haswell CPU 6 port PFSense box. I want to move the PfSense firewall over to the Leviton 42" media panel and off the server rack.

I promoted the Qotom boxes a few months ago on Homeseer. In a dialog presently with one CT user who purchased it via Amazon and paid the $30 something shipping for it. Appears to have a video hardware issue and Qotom is giving him a run around. I purchased the one mentioned above from a reseller here in the US. It has both the resellers tag on it and a Qotom tag on it.
I would suggest you look at a different cable modem.
It says 1.4Gbps but it has a single 1Gbps LAN port.  Much more importantly, it uses the Puma chipset.  Apparently there is a fix for the packet loss but there is also a class action lawsuit:
The fix would need to come from the ISP as well.
What speed Internet service is being used where it will be installed?  If say they only have 300Mbps service, I wouldn't be spending the extra money to get one capable of 1.4Gbps.
I ry to stay away from Arris products as I've seen plenty of issues with them.  A couple of examples, they have had issues with DMZ modes.  Some of this has been corrected as they bought two other companies and both were able to offer a DMZ mode whereas the original Arris products had issues.  Next, on a gateway you could see ARP requests on the LAN side for WAN traffic.  Given that Arris has bought both Pace and Motorola (SurfBoard) I wonder if they kept the original developers or have their own handling firmware these days.
Thank you lanbrown.
Yeah purchased the second SB-6190 modem a couple of days ago.  (great Costco openbox deal of $40 with free shipping). Initially it appears to have been introduced in 2015. Hopefully by now they have fixed the bugs in the modem.
This is the second one purchased in the last few months.  I've always used/owned Surfboard modems with my Comcast / XInfinity ISP.
Current version stuff is:
Standard Specification Compliant ARRIS DOCSIS 3.0 Cable Modem / Retail
Hardware Version 3
Software Version 9.1.103AA45
Most purchased it relating to the 32 downstream / 8 upstream channels.  I am 150Mps down and around 10Mps up.
Noticed that I do only get 4 upstream channels.
Have not seen any latency issues to date. 
Wow...didn't know about the issue with the Puma chipset.
Looking at the PFSense box I see no packet loss or latency issues with the two Surfboard SB-6190 boxes today.
That said don't really push them here much.  Noticed too that the SB-6190 firmware today has little features that I can change.
Watching the dialog between Qotom and CT peer and Amazon.  Sort of looking like it PITA to deal with them.
Problem with Qotom box is bad VGA video.  Working but very distorted image.  Good VGA monitor and cable are being utilized.
It is a barebones with new purchased memory.
First email via Amazon. 
Product name: Barebone Q150P Intel Celeron J3160,Quad Core,Up to 2.24 Ghz,AES-NI Barebones 2 LAN,3 Display,1 Com,6 USB,Act As A LAN Or Wan Router
Hello user,

Don't worry, pls open the case to re-insert or replace a memory to test.

It supports 1333/1600GHz DDR3L 1.35V ram.

Any question, pls contact me.

Best regards
Second email:
Hello user,

Pls sure the memory can works well, does it can works well on other computer ?
If possible, could you give me a test video ? my skype is qotom03 , if our engineer can't solve it on Monday , we can send a replacement motherboard to you, is okay?

Best regards