M1EXP, ElkRP2 and HyperV Ethernet on Windows 10


Active Member
This is an FYI (though if someone knows why let me know).
I rarely use Elkrp2, maybe 2-3 times a year.  I went to use it today and it would not work.  It kept complaining that my network interface was not selected or working.
Well, it wasn't selected -- I had changed to configured HyperV on my Windows 10 workstation, and was using a shared NIC, and the name had probably changed from the last time.  No problem, selected -- still wouldn't work. It alternated between crashing and just saying it was not there.
I had a spare NIC, so brought it online and configured, and used that NIC instead.  Worked perfectly.  Same subnet by the way.
Afterwards I went back and tried both again - consistently the HyperV shared NIC does not work, the regular NIC does. Note I am running ElkRP from the host OS, not from a HyperV guest, in fact all guests were shut down at the time.
Just in case anyone else gets stuck with something similar.
ElkRP 2.0.34 on Windows 10 x 64.
Might be looking at the guests as teaming/shared NIC even though the VM's are not running. I'd try disabling in the guest VM's and see where that gets you. Also look at your virtual switch.