M1XEP does not seem to connect to M1G


Active Member
Everything was working fine for years till a few weeks ago. 
I have an M1G with the XEP connected. I have Indigo set up on my iMac that communicates with the M1G to run automations and such. 
Indigo stopped being able to connect a while back I am just getting around to working on the problem. 

I set  up RP on a Win 7 VM and when I go to "M1XEP setup" I can find the XEP. It shows up with an address and with the name I gave it years ago. All good so far. Then when I try to connect the RP via the network, I get this error. 
Conection error: Could not connect.
Possible reasons: The port is not forwarded on the router
The IP Add ress or URL is incorrect. The remote site is down
It seems like the XEP is running but not connecting to the M1G. 
I tried reenrolling from the kepad, but it just gives me that KP1 Error Comm message. 
 have done some basic stuff like check and reseat all connections, rebooted both the M1G and the XEP multiple times. No change so far. The XEP has a steady red light on the board next to where the power is plugged in. The ethernet port on the XEP has one solid and one flashing light. 
I ran XEP Diagnostics 1.1.0 and when it first comes up, it sees a device at When I look up this device on my router, it has a different MAC address than the XEP.
After hitting next a couple screens, it comes back with My net is set up with 192.168.1.xxx, so this seems odd. 
After next again, it says:
Could not get remaining setup data from the M1XEP, probably
because The M1XEP's firmware is older than version 1.3.24.
Other possible causes are:
Windows Firewall or another program is blocking access.
The reply took longer than five seconds.
The M1XEP is rebooting or synchronizing with the M1.
The M1XEP is on a different subnet than the computer or their subnet masks differ.
I disabled Windows firewall. no effect. 
I have not had to mess with the system in years, so I am totally stumped. Any help would be most welcome. 
Can you set your IP address manually to something on 192.168.0.x and see if you can reach it at the above IP?
I think it defaults to that subnet if DHCP isn't working.  Is your XEP set on DHCP?  Maybe just a reboot of the XEP will help; maybe it lost connectivity.
Have you used this W7 VM to connect before?  I know we had trouble going to W10; I don't recall any W7 issues - but I didn't keep up either.  A known-good computer would be ideal to try to access it.
Just some thoughts to throw out there.
An IP address of is the default IP address that the M1XEP will use if it has not been set up to use DHCP and a static IP address has not been programmed.
What MAC address did your router show for the XEP? 
There was a bug in older firmware levels that can cause the MAC address to change at random, and that can cause it to suddenly not be recognized.
If you have not touched the XEP in years, there's a good chance that the firmware is back level. That will cause problems with trying to connect with Windows, whether you are running Win7 or 10.   The older XEP firmware uses SSL protocol for communicating over IP.  SSL has security problems and has been abandoned by Windows and most browsers in favor of TLS protocol.  You'll need to upgrade the XEP firmware to version 2.0.42 to get support for TLS.
Report back with the firmware levels of your M1, XEP and the XEP's MAC address and maybe we can figure out what you should try next.
RAL - you may be more familiar than me... I know W10 couldn't connect to the XEP due to the SSL changes, but I thought it was fine with W7?  Or did W7 get an update that killed it off too? 
Work2Play said:
RAL - you may be more familiar than me... I know W10 couldn't connect to the XEP due to the SSL changes, but I thought it was fine with W7?  Or did W7 get an update that killed it off too? 
There was a time when Win7 would still work with the XEP, while Win10 would not.  But somewhere along the way, it seems like Microsoft must have pushed out an update that killed it for Win7, too.  The various browsers also disabled support for SSL, but if you know what configuration parameter to change, it can be re-enabled.  Not sure if there is a way to re-enable SSL in Win7 itself.
Thanks for the suggestions. 
I'm trying to get some time over the holiday weekend to dig into this more.