• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

PC Access 3.17 Unhandled Exception Setting Clock Omni Pro II

SilverJA

New Member
I'm getting the same error.  Although my pc crashed and I had to reinstall PC Access, but I'm stuck on version 3.0, so I assumed that was it.  When trying to update, it can't find "PCA3D_EN - 0version.xml".  Can't find any other download links to get off 3.0.  I don't understand why it's so hard for me to find.
 

SierraTech

Member
ctuinstra said:
I'm having the very same issue.  This is a programming issue with PC Access.  A kind of Y2K issue, the programmers didn't think that it would be used in 2021.  I'll bet if you set your PC clock back to 2020, it will work.  I would try it but, I don't want to set my controller back that far and not be able to correct it.
 
Hopefully Levitron hasn't slammed the door on Omni just yet and they will consider fixing it.
ctuinstra
 
Did you try it last year?  I have been having ALC intermittent issues (haven't got into it yet), and after Resetting controller a few times I noticed time lag. 
 
I don't ever recall attempting to update Time last year, so I'm not convinced it ever worked on 4.0B.
 

ctuinstra

Member
I talked with Levitron tech support and before I could even explain the issue and soon as I mentioned time, he interrupted me and finished the sentence.   They know all about it and he said they are working on it.  Keep checking for updates and hope it's taken care of soon.
 

SierraTech

Member
@ctuinstra
 
Good News!
 
I tried to send you a private message with download link for Dealer PC Access, but cocoontech system won't allow me to send you a message yet.
 
I need to also determine why my ALC board keeps going offline, since I updated firmware last year.  Might not be a firmware issue, but didn't start having problems until 4.0B.
 
-Bob
 

pete_c

Guru
Good news!!!
 
Over the last few years here noticed that Leviton over wrote some old basic embedded routines / functions from their legacy Omnitouch serial touchscreens when they added the email board and Omnitouch Android screens.
 

xlurkr

Active Member
Speaking of which...
 
Pete: do you know which version of the firmware was the last one to support analog video to the small touchscreens?  Like you (I think), I have the board that supported the small touchscreens with video.  They still work, but the videocam display doesn't.
 
-Tom
 

ctuinstra

Member
SierraTech said:
@ctuinstra
 
Good News!
 
I tried to send you a private message with download link for Dealer PC Access, but cocoontech system won't allow me to send you a message yet.
 
I need to also determine why my ALC board keeps going offline, since I updated firmware last year.  Might not be a firmware issue, but didn't start having problems until 4.0B.
 
-Bob
 
That would be awesome.  Four 15 years, I didn't even know there was a Dealer version.  I've been having a lot of issues with my X10 and was thinking of switching over to PLC but need the dealer version to set that up.  I'll keep posting until you can PM me.
 

pete_c

Guru
do you know which version of the firmware was the last one to support analog video to the small touchscreens?  
 
Last version of firmware supports the old serial OmniPro 5.7 and 3.5 screens just fine.
 
The analog video ran on one of the wires.  IE: power, RX, TX, Ground and Video.
 
I used an Omnitouch / video hub.  I also used an IP to analog video device to get the IP video over to the screens.
 
What didn't work was the pop up analog video when the doorbell rang and that was fixed.
 

gym4im

Member
I too had the issue a few days ago. I was in the midst of trying to set up a UPB Module (in another post), installing a new Omnistat RC-1000 and I had the same error message. The entries in the Time and Date fields n PCAccess said something like "RESET THE TIME AND DATE".  When I clicked the field the error message came up. I continued with my Lamp Module problem and eventually forgot about the time and date problem. I just went back in and it as displaying the proper information. However, when I clicked on the field, the same error message came up. Will also write support. I have version 3.17.0843. 
 
P.S. My ALC light have not worked for 2+ years. They all of a sudden stop working. Switching to HUE as they control the Outside Floodlights and switches are in garage where the previous owners only ran two wires to...so had to use ALC.
 

pete_c

Guru
For configuring UPB go to Upstart and configure it there and put the unit number in your PCA configuration.
 
That said a UPB switch needs a neutral wire in the box.
 

ctuinstra

Member
Still no update.  Now I am finding another issue and can't help but think it may be tied to the clock issue.  I have almost 400 lines of automation programming and wanted to add another button and action.  I can create the button and upload everything to the controller but this button will not show up on the consoles nor in SnapLink.  Clearing the new button from the file and reading the setup from the controller confirms that's it's not programming the controller.
 
I set the clock back on the PC used for programming to year 2020 (same day and time) and sure enough it will program just fine. This is another issue with the date/time not supporting 2021.
 

ctuinstra

Member
It's finally here!   The update was just released.   version 3.17.1.856
 
 
The new version that fixes the time issue (and I assume the failure of writing a new Setup configuration) is out as of today, 02-08-21.   The release notes state that it was released on Friday, January 22, 2021; but it probably had to go through some beta testing first.   I confirmed the time/date update does work now.

No new release on firmware on the controllers. Other options/boards may have a new release, I don't bother with those since I don't have any.

 
 
 
Here is a copy of the release notes:
 
PC Access Version 3.17.2.858 (05/January/2021)
 
- Fixed issue with dates beyond 12/31/2020.
 
--------------------------------------------------------------------------------
PC Access Version 3.17.1.856 (01/October/2020)
 
- Removed serial number and product registration requirements.
 
--------------------------------------------------------------------------------
PC Access Version 3.17.1.853 (20/March/2020)
 
- Fixed TLS issue on check for updates form.
 
--------------------------------------------------------------------------------
PC Access Version 3.17.1.852 (24/January/2020)
 
- Added TLS version 1.2 support.
 
--------------------------------------------------------------------------------
PC Access Version 3.17.0.843 (2/January/2018)
 
- Updates for Windows 10 security changes.
 

JonW

Senior Member
I just checked for updates and was able to get  3.17.1.856, but not the newer version. :(
 

ctuinstra

Member
JonW said:
I just checked for updates and was able to get  3.17.1.856, but not the newer version. :(
I just. Otuced that I think their release notes are wrong. The version I posted 3.17.1.856 is what was just released and fixed the time issue. Have you tried to see if you can update the date/time?
 
Top