Windows Media Player not playing video


Senior Member
Recently my Windows Media Player 10 on my development laptop will no longer play video files. I double click on the file and it shows the first frame still. If I modify any setting in the settings field the video plays. Select the next video and it only shows the first frame. The sound is fine just no video. Any of you guys ever experienced this? I rolled back to WMP 9 and have the same problem. Roll back to 10 same problem.
I bet you have a bad/incomplete codec install, or windows is not picking the exactly right codec for the video you're trying to play. It could also be that your hardware acceleration got turned on/off (opposite of what it was when it was working).

I'd try checking hardware accelerations first, as it is the least invasive.

To fix hardware acceleration, open WMP and click "tools," "options" then select the "performance" tab. From there, click the "advanced" button, and play around with the various check boxes, and try your video(s) again and see if they work.. There may be 10+ different possible combinations of these checkboxes, and who knows which will work.

If it's a bad codec, see this: on how to remove codecs. After you remove a codec, the next time it's needed, WMP shoud attempt to download the appropriate codec. You can also do a search for "codec cleaner" or "remove codec" on google and turn-up some utilities that may do this better.. maybe even some that will identify the bad codec.

There's also a chance it's your video driver. You can try to uninstall and reinstall the driver.

It could also be a combination of any of these. I had a similair problem about 2 months ago, and doing any one of these did not fix it, but after unisntalling EVERY video driver and codec on my system, and then reinstalling only the ones I needed, it fixed everything (and I think my video performance is better than ever). There are some driver cleaners you can google for that will remove all the unused video drivers from your system (for example, I had all sorts of nVidia and ATI drivers on my system but only needed a specific nVidia driver).

It's also common to have 3 or 4 codecs capable of decoding the same media types. I think it's best to keep the bare minimum to play just the media you want. ZoomPlayer makes it easy to see what codecs are linked to what mediatypes and to adjust registry values for them to prioritize them (for example codec 1 plays media A and B, while codec 2 plays B and C... you could set the priorities so codec one always plays media A and codec 2 always plays B and C). I do not know how to do this outside of zoomplayer, but I'm sure its possible.
I had a very similar problem, took me months to figure this out, and was extremely frustrating. The problem even remained after rebuilding my system. I did figure it out, but not sure if you have the same issue. I have an nvidia based graphics card, which has both vga and dvi out. This forced the system to detect 2 monitors for some reason, and my primary monitor was appearantly considered monitor 2. After changing that back (I never changed this), it started working again, so try fiddling with those settings. Not sure what happened, but worth a check.