Amazon Echo control UPB lighting - Have Elk M1

pete_c

Guru
Relating to Homeseer 3 there are two UPB plugins available.  (and 3-4 scripts / plugins relating to the use of the Amazon Echo).
 
Homeseer 3, Elk M1 plugin, UPB and Amazon Echo (and now Google Home) all work fine and easy together.
 
Why work and do this the long math way?  As mentioned above Homeseer 3 Zee is available today for less than $100.
 
The limitation to Homeseer 3 Lite (Zee2) is 5 plugins and today Homeseer Touch and Amazon Echo integration is included in the core HS3 OS.
 
The ARM CPU architecture is quite different to a x86 CPU Architecture so any comparison is largely meaningless.

Though as we are playing fantasy would say running Windows XP on the last of the Pentium 4 Socket 478 CPU is a "reasonable" comparison when undertaking Web Browsing and Office Suite tasks in the latest Raspbian Jessie with Pixel.
 
The Homeseer 3 lite Zee2 program will run on any Linux computer with Mono installed.  It is not just an RPi Wheezy or Jessie program.  IE: Homeseer Zee2 will only run on Linux / iOS while Homeseer Standard / Pro run on Windows, Linux or iOS.
 
For granular tinkering with the Zee2 you should be familiar with Wheezy or Jessie and Linux and the Homeseer 3 program.  Homeseer 3 runs using Mono for Linux.  You do not really need to be familiar with Mono rather just Linux.
 
For scripting using Homeseer 3 you can utilize just about anything that runs in Linux plus native Homeseer 3 VB scripting. (here also utilize bash, perl and python).  Native too are some commands that you can compile from C right on your RPi.
 
The free one was never really updated much and the paid for UPB plugin which works fine.
 
If you have an OmniPro 2 you can talk to the UPB via an Omni Plugin command to a unit and or using the two UPB Homeseer 3 plugins.
 
Adding the HAI Logger to the mix you can also utilize the Samsung Smartthings hub.
 
IE: here have multiple UPB PIMs configured.  (Homeseer 3 (2), remote serial -1 , OmniPro 2 Panel - 1) mostly configured to tinker with and check signal strengths of UPB (no issues today).
 
Relating to using Homeseer 3 I have configured remote RPi's with a ZWave GPIO, X10 CM11A and UPB serial PIM; all work fine using ser2net or running the plugin remotely...IE: mono homeseerplugin.exe server=ipofhomeseer.
 
Currently have a POE connected RPi2 in the attic with a ZWave GPIO card which talks to Homeseer.  Testing it is also running Domotize and a 1-wire network covering the second floor and attic temperature and humidity sensors.  Introducing another POE RPi2 with a Zigbee GPIO card to a bit more stuff.
 
I have no issues here using cheapo usb to serial devices, Digi Edgeports or a couple of EU USB to 4 serial port devices.  Doing this today for my 1-wire hub.  I see some stuff above using direct pins for a TTL connection to the RPi.  You can purchase a USB to serial cable or connector today for less than $10.  For the Homeseer stuff been mostly using Digi Edgeports, Digi USB Anywhere devices, Digi USB powered hubs...now for over 10 years with absolutely no issues.  IE: the big Homeseer 3 Pro mothership running headless is using one USB cable to one 7 port Digi powered hub to 5 USB devices and 2 Digi edgeports and works great.  Audio (multiple SAPI voices - VBs) is one wire to the the Russound system. 
 
Here have updated the RPi 2 Zee2 computer to running on a Pine64 2Gb machine with Ubuntu 16.04 64bit versus running Wheezy / Jessie or Stretch on the Zee2.  (under $50).  It has same pinouts as an RPi2 and includes an RTC.  Next update is to the Rock 64 4Gb machine running OS on an eMMC versus a microSD.  Also tested and working well was the Xi5a cube computer running with a dual AMD CPU, 2Gb of RAM and a 32Gb SSD drive.  It is larger than an RPi2.  I purchased a couple of these new old stock for $60.  I am hoping that the RPi4 comes with 2Gb of RAM and runs 64bit Stretch in the future.  I have turned my RPi-1's and RPi-2's in to little slaves hub and spoke like to the main Homeseer mothership. 
 
Homeseer Zee2, Homeseer Standard and Homeseer Pro had no issues running on the PipoX7 using an Intel Baytrail and 2 Gb of RAM dual booting to Windows 10 32bit or Ubuntu 16.04 64 bit Linux.  Many new Homeseer users are running Homeseer on the new Intel Skylake micro PCs today.  (Linux or Windows 7-10).
 
What I am starting to see is that many Homeseer folks are running hundreds of variables, events and triggers, 5 plugins, et al on the RPi2-3.  This does push a bit on the RPi as it is still a tiny computer with 1Gb of RAM.
 
Working on documenting next RPi project which will be posted as a blog which is using a software defined radio for downloading NOAA satellite weather maps with the POE RPi directly connected to a satellite antenna in the attic for direct downloading of weather maps (from satellite versus internet).
 
There is an SD radio project out there in internetlandia (you can purchase an SD USB radio now for less than $10) to be able to receive and utilize wireless sensors (and weather sensors) like or similar to the RFXCom receiver.
 
Relating to the above and Homeseer this makes integration of the Amazon Alex very easy.  Many Homeseer folks are installing Amazon Dot's on their ceilings for an Amazon Echo omnipresence.
 
Relating to the Wemo a Homeseer user wrote a bash script to sync the Wemo switches with Homeseer 3 using the Java Wemo bridge in 2015.  He found that the Belkin Wemo switches as fast as the ZWave switches and cheaper in Australia.
 
How to use Belkin Wemo devices with HomeSeer
 
Re Reading my post above it is kind of a splat of a bunch of stuff.
 
Original OP mentions
 
1st option would be the Alexa UPB bridge for $600.  Seems WAY OVERPRICED and limited
2nd option would be some sort of software controller like CQC or HomeSeer.  I guess you could buy Homeseer hardware controller as well.....I like CQC given the involvement of the company here on these forums.
 
added after original OP
3rd option would be the DIY offered options above.
 
Personally relating to the OP would be to utilize software integration for the Elk M1 / UPB and Alexa Amazon like CQC or Homeseer or a DIY solution using the RPi.  It is up to the OP.
 
Here biased to using Homeseer as I have utilized it since the 1990's.  Homeseer Elk M1 integration was provided to Homeseer 2 in the early 2000's by Randy on the Homeseer forum.  Randy upgraded his plugin to Homeseer 3 as soon as Homeseer 3 was available.
 
Free Homeseer 2-3 UPB integration came with HS2 and was ported over to HS3 a few years back and a paid 3rd party UPB plugin is offered updated to current UPB devices.  I have tested both and while the free UPB plugin works the 3rd party UPB plugin (Spuds) is much nicer and has many more features to it.
 
Homeseer Amazon Alexa integration to Homeseer 3 came days (literally) after release of the Amazon Alexa.  There is also a free Jon00 plugin available (and a couple of scripts)
 
and
 
Homeseer 3 Zee2 is / was available for 50% off putting the price to around $65.00 USD. 
 
RPi3 Zee2 including power supply, case, ZWave and HS3 ==> $65
 
Breakdown
 
1 - RPi 3 with case and power supply ~ $50.00 USD
2 - ZWave device ~ $40.00
 
You are getting the Homeseer 3 software for free with the purchase above.  If you want you can repurpose the RPi3 and ZWave device to making it a ZNet device (ethernet ZWave ZNet like device) and put the HS3 OS on any Linux computer and or another RPi2-3.
 

Desert_AIP

Senior Member
I'll piggyback onto what Pete is saying WRT WeMo performance (when emulated witht he RPi).
 
Since I had my breakthrough 2 weeks ago above, I am running an RPi emulating about 38 WeMo devices as of this typing.
 
They're emulated on a single RPi with a single IP address and separate ports for each device.
Some devices are duplicates to make the language more natural.
For Instance, "Floods", "Flood" (lights) and "Outside" (lights) are all separate Devices in Alexa with separate ports, but they all call the same action.
Same for something like "Kitchen High" and "Kitchen Bright".
 
This has been working very well and the response is very quick.
The UPB command gets sent before the emulator sends the response to Alexa, so the lights change before she replies "OK".
 
The only problem I had was in discovering so many devices.
Past about 12 devices she won't discover any more.
I don't know if it's an internal IP address limit or a timeout or why that happens.
 
I simply broke up the triggers into groups of 8.
Ran the emulator with only those triggers/devices/port numbers, and "discovered the devices"
Then I changed to the next batch of 8 and reran the emulator and discovery.
 
Alexa remembers the old devices and lists them as offline.
 
So after the discovery process, I added the complete list of triggers back in and ran the emulator.
They all work.
 
I have a second RPi emulating a single WeMo device that I use for voice control of the TV/Security camera feed.
 
They are working together seamlessly.
 

Desert_AIP

Senior Member
I got Homeseer loaded on an RPi 3,loaded the Omni plugin.
Spent about half an hour naming rooms and devices.
Told Alexa to discover my devices.
She imported over 120 items.

Lights, thermostats, flags, outputs, wow.

I haven't tried everything yet.

The light and thermostat control works very well and very fast.
Individual light control, on, off, dim - works perfectly.
Thermostat control, endpoints, etc. - works perfectly.

Need to test scenes, groups and other devices, but this is very promising. Much easier than the hard coding I was doing. I can see wanting to use the WeMo emulation in Some sod it if cases, like having multiple names for the same thing. Did a test and both HomeSeer and the WeMo emulation play together with Alexa. Running on separate RPis.

This is very exciting!
 

Desert_AIP

Senior Member
Played with the API extensively, the Homeseer/Alexa lexicon is very extensive.
These commands work perfectly.
 
Lighting loads:
 
Turn "Light Name" On/Off (snap)
Turn "Light Name" On at XX percent (this also works if light is already on to make it go to a new set point)
Dim "Light Name" to XX percent (works on a light that is currently on)
Bright(end) "Light Name" to XX percent (works on a light that is currently on or off)
Dim/lower/decrease "Light Name"  (appears to lower current light level ~25% increments [haven't verified with a status check])
Bright(en)/raise/increase "Light Name" (raises current light level ~25% increment) (will work on a load that is off)
 
When referring to lighting loads they word "light(s)" does not need to be in the Voice Command description box in HomeSeer, and does not need to be used.  But if it is used it will not create confusions, Alexa appears to ignore it if it is not part of the "Light Name".
 
So with a device named Living Room;
"Alexa, turn on living room.", "Alexa, turn on living room lights.", "Alexa, turn on the living room light.", "Alexa, turn on the living room lights." all produce the same result.
 
Thermostats:
 
Set "Tstat Name" to XX degrees (if in heat mode will set heating setpoint, if in cool mode will set cooling setpoint, if in auto mode sets both setpoints with the designated value in the middle.
For example in auto mode - "Set Downstairs to 68 degrees."  Sets lower setpoint to 66 degrees and upper setpoint to 70.
Increase/decrease "Tstat Name" (by) XX degrees.
 

Dean Roddey

Senior Member
That's still pretty limited. Unfortunately, because of how the Echo works, if you really want power via voice control you have to have a custom skill and you can't use the short syntax, you have to use the 'Alexa, tell xyz, to blah blah blah" form. Otherwise you are limited to basically just voice driven remote control.
 
If you use a custom skill, as CQC does, then you can have much more arbitrary commands and they can address things that don't fall into that simple lights, thermos, etc... list. So you can do stuff like (you can select whatever name for CQC you want, so I give some variations):
 
Alexa, ask Jarvis how many hours have the front sprinklers been running?
Alexa, tell Sally to power on the home theater
Alexa, ask CQC what is the highest temperature for the next three days?
Alexa, ask CQC if there are any bedroom windows open?
Alexa, tell Jarvis to set the home to party mode
 
And on and on. It's important to understand that none of those are built into the CQC support. You can create what you want. And each of them can do complex sets of operations to find out things or to coordinate devices to achieve some goal. You aren't limited to just say one thing to affect one thing. Each command has access to anything CQC has access to, but for control and for information query. And you can format whatever text you want to return to be spoken to the user, you aren't limited to canned responses supported by the built in stuff. And of course you can use whatever keyword you want. 
 
So, there's really two different worlds. They each have their pros and cons. There's a bit more syntax to the commands, but they are open ended and vastly more powerful.
 

macromark

Active Member
We just added support for Amazon's latest API (version 3) and that is undergoing certification now. We're also about to release a new version of HS3 that will take advantage of the new changes. One such change will now run events using the shortened syntax. Example: "Alexa, turn on the party scene" (where "party scene" is the name of the event). Another changes involves support for the new group feature. With this feature, you can add an Echo to a group, then add devices to the same group... and then control them with a single command. Now, you'll be able to turn on lights only in the bedroom speaking to the bedroom Echo and saying "Alexa, turn on the lights".
 
Anyway... that's close to release. Keep an eye on our forum for announcements.
 

bbrendon

Member
Don't listen to their advertising. Just get Home Assistant. It's better than all that crap. :)  (and it's free!)
 
...and yes. I'm advertising because they are!
 

Desert_AIP

Senior Member
I've created a monster.
I got voice control working very well.  My wife was reluctant to use it at first.
I changed the name of one device last night from "Christmas" to "All Christmas Lights".
 
I forgot to update the devices.
 
My wife got home and tried to "Turn on Christmas" and it didn't work and I got a phone call at work...
 
That's a huge WAF hit I need to fix.
 
First world problems...  :)
 

pete_c

Guru
@bbredon - I am impressed with Home Assistant.  Recently test installed it on one Ubuntu based tabletop touchscreen. 
 
Works great and have used Python for a while now. 
 
For automation tinkering HomeGenie, Domoticz, Almond plus, Samsung Smartthings and now Home Assistant. 
 
HomeGenie is doing the Mono thing to run it on Linux.  Domoticz primary does Lua. 
 
 
 
I am biased a bit to Homeseer as I have used it now since the late 1990's. 
 
Personally I would recommend that you give Homeseer 3 a spin.  It is like a swiss army knife of automation.
 
You can run Python scripts on HS3 if you want.
 
Top