Can't get Elk RP to connect to the M1


Active Member
I had my M1 all set up and working on the bench via the M1 XEP, had tested a few sensors, etc. So today I mounted it in the can on the wall and began to connect door contacts. But when I went to connect to it with RP, I get an error that the Remote Programming Access code is invalid. I did not change and have not ever changed it from the default 26801. It has always worked with no issues.

But now I'm getting this error whether connecting to the panel via the XEP or direct serial conneciton. I reset the panel using Globals 45,99 but still no dice.

Any ideas? There must be some way to default the code, no?
That default code is 246801.

Make sure you have allowed time for the XEP to reboot upon powerup, which can be several minutes.

Can you find the XEP through ELKRP's Find Routine?
I could find the XEP just fine. Also I was getting the same error with a serial connection. Anyway, I'm up and running now.

I had installed RP from CD onto my laptop and it was an older version which may have been the issue. I downloaded 1.6.12 and everything is working fine now.


Edit: Just notice I put 26801 in the post above instead of 246801. Makes me wonder if I was doing the same thing in RP. It was late and I'm on like Day 10 of 16 hour days so anything is possible. <_<