GRI2600 in a series on an Elk M1


Active Member
Hey guys, been a while! I have moved to the Elk M1 Gold for my new to me home. I installed some GRI2600's in some bathrooms I remodeled. I have 2 GRI2600 (NC) in my one bathroom in a series. It seems to work fine 99% of the time. The sensors are wired back to an expansion module connected to my main panel.

I have had 2 incidents now where 1. the sensor on the panel next to it (my laundry room) and the bathroom both tripped, but the others on the same panel had no problem - meaning I don't think it was a power supply for the GRI's problem. 2. the second time just the bathroom tripped. It reset almost instantaneously (the next minute) but it did actually trip despite no water in the vicinity of either sensor. Time number 1 - no one was home. Time number 2 - no one was near those bathrooms. Time number 2 the laundry room didn't trip at the same time.

Any suggestions on what to test or check for here? The time between time 1 and time 2 was about 10 days so no other pattern I can see.

What else is connected to your expansion module (trying to rule out loose wiring/terminations/expansion board issues). Secondly, I would check for loose wiring on your sensors. Wiggle the wiring (slight tug) on the wiring at the terminal connections.

How were the zones defined on the Elk system (0-12 volt input with no EOL?)? How are you powering the sensors? What else does this power supply provide power for?

For the wiring, you are powering the sensors in parallel, but the contacts are wired in series so you only use one zone correct? Are these the only sensors wired in series in your system?

Did you experience a large temperature differential in the home during these false alarms?
Last edited:
Hi! Thanks for the reply! There is nothing but GRI2600's on this board. Nothing else. They are defined as NC zones and show a status of short normally.

I am powering the sensors from an Altronix power supply and I don't suspect it is an issue since there are 5 more sensors on there that work without incident. What is strange that it happens to my daughters - all the time and others sometimes with it.

Today it occurred again: my daughters bathroom and the attic toilet. Not sure whats going on.
Ok I worked with Steve Hoh and he helped me with the total mess I had. Basically nothing was configured properly on my data bus. I HOPE this fixes the problem - only time will tell! I didn't have Jp3 enabled on the M1, I didn't have the Data Hub configured properly with jumpers nor did I have jumpers on certain keypads. A miracle that it worked at all!
Thanks. Its been what about 10 days? I hope not to jinx myself but since I updated everything it appears to be pretty solid!
So I KNEW - that posting would causing it to crap out - and it did this morning :( No idea whats happening. Its the last 3 zones that seemed to have tripped when it happens.