Elk M1 with ???? ???? for time and Date

I am in a bind. I leave for a week tomorrow and the wife wants the security system up and running. I need to get the time and date fixed. Can anyone help.


Just the date&time?

Menu 8, submenu 1 on the Elk keypad. Press the right arrow after selecting the date to enter date/time, use 2 digits for each. * to exit.
Thanks but I tried that. As soon as I type in the month it kicks out to main. I also tried to download time & Date from RP and no joy.
did you hit the right arrow to get into date/time mode (and not select day-of-week)?
You probably need to reset the clock chip.


The solution to unlock the clock and reset it to running condition requires that it be totally powered down. Use the following procedures:
A. Remove the M1 cover (it may be easiest to remove the board from the box first).
B. Then slip a small piece of paper in between the coin cell battery (upper left corner) and the metal clip that holds it in.
C. Leave this paper in place and turn off the M1 power switch.
D. After 15 seconds, turn the power switch on and remove the paper.
E. This will unlock the clock and allow it to be set from the keypad or from the Elk-RP software.