• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Elk M1G lost all keypads - debugging tips needed

kbmyers

New Member
Hello - my M1G system has been running trouble free for quite a while now, but yesterday each keypad came up with the error:
KP Addr-> 1
Lost Comm.
 
Keypad 2 has the same error, and neither respond to keystrokes.
 
I can connect to the ElkRP software, and the log has the following entries:
1141 = EXPANSION MODULE TROUBLE  Keypad 1
1141 = EXPANSION MODULE TROUBLE  Keypad 2
 
I pulled the keypads off the wall and tried unplugging each to see if I could isolate the problem, but no luck.  The wiring looks good and all the crimps are solid.
 
Suggestions on where to go next?
 
Thanks,
Kent
 
 

RAL

Senior Member
I would start by disconnecting every thing from the data bus - all keypads and any other devices such as expansion units.
 
Connect a keypad to 12V power using a short cable, but don't connect the data bus wires.  Power things on and see if you can get it into address setup mode by pressing the "*" key for 10 seconds.   Set the address to address 1, and then press the exit key.  
 
Power down and connect the data bus wires.  Make sure you have a termination jumper on the M1 and on the keypad.
 
Power back up and see if it will work with just the one keypad.  If it does, then try setting up the next keypad to address 2, and daisy chain it to the temporary data bus connection.  Make sure you have the terminator jumper on the last keypad.    See if things work with the 2 keypads.
 
If things won't work with just the one keypad, then substitute another keypad (also set to address 1).
 
If you can set the address on one or both keypads, but the M1 isn't able to talk to either one, you could have a problem with the M1 itself.
 

kbmyers

New Member
SOLVED:  After working through all of the combinations of keypads, and testing all the wires and checking the resistance I finally got it resolved by replacing the power supply.
 
I had forgotten that about 4 years ago I had other, inexplicable behavior that was solved with a new power supply.  From now on that is going to be my standard first debugging step.  I'll probably just get an extra one to have ready.
 

bucko

Active Member
You can always open the Elk debug window and see whats going on realtime. 
To do this.......
[SIZE=11pt]·         [/SIZE][SIZE=11pt]Open your account[/SIZE]
[SIZE=11pt]·         [/SIZE][SIZE=11pt]Connect to the M1[/SIZE]
[SIZE=11pt]·         [/SIZE][SIZE=11pt]On the left hand side of the screen scroll down to “ + Automation”[/SIZE]
[SIZE=11pt]·         [/SIZE][SIZE=11pt]One single left click of your mouse below “+ Automation” in the white area ---- NO action will take place[/SIZE]
[SIZE=11pt]·         [/SIZE][SIZE=11pt]Press Ctrl & F7 to Open the M1XEP Debug Trace Window[/SIZE]
[SIZE=11pt]·         [/SIZE][SIZE=11pt]From the M1XEP Debug Trace click Select All, click Show Setup, click Resume[/SIZE]
 
Top