Elk RP2 will not connect to M1G


New Member
Hello All,
I am a new member here and as a newbie, I need some help...I seemed to have painted myself in a corner.
I currently have an ELK M1G along with an M1EXP system that was professionally installed and has been working great. I was looking to add the functionality of the M1 Touch pro app and one of the requirements was to update the M1 firmware to 5.3.0 or above.
I had successfully downloaded firmware version 5.3.8 and updated the elk. Elk RP had initially worked which allowed me to push all of the settings from RP2 to the Elk and the M1 system seems to working fine. My issue now is when I opened Elk RP for the second time, it now states that the system has an unrecognized firmware version and to contact the company in the help option, there are no other options. Any help would be very much appreciated and please let me know what other info I may need to provide.
Elk M1G: Firmware 5.3.8
Elk RP2: Version 2.0.24
did you back up the panel before any upgrades? Is the system working otherwise? Have you tried making a new DB and pulling the upgraded panel into RP vs. the existing DB?
Yes, I backed up the existing database and the push to the M1 seemed to work fine as, the alarm is functioning as it was originally. I don't believe I pulled the DB back into RP. What do you suggest the next step is? 
OK, so I was successfully able to create a new DB and receive and send to the M!, but when I go to login to RP again, it comes up with the same firmware error. I also have a control database error where it will not update citing it was not able to open the temporary database and may be a disk drive error.
Export the DB to a thumbdrive and I'd blow out RP and all the related folders, including the hidden ones and do a fresh install of RP....that or try another PC.
I got this error message.  I bypass the XEP and connect my Win 10 PC with ELKRP directly to the serial port using a USB to serial converter.  5.3.8 immediately installed the system returned to normal operation.