• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Evil, port blocking so-and-so's

electron

Administrator
Staff member
you don't even have to go that crazy if your router supports flexible port forwarding. See if you can port forward 3390/tcp to 3389/tcp, so you would connect using using a different port, but nothing on your machine would have to be changed.
 

jrfuda

Active Member
Ahhh, you're a genius!

I suppose I could use the same technique to directly connect with multiple PCs via RDP as well.

Too bad I don't have remote admin enabled on my router, or I'd try it right now!
 

electron

Administrator
Staff member
that's exactly what I do when I want to connect to one of my many machines at home, I just use a different port, but still use the standard port on the actual host.
 

huggy59

Active Member
If you can do port remapping, try putting it at port 443, which is the standard port for SSL encryption between web server and client, but often proxy servers will be configured to allow port 443 uninhibited since it cannot participate in the encryption. Unless they have the proxy server and firewall set to read the protocol (HTTPS headers), you should be able to get right through. The bad part is if you want to run an SSL web server at home, you can't do this.

However, if you are still working for Uncle Sam, you may not want to try to do any of this... I'd certainly not want the security of the Armed Forces compromised! ;-)
 

jrfuda

Active Member
Hmmm,
I've got a Linksys BEFSR41 V3,

I use Port Range Forwarding to take care of my HS WebServer and other apps (including RDP, until today).

It also has "Port Triggering" settings that let you specify a triggered range and forwarded range. I tried this and it didn't work - for example, setup trigger start port 1234 end port 1234 forwarded to start port 3389 end port 3389 and then changed my RDP client to mydomainname:1234

My router also has UPnP forwarding that will forward an external port (1234) using EITHER TCP or UDP to an internal port (3389) at a specific IP (1292.168.x.x). This seemed like the one that would work since it let me specify both an internal port AND IP pair. It did not work either. The help file said DHCP must be turned-off for this feature to work, but I figured that note was put there for people that try to use the feature using ONLY DHCP. I have DHCP enabled, but use static IPs for all my PCs, except for my work laptop I bring home, which I use a dynamic IP on - so leaving DHCP on is a must.

Anyway, maybe my router ain't fancy enough to pull this off, or maybe I'm just doing something wrong.

On a side note: anyone else with this router? Have you ever noticed that, when you save changes, it takes up to 10 minutes sometimes before you can access one of your PCs inside your network from outside your network, although you can do the opposite (access the internet from PCs inside your network) instantly. That's really annoying (although, maybe my SBC-Yahoo DSL is to blame).
 

electron

Administrator
Staff member
A buddy of mine just tried doing the same thing with his linksys, and has the same problem, I do this with my Linux router without any issues, so it's definitely something with the Linksys. Time to do some more experimenting.
 

deranged

Active Member
You can also change the port that RDP listens on.

Microsoft

You must also manually configure any client you are going to use for the new port number also. Kind of a pain, but it works.

StevenE
 

jrfuda

Active Member
I did the registry hack - rather simple actualy, and it apears to be working - from home anyway.

Just remember, f you do this, open the new port on your firewall or you'll be wondering WTF is wrong!

Oh, yea, and reconfigure your port forwarding on your router to reflect the change.

The good thing about this is that I shold be able to assign each PC its own RDP port and be able to acces each directly, instead of accesing the other PCs through my HS server as I've been doing (RDP to my server, and then RDP to theother pCs in my netwrok inside that RDP session)

I'l be testing it from work in a couple of hours.
 
Top