How to change Elk's local programming code?


Active Member
I have tried changing this in the keypad and via ElkRP to no avail... (option 42 under programming/globals)

It seems to accept the new code, but if i exit the menu, let it time out (4 min i think) and then try to access menu 8/9 again, when prompted, i enter the value i put in and it is not accepted. I also try entering the 172839 default to no avail. Using one value kicks me right back to menu nine parent. The other just shows asterics, beeps at me and lets me keep typing more than 6 digits in the display. The only way i know out of it is to change it in elkrp back to default in account details, upload and at least i can continue...

Note that when i downloaded from M1 into ElkRP, the new code i had entered via keypad is downloaded to account details, just doesn't seem to work...

Found something similar, but specific to Elk RP but no solution:

First question is the keypad enrolled? Do a module enrollment in installer programming option 1.

It sounds like the keypad is not responding properly. If not an enrollment problem then make sure the data bus is terminated and wired in a series fashion as explained on page 7... of the M1 manual.

With power off measure the resistance across Data A and Data B on the RS485 data bus. It should read about 65 ohms. 40 or less - too many termination resistor jumpers, 100 or more - too few termination jumpers.

Upgrade to latest software on the ELK Download site. Although I don't know of any problems that would have your symptoms in older software.

Last resort: Default the Globals section of the EEProm using Global 45, enter 87 for globals restore to factory default or download globals from ELKRP.
Well that may go back to this post then (resistance is/was good):

However, all functionality on the keypad from automation to programming works fine (save changing the programming code)... And that's true for both key pads on both sides of the 485 bus.

Anyway, i'll try the spare serial expander and see if the errors on the bus go away or this issue...

Have no idea how i did it, but finally went through tonight...

Only difference that i can think of is that I tried a code with unique digits (prior one had a couple of repeating ones). I still had some hesitation at first, but after disconnecting from elkrp, rebooting the elk, reconnecting with elkrp to insure the programming code was uploaded - i could access the keypads.
The code parser works this way:

Bad example code: User code 5512, installer code 995512

When 4 or more digits are entered from a keypad, the user codes are evaluated first and if no codes match, the 6 digit installer code is checked for a match. In this case 5512 would arm and disarm the system. Since it is a 4 digit user code, only the last four digits entered are compared for the user code match.

Now the installer code is entered, 995512. The user codes are scanned first, checking the last four digits entered and a match is found of 5512. The installer code 995512 is never found because a valid user code was found first.

This will work: User code 5512, installer code 551299.