M1XEP won't send email


I've tried multiple email accounts for both sending and receiving, with authentication, just as I do my regular email. But, when I use a test rule


I never receive an email. I've looked over the FAQs, and it all looks pretty straight forward and correct. I disconnect from the M1XEP, since I am not sure it sends emails while connected, and the connection to the M1XEP is working great.

Is there any way I can tell what is happening? Nothing shows up in the log. I don't even know if it tries to make the attempt. Any way to turn on a diagnostic?
Brad did you port forward port 25 in your router. You are correct you have to ELKRP disconnected for the emails to work.

I have had a few problems with the emails myself a few times. I just got mine working again last week.
I tried Port forwarding 25 (no help), but I don't see why that should be needed -- my desktop computer can do email fine without port forwarding. It does make sense when using the XEP as a web browser to forward port 80 since otherwise the XEP is not seen to the outside world (haven't tested if that works yet).

I'll try using the ip address of the email servers. But, there still should be a better way to diagnose problems than trial and error -- I'd like a diagnostic option where failures are written to the log -- or *something*.
Port forwarding isn't needed in this situation. I recommend using the IP address as well, it takes DNS off the list of possible causes. Most firewalls/routers have logging options, so you could probably use that mechanism to see if it is trying to communicate with the mail server at all (assuming it is internet based).

Only other diagnostics option is to run a sniffer, and either spoof the MAC address to see what's going on (assuming it is a switched environment), or plug your sniffer and XEP into a hub.
You cannot use a web based email server like Hotmail or gmail. It must be an email server like your service providers email.

Some email systems require authentication. In the latest M1XEP setup section of ELKRP there is an area to add email authentication for many email servers.
Here's a suggestion for Elk Products Inc: provide an email host for users of the M1 gold / M1XEP system. It would require serial number to get authorized and would be a forwarding system only (any mail sent to it would be dropped on the floor). That way there would be no hassle trying to set up the email host stuff.
Here's what I did to get my email to work:

1. Updated to the latest firmware for M1XEP - 1.2.8
2. I uses the real IP address for the SMTP server (smtp.att.yahoo.com - port 587 since the default (port 25) has been closed due to spamming issues.

Those two solved my problems and now get email alerts when one of my rules evaluate to true. Hope this helps.