• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Multiple XSP Enrollment (via data hub)

Smarty

Active Member
Folks,
Here is the problem: I am unable to enroll my newly purchased 2nd M1XSP serial expander. I can either enroll my first expander (running the latest Insteon firmware), OR I can enroll the new expander (with 1.0.16 firmware). When I try to have them both connected to the M1 at the same time, the RP software tells me no expanders are connected (or other weird firmware version numbers that don't exist).

Background (hardware set-up): I have a M1G connected to data hub (non-retrofit style). Prior to my new M1XSP serial expander addition; multiple items were run into the data hub and they ALL worked fine. The items were: the keypad, the Insteon M1XSP serial expander, Elk temp sensor, and a zone expansion board.

First thing I double checked was the RJ45 connector. The old one look OK, but I made a new one anyway - same result.

I double checked the wirring connection on the other end of the cable (from the cable to the New M1XSP board). It was OK, and it same as on the Insteon M1XSP board/cable.

Then I doubled checked to make sure the terminating resistor was in the last unused RJ45 socket (it was). To be extra sure, I checked the resistance across data A & B, it was the 66 Ohms I was looking for (for proper data bus termination).

I am confused. Why will each M1XSP work singularly OK, but not when I hook them both to the datahub at the same time? Please help.
 

dlamb

Member
Have you assigned a unique address number to the new M1XSP? This done with the 4-position DIP switch.
 
Top