Networking Problems


I'm having a bit of a problem with my one computers (older one). Its a 1.33 GHZ AMD T-Bird running 500 MB DDR Ram on an Epox EP-8K7a motherboard. I have an older 3Com 3C905 NIC in it and an Nvidia GForce3 graphics card.

I have recently been having problems with the network going dead after a few minutes of browsing on the internet. No status changes in device manager or any other problems which are obvious, just that the connection is dead.

I have a Cable Modem box go into a Linksys Router/Firewall, then a Linksys Hub, then (in the den because I ran out of connections) another GigaFast Ethernet Switch where my Homeseer computer and this computer reside as well as a printer network adapter.

I only have a problem with this one computer (and not the Homeseer computer or printer).

I ran Spybot, Adaware, as well as scanned for viruses with Norton AV (all with latest updates). I also have all of the latest updates as all my machines run Windows XP (Professional).

I tried reloading the drivers for the network card (even though nothing showed odd in Device Manager). I also tried throttling the connection down to 10 MB full duplex (from its "Auto" setting).

I also run a fixed IP on this computer and nothing has changed other than windows updates.

I first though network card, but wouldn't I have the trouble all the time if this was the case?

I am running out of ideas so I'm asking for help from our membership! ;)

Thanks in advance for any ideas and suggestions.

BraveSirRobbin said:
I have recently been having problems with the network going dead after a few minutes of browsing on the internet.
Does all network connectivity fail or just external web surfing? This sounds a lot like a problem Gordon was/is having, make sure you link up with him.
wow, I am wondering what is going on, this is the 3rd person having this problem. Gordon figured out the fix, it involved the netsh command, but he will have to post the details on that one.
I had a machine that was exibiting the exact same problem. Turned out the network card was going bad as I replaced the card with one of those wireless b cards and haven't had a single problem since.
I'm in agreement with Rupp. Sounds like the card is going south. Give the card a good sweep with the vacuum cleaner to make sure it's not overheating. If possible, hit it with some "canned air" next time it glitches, and see if it starts working again.

Worst case, swap out the card. With the exception of server quality cards, most NICs are ridiculously inexpensive now.
electron said:
wow, I am wondering what is going on, this is the 3rd person having this problem. Gordon figured out the fix, it involved the netsh command, but he will have to post the details on that one.
As usual seems like I'm the last to know what is going on. What problem has Gordon figured out? Is there a link to another site. I do have his Email, perhaps I could give him a shout.

Thanks to all else who gave suggestions. I will grab a new NIC next time I'm out at Fry's.

BTW: Wayne, all networking fails.
Gordon had the exact same problem, and until he told me he was able to fix it, I would always recommend to replace the nic first, I learn something new every day, that's for sure.

As for the fix it self, it's a 'hidden' command in XP, I never heard of it myself until he figured it out, so he will have to post the parameters he used to fix this. But I do recommend getting a backup nic, in case a card really does go bad (or if this one is bad after all).
I think we are seeing the results of either a change under XP Sp2 in combination with a security patch, or a simple security patch that has somehow corrupted the network stack and related programs. The symptoms I experienced are:

- after some variable period, I could no longer surf the Internet
- could no longer ping Internet sites
- local network systems and sites worked fine
- only some protocols/utilities were affected - I could still use tracert to Inet sites, for example
- connections that were already established before the "event" that shut down the Inet connectivity were fine, such as open IRC connections - after the event, these same connections could not be established
- little or no errors in any logs of any kind that made any sense
- sometimes, but not always, I would see several "mrxsmb redirector failed to determine the connection type" errors in the Event Viewer, but I don't know if thiese were related, either

After a lot of investigation and researching so-called MS "error codes", I finally stumbled across a little-known utility in XP Pro SP2 (and 2003 Server, I believe) that allows reading, setting, and RESETTING registry entries surrounding the networking stacks. In my case, I believe the problem was a corrupted Winsock or Winsock2 subsystem.

Here's what finally fixed it for me:

netsh int ip reset <logfile>
netsh winsock show catalog > <myfile>
netsh winsock reset

The first command resets the TCP./IP stack to a clean state. The <logfile> is required and shows the changes made by the reset.

The second command saves a copy of the current winsock catalog (settings).

The third command resets the winsock component settings to a clean state.

I have not yet run into any problems after having done this, however, if you use VPN or other software that may modify or wedge into the networking stack, that software may have to be reinstalled after this.

Finally, judicious use of the command format:

netsh ?
netsh int ip ?

etc. may show you a lot more about the networking and firewalling component settings of your system than you can see with the traditional Control Panel applets. It looks like a quite extensive set of commands to display, troubleshoot, repair and reset the various networking and security components within XP and 2003 Svr. As a network, AD, and server admin, I'm going to learn more about this utility.

Other utils I found that weren't previously known about included GPRESULT and SC QUERY. I urge anyone wanting to learn more about networking and security on their XP machines to look into these utils. They are included in XP SP2, I believe.
Wow, may I say, I am impressed huggy!! That seems to have fixed my problem! I was on all evening and no problems.

You know after reading your explanation I'm wondering about something. I did uninstall some VPN stuff recently (got rid of work stuff on this machine). Wonder if that messed up the stack when I did that?!?!
Thanks again for this fix. Fantastic help!! ;)

Again, regards and thanks,

It's entirely possible. With more and more "security" being built in, there are more possible problems with interaction or interference between other software packages that do their own "security", and one of those is VPN software. That's why, in many cases, multiple manufacturers' VPN packages can't co-exist on the same machine. Sort of like trying to have two anti-virus packages running. They sometimes "fight" each other, and the loser is you and your machine! hehe

I had a VPN package installed here some time ago, but it was removed way back as well. I suppose it could have left some remnants in the system that triggered my problems as well.