Using Amazon Alexa devices (Echo, Dot, Tap, etc.) with HAI

dwpaddack

Member
My Mac mini is currently runing the El Capitan OS. Has anyone successfully updated? I tried a few years ago, but Alexa stopped working.
 

heffneil

Active Member
Hey all! Dredging up dead topics but yesterday I tried to turn on a device and I was told "there are multiple devices with that name" there aren't so I am at a total loss?  Anyone have any ideas?  I didn't change anything?  I guess I need to delete all the devices and re-discover?  Don't know how to delete them in bulk if possible....
 
Thanks,
 
Neil
 

heffneil

Active Member
Ok so there ARE two of every device in there now :( . I don't know 1. How it happened or 2. How it is possible?  I guess amazon isn't smart enough to weed out the identical copies?  Maybe one of the kids did a rediscovery but still seems like they shouldn't duplicate?  Now I just need to figure out a bulk way to wipe them out.
 

heffneil

Active Member
Don't know if anyone is still on here using this?  In the past two days for some reason - my Alexa is saying it can't communicate with any of my devices.  I have removed all, discovered - 2 times now - and still doesn't work.  Also I rebooted my haiku helper server.  I can reach the HA Bridge site and control devices so there is some broken connection between the Alex / Service and my HA Bridge server...
 
Any one have suggest or ideas?
 
Thanks!
 
Neil
 

pete_c

Guru
Unrelated to the HAI bridge here have been tinkering with HUE emulation on my Espurna / Tasmota firmware updated WiFi devices and noticed a few weeks back that I am seeing two of each device.  I have something about changes in the undocumented Amazon Alexa apps.
 
The doubles are showing up as
 
Royal Philips Electronics smart device
 
I delete them and they keep coming back.
 

heffneil

Active Member
I went to the github for the HA-Bridge and people said that it is a known issue with Amazon somehow.  I had to change the port to 80 but in order to work with Haiku Helper I had to move my apache page to a different port.  A little juggling but for now things work.
 
I had repeating devices - deleted them and re-added and have been lucky ever since.
 

pete_c

Guru
Yes here using the Home Assistant HUE emulation / bridge and MQTT and the OmniLinkBridge and testing OmniPro 2 Alexa TTS for the OmniPro 2 panel which works well.  (also now off I was using the Smartthings Alexa connection to the OmniPro 2 panel).
 
Doing the automation in Ubuntu Linux (running HS3, HA, Mosquitto server, Node Red) on a very tiny Intel box (a TV Box) on a 64Gb eMMC, Gb, Wireless and Bluetooth. (~10 watts).
 
 
 
Unrelated here have switched off Windows now for any automation.  I still have a Windows 2016 server running for some Windows tools. 
 
Top