• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Homebridge Plugin for Omni-Link II

@Mantorok
 
I attached the logs. In this case I tried turning on the kitchen lights. It's encouraging to be able to see the state of the lights atleast. Thank you.
 
-highlyauto
 

Attachments

  • homebridge.log.txt
    23.2 KB · Views: 4

mantorok

Member
I see you're getting quite a number of TCP connection errors. This is what I think is happening but could be wrong:
 
When the plugin attempts to request the status of the zones the Omni controller generates a fault and restarts. This will drop the connection to the plugin. The plugin detects that the connection has been dropped and attempts to reconnect. When this happens the plugin will try to refresh the status of the zones again which then generates another fault on the controller and the process starts again.
 
I think this is why you're not able to set the bulbs on/off as the controller is not able to accept commands in the faulty/restarting state.
 
Unfortunately you're going to have to sort that faulty zone out before you can get any further with the plugin.
 
Thanks anyways for the help. I downloaded the pc access software. However, it looks like I need the account file to edit my setup which I don't have since I inherited this system. I could start from scratch which is pretty overwhelming. 
 

mantorok

Member
I had a bit of trouble getting PC Access up and running at first but its not that hard when you get the hang of it. You first create the account file and then connect to the Omni controller which should load your config into that account file. I think the rough steps were:
 
1. Start PC Access and login using the default password: PASSWORD
2. Create a new account file and save
3. Select your model and language on the popup
4. Select Options > Network in menu
5. Enter your the Omni's IP address and keys
6. Select Communications > Network in menu to connect
 
Thanks for the encouragement. I was able to load the configuration into the account file which was great because I thought I was going to need to recreate everything without the original account file. I removed the thermostats from the setup and double checked that they don't show up in the controller after I uploaded the new setup though they do still show up on snaplink. Unfortunately the issue remains so I'll continue troubleshooting. I noticed that zone 59 (the first one to time out if I understand the log correctly) corresponds to my back door which is working fine in that it shows ready/not ready on the controller as expected. It is the last zone though. There's zones 60-64 listed in pc access but they seem to be just dummy zones. 
 
The other thing I noticed, which I'm not sure if it's been happening this whole time, is that the controller is showing "Fuse Trbl Now"
 

mantorok

Member
In the SnapLink app did you go into settings and "Retrieve Setup" again? This will sync the app with the current config of the Omni
 
Likewise for the plugin you'll need to set forceAutoDiscovery to true and restart so that the plugin can retrieve the latest config.
 
BTW, its not necessarily zone 59 that is timing out. The plugin requests the status of all zones between 1 and 59 in a single request so it could be any one in that range that is the problem.
 
Not sure about that fuse issue. I've not seen that before
 
I had done the retrieve setup in snaplink. I hadn't done the force autodiscovery to true, but doing so didn't help. I noticed that the plug-in returns the thermostats in the list but [NotUsed]. I thought changing them from heat/cool to Not Used and then removing them from the "rooms" would remove the zone but but maybe I'm missing a step.
 
[08/08/2021, 23:03:47] [Omni] Thermostats found: 2
[08/08/2021, 23:03:47] [Omni]     1: TSTAT Down        [NotUsed]
[08/08/2021, 23:03:47] [Omni]     2: TSTAT Up          [NotUsed]
 
 
would you say the other 4 time outs are also zones? does the sequence before the last number field give me a clue as to what is failing?
 
[08/08/2021, 23:04:08] [Omni] Request: 33,6,58,1,0,1,0,59
[08/08/2021, 23:04:18] [Omni] Request timed out [33,6,58,8,0,15,0,15]
[08/08/2021, 23:04:18] [Omni] Request timed out [33,6,58,1,0,1,0,59]
[08/08/2021, 23:04:18] [Omni] Request: 33,6,58,2,0,1,1,129
[08/08/2021, 23:04:28] [Omni] Request timed out [33,6,58,2,0,1,1,129]
[08/08/2021, 23:04:28] [Omni] Request: 33,6,58,6,0,1,0,2
[08/08/2021, 23:04:38] [Omni] Request timed out [33,6,58,6,0,1,0,2]
[08/08/2021, 23:04:38] [Omni] Request: 33,6,58,8,0,15,0,15
 

mantorok

Member
One thing you can try is remove the name of the thermostats. The plugin ignores objects that have no name (with the exception of Areas).
 
If I had to guess which zone is causing the issue I'd say it was zone 15 as it's related to the thermostats. Again you could try removing it's name.
 
As for the timeouts I think it's only the first one that matters. All subsequent ones will most likely be caused by the controller restarting (or whatever its doing).
 
I was able to remove the thermostats so they don't show up on snaplink or in the plug in discovery. I removed Zone 15 by naming it "ZONE 15" and make it type auxiliary instead of temperature sensor and that seems to ignore it. I also removed a button that has never worked. I attached the log. Only thing I can think of is to troubleshoot that fuse trbl now message. I saw a post on this topic in this forum. 
 
Thanks
 
-highlyauto
 

Attachments

  • homebridge.log.txt
    147.8 KB · Views: 1

mantorok

Member
Hi @highlyAuto,
 
I had another idea that may help you use the plugin if you don't mind having no zones. In the homebridge folder there will be a subfolder named OmniLinkPlatform and it contains a file named Omni.json. In that file you should see something like:

...,"zones":[...],...

Can you edit this file and remove all the numbers inside the brackets for zones and save. So it should look like this:

...,"zones":[],...

 
This should prevent the plugin from trying to get the status of the zones (and causing the time outs).
 
NOTE: Make sure you set forceAutoDiscovery to false before you do this.
 
@ Mantorok,
 
Thanks for the tip. I can now turn my lights on and off with homekit which is awesome. Could I edit that zones list to isolate one zone at a time to figure out which zone is causing the issue? like add one at a time until i get the time outs? 
 
@highlyauto
 

mantorok

Member
That's great news.
 
I was going to suggest if that works then you can add the zones back one (or a few) as a time to try to determine which zone is causing the issue.  Just start with the lowest number and add them in order as the plugin will request the status of the zones between the lowest and highest.
 
Once you think you've found it then try having just that number inside the brackets to confirm its that one.
 
Let me know how it goes.
 
Top