RCS TR40 DOA or user error?


Active Member
So I finally got up the guts and the time to try installing the TR40 that's been sitting in my closet for the last few months. I was particularly sensitive about screwing something up and leaving my family without heat so I actually read and re-read the instructions several times before even starting. I was very careful to wire up everything exactly as the directions said, but when I powered up the HVAC unit the WDU was blank. The backlight was on, but there was absolutely nothing on the screen, and none of the LEDs were lit. The status light on the control unit was blinking slowly. I shut everything down, rechecked my wiring, and powered up again. Still nothing on the WDU except for the backlight, but now the status light on the control unit just stays lit.

Any ideas whats going on here?


I recently installed a TR16 and had no problems.

I would say that the power to the WDU is correct as you have power to the back light, but you might have reversed the clock and data lines at either the WDU or the controller.

I would check to make sure that the clock and data lines are correct before doing anything else.

The status light on the control unit should blink slowly if the control unit is functioning correctly. The fact that the WDU is not working correctly may be the cause of the control unit status light not blinking anymore.

I suggest that you go to the RCS website and look at the TR40 installation manual online and see if it differs from what you received with the unit. I found that I had to switch back and forth between the website manual and the delivered one.

Also, unlike earlier versions of the TR16/40, the control unit is no longer powered by an external power supply (wall wart) and uses 24v AC from the HVAC unit. Is that the way that you have your controller hooked up?

Hope this helps.

Thanks TCIII, I did try reversing the clock and data lines but the WDU remained blank with just the backlight on, and I did follow the online instruction guide, and I did also power the control unit from the HVAC (common + return).

Any other ideas?

Have you tried adjusting the contrast control on the WDU? Look for a small rotary control on the back of the WDU board (you have to remove it from the base first). Remember its initial position and then try it in several different positions (plugging it back in the base every time) to see if it displays anything.
I finally got some time to take a look at this again, and after wiring everything up again I'm still getting the same results -- control unit status light remains lit (not blinking) and WDU LCD backlight turns on but nothing is displayed on it and none of the LEDs are lit up.

I don't have the heat or fan wires connected since the manual states it should be bench tested with just power (common & return) first. Could that be why the status LED on the control unit is on and not blinking? Still doesn't explain why the WDU is not working...

Also, I can't find any contrast control on the WDU. Maybe I have a different version? Or do I have the wrong WDU? Mine says TS40 Rev D. Here's what it looks like:


I really hope I can get this working since it's been over half a year since I bought the unit from Martin. Anyone have any other ideas?

Just want to say thanks to Automated Outlet and RCS for their great support. They ended up taking the unit back under warranty and sent a replacement w/in just a few days. I've got the new unit up and running and connected to my Elk and everything is looking great so far.

:lol: :) :)