• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Remote Desktop and speech problems

jwaldo1301

New Member
Hello all :D

Anyone know why I cannot get HS Phone to announce CID unless I am logged in with Remote Desktop? The server is in the basement and does not have a monitor or keyboard so all interaction is through Remote Desktop. I have my sound card selected as the sound device. When I am in a session the sounds are "left at remote".


Please help :D
 

electron

Administrator
Staff member
So you are saying that the system will only announce it when logged in with Remote Desktop? I would switch to VNC, since it won't screw around with your sound output, and also try a reboot after you installed VNC.
 

jwilson56

Senior Member
This is a known problem with RD. The problem is that when you log off RD you leave the other system with no one logged in. There is a simple script that you can run with an icon to log off the RD and log in the console but I would have to look for it. I would also suggest you run RealVNC like Electron suggested. I switched to it myself.

John
 

electron

Administrator
Staff member
I wrote that script, but I thought the usual RD problem was the the sound was disabled while someone was logged in with remote desktop (the opposite of this situation).
 

jwilson56

Senior Member
That was another problem.... but if you log off RD and the console is not logged back on the sound will just stop working.... used that script to solve that problem....

John
 

jwaldo1301

New Member
Hey Everyone :D

Thanks for fast replies. I guess I didn't realize that despite having auto-logon, when I disconnected, all users are then logged off. I already have VNC running and will try it. Thanks for great info.

Cheers :D
 

sbessel

Active Member
Actually Remote Desktop does not log out the user unless you select that option. You can choose just to disconnect.

The sound issue is a known bug, I use Remote Desktop on my HS boxes with zero issues, and over the internet without issues as well.

I have an icon placed on my desktop named 'Disconnect Remote' it is just this shortcut "%windir%\System32\tscon.exe 0 /dest:console" I double-click and it disconnects me and keeps the sound working perfectly. I only use that to disconnect and everything stays working.
 

jwaldo1301

New Member
Thanks sbessel and electron, and all who have replied. I have expanded my knowledge. Best of all I solved my problem!!!

You guys rock!
 
Top